HDU 5024 Wang Xifeng's Little Plot (搜索)

Wang Xifeng‘s Little Plot

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 157    Accepted Submission(s): 105

Problem Description

《Dream of the Red Chamber》(also 《The Story of the Stone》) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. This novel was created in Qing Dynasty, by Cao Xueqin. But the
last 40 chapters of the original version is missing, and that part of current version was written by Gao E. There is a heart breaking story saying that after Cao Xueqin died, Cao‘s wife burned the last 40 chapter manuscript for heating because she was desperately
poor. This story was proved a rumor a couple of days ago because someone found several pages of the original last 40 chapters written by Cao.

In the novel, Wang Xifeng was in charge of Da Guan Yuan, where people of Jia family lived. It was mentioned in the newly recovered pages that Wang Xifeng used to arrange rooms for Jia Baoyu, Lin Daiyu, Xue Baochai and other teenagers. Because Jia Baoyu was
the most important inheritor of Jia family, and Xue Baochai was beautiful and very capable , Wang Xifeng didn‘t want Jia Baoyu to marry Xue Baochai, in case that Xue Baochai might take her place. So, Wang Xifeng wanted Baoyu‘s room and Baochai‘s room to be
located at two ends of a road, and this road should be as long as possible. But Baoyu was very bad at directions, and he demanded that there could be at most one turn along the road from his room to Baochai‘s room, and if there was a turn, that turn must be
ninety degree. There is a map of Da Guan Yuan in the novel, and redists (In China English, one whose job is studying 《Dream of the Red Chamber》is call a "redist") are always arguing about the location of Baoyu‘s room and Baochai‘s room. Now you can solve this
big problem and then become a great redist.

Input

The map of Da Guan Yuan is represented by a matrix of characters ‘.‘ and ‘#‘. A ‘.‘ stands for a part of road, and a ‘#‘ stands for other things which one cannot step onto. When standing on a ‘.‘, one can go to adjacent ‘.‘s through
8 directions: north, north-west, west, south-west, south, south-east,east and north-east.

There are several test cases.

For each case, the first line is an integer N(0<N<=100) ,meaning the map is a N × N matrix.

Then the N × N matrix follows.

The input ends with N = 0.

Output

For each test case, print the maximum length of the road which Wang Xifeng could find to locate Baoyu and Baochai‘s rooms. A road‘s length is the number of ‘.‘s it includes. It‘s guaranteed that for any test case, the maximum length
is at least 2.

Sample Input

3
#.#
##.
..#
3
...
##.
..#
3
...
###
..#
3
...
##.
...
0

Sample Output

3
4
3
5

题意:

图上有 ‘ . ’ 和 ‘ # ’,其中在 ‘ . ’ 上面可以走动,但有规定:只能朝相邻的8个方向走动,且只能拐一次弯,弯的大小要求恰好为90度。其中 ‘ # ’ 为墙不能走到上面去。求符合以上要求的距离最远的两个点的距离。

其中样例一的解法:(0,1)-> (1,2) -> (2,1)

思路:

以符合要求的点为拐弯点,朝两个垂直的方向走,求出最远的距离。

方向如下图所示:

/************************************************************************
	> File Name: 1003.cpp
	> Author: Bslin
	> Mail: [email protected]
	> Created Time: 2014年09月20日 星期六 12时43分13秒
 ************************************************************************/

#include <stdio.h>

char map[110][110];
int dir[8][2] = {{0, -1}, {-1, -1}, {-1, 0}, {-1, 1}, {0, 1}, {1, 1}, {1, 0}, {1, -1}};
int n;

bool inmap(int x, int y) {
	if(x >= 0 && x < n && y >= 0 && y < n)
		return true;
	return false;
}

int togo(int x, int y, int d1, int d2) {
	int nowx, nowy, res;
	res = 1;
	nowx = x + dir[d1][0];
	nowy = y + dir[d1][1];
	while(inmap(nowx, nowy) && map[nowx][nowy] == '.') {
		nowx = nowx + dir[d1][0];
		nowy = nowy + dir[d1][1];
		res ++;
	}
	nowx = x + dir[d2][0];
	nowy = y + dir[d2][1];
	while(inmap(nowx, nowy) && map[nowx][nowy] == '.') {
		nowx = nowx + dir[d2][0];
		nowy = nowy + dir[d2][1];
		res ++;
	}
	return res;
}

int dfs(int x, int y) {
	int res, tmp;
	res = 0;
	// 0: l  1: lu  2: u  3: ru  4: r  5: rd  6: d  7: ld
	tmp = togo(x, y, 0, 2);
	if(tmp > res) res = tmp;
	tmp = togo(x, y, 0, 6);
	if(tmp > res) res = tmp;
	tmp = togo(x, y, 4, 2);
	if(tmp > res) res = tmp;
	tmp = togo(x, y, 4, 6);
	if(tmp > res) res = tmp;
	tmp = togo(x, y, 1, 3);
	if(tmp > res) res = tmp;
	tmp = togo(x, y, 1, 7);
	if(tmp > res) res = tmp;
	tmp = togo(x, y, 5, 3);
	if(tmp > res) res = tmp;
	tmp = togo(x, y, 5, 7);
	if(tmp > res) res = tmp;
	return res;
}

int main(int argc, char *argv[]) {
#ifndef ONLINE_JUDGE
	freopen("in", "r", stdin);
#endif
	int i, j;
	int ans, tmp;
	while(~scanf("%d", &n), n) {
		for (i = 0; i < n; ++i) {
			scanf("%s", map[i]);
		}
		ans = 0;
		for (i = 0; i < n; ++i) {
			for (j = 0; j < n; ++j) {
				if(map[i][j] == '.') {
					tmp = dfs(i, j);
					if(tmp > ans) ans = tmp;
				}
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}

HDU 5024 Wang Xifeng's Little Plot (搜索)

时间: 2024-11-08 20:08:37

HDU 5024 Wang Xifeng's Little Plot (搜索)的相关文章

HDU 5024 Wang Xifeng&#39;s Little Plot (枚举 + DFS记忆化搜索)

Wang Xifeng's Little Plot Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 513    Accepted Submission(s): 338 Problem Description <Dream of the Red Chamber>(also <The Story of the Stone>)

hdu 5024 Wang Xifeng&#39;s Little Plot【暴力dfs,剪枝】

2014年广州网络赛的C题,也是水题.要你在一个地图中找出一条最长的路,这条路要保证最多只能有一个拐角,且只能为90度 我们直接用深搜,枚举每个起点,每个方向进行dfs,再加上剪枝. 但是如果直接写的话,那一定会特别麻烦,再加上方向这一属性也是我们需要考虑的方面,我们将从别的地方到当前点的方向编一个号:往右为0,如下图顺时针顺序编号 (往右下方向为1,往下为2......以此类推) 我们知道了当前点的坐标,来到当前点的方向,以及到目前有没有拐弯,这几个属性之后,就可以记忆化搜索了,用一个四维数组

HDU - 5024 Wang Xifeng&#39;s Little Plot

Problem Description <Dream of the Red Chamber>(also <The Story of the Stone>) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. This novel was created in Qing Dynasty, by Cao Xueqin.

HDU 5024 Wang Xifeng&#39;s Little Plot(广州网络赛C题)

HDU 5024 Wang Xifeng's Little Plot 题目链接 思路:先利用记忆化搜索预处理出每个结点对应8个方向最远能走多远,然后枚举拐点记录最大值即可 代码: #include <cstdio> #include <cstring> #include <algorithm> using namespace std; const int d[8][2] = {{-1, 0}, {0, 1}, {1, 0}, {0, -1}, {-1, 1}, {1,

HDU 5024 Wang Xifeng&#39;s Little Plot (DP)

题意:给定一个n*m的矩阵,#表示不能走,.表示能走,让你求出最长的一条路,并且最多拐弯一次且为90度. 析:DP,dp[i][j][k][d] 表示当前在(i, j)位置,第 k 个方向,转了 d 次变的最多次数,然后用记忆化搜索就好. 代码如下: #pragma comment(linker, "/STACK:1024000000,1024000000") #include <cstdio> #include <string> #include <cs

hdu 5024 Wang Xifeng&#39;s Little Plot (dfs+暴力)

Wang Xifeng's Little Plot Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 194    Accepted Submission(s): 131 Problem Description <Dream of the Red Chamber>(also <The Story of the Stone>)

HDU 5024 Wang Xifeng&#39;s Little Plot(2014广州网络赛1003)

写了1h的DFS,简直被自己的代码吓哭了..不过起码还是思路清晰,QUQ~ 说一下题意吧: 题意是求一条最长路,最多能经过一次转弯,并且其角度只能为90度. 拿第一个样例来说:(0,1)->(1,2)->[转弯](2,1) ,所以答案是3. 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5024 代码如下: #include<iostream> #include<cstdio> #include<cstring>

HDU 5024 Wang Xifeng&#39;s Little Plot(暴力枚举+瞎搞)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5024 Problem Description <Dream of the Red Chamber>(also <The Story of the Stone>) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. Thi

[ACM] HDU 5024 Wang Xifeng&#39;s Little Plot (构造,枚举)

Wang Xifeng's Little Plot Problem Description <Dream of the Red Chamber>(also <The Story of the Stone>) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. This novel was created in Qin