分支-12. 计算火车执行时间(15)

本题要求依据火车的出发时间和达到时间,编敲代码计算整个旅途所用的时间。

输入格式:

输入在一行中给出2个4位正整数,其间以空格分隔,分别表示火车的出发时间和到达时间。每一个时间的格式为2位小时数(00-23)和2位分钟数(00-59),如果出发和到达在同一天内。

输出格式:

在一行输出该旅途所用的时间,格式为“hh:mm”,当中hh为2位小时数、mm为2位分钟数。

输入例子:

1201 1530

输出例子:

03:29
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		int a = cin.nextInt();
		int b = cin.nextInt();
		int c = b - a;
		if (b % 100 < a % 100) {
			System.out.printf("%02d:%02d", c / 100, c % 100 - 40);
		} else {
			System.out.printf("%02d:%02d", c / 100, c % 100);
		}
	}
}
时间: 2024-10-05 20:17:52

分支-12. 计算火车执行时间(15)的相关文章

分支-12. 计算火车运行时间(15)

#include<iostream>#include<iomanip>using namespace std;int main(){    int s,e;    cin>>s>>e;    cout<<setfill('0');    if(e%100>=s%100)        cout<<setw(2)<<e/100-s/100<<":"<<setw(2)<&

*分支-12. 计算火车运行时间

1 /* 2 * Main.c 3 * B12-分支-12. 计算火车运行时间 4 * Created on: 2014年6月4日 5 * Author: Boomkeeper 6 * 7 ********测试未通过******* 8 */ 9 #include <stdio.h> 10 #include <stdlib.h> 11 12 int startTime,arrTime; 13 int *p_startTime=&startTime; 14 int *p_arr

分支-11. 计算工资(15)

1 /* 2 *c语言实现 3 *B11-分支-11. 计算工资(15) 4 *Created on: 2014年6月3日 5 *Author: Boomkeeper 6 *未全部通过 7 * 8 */ 9 10 #include <stdio.h> 11 #include <stdlib.h> 12 13 float salary=0; 14 15 void newStaff(int *worktime) 16 { 17 if(*worktime<=40) 18 { 19

分支-13. 计算天数(15)

本题要求编写程序计算某年某月某日是该年中的第几天. 输入格式: 输入在一行中按照格式"yyyy/mm/dd"(即"年/月/日")给出日期.注意:闰年的判别条件是该年年份能被4整除但不能被100整除.或者能被400整除.闰年的2月有29天. 输出格式: 在一行输出日期是该年中的第几天. 输入样例1: 2009/03/02 输出样例1: 61 输入样例2: 2000/03/02 输出样例2: 62 import java.util.Scanner; public cla

*分支-13. 计算天数

1 /* 2 * Main.c 3 * B13-分支-13. 计算天数 4 * Created on: 2014年6月12日 5 * Author: Boomkeeper 6 * 7 ******测试又是木有完全通过啊********* 8 */ 9 10 #include <stdio.h> 11 #include <stdlib.h> 12 13 #define JANUARY 31 14 #define FEBRUARY 28 15 #define MARCH 31 16 #

*分支-11. 计算工资

1 /* 2 *Main.c 3 *B11-分支-11. 计算工资(15) 4 *Created on: 2014年6月3日 5 *Author: Boomkeeper 6 * 7 ******测试未通过********* 8 */ 9 10 #include <stdio.h> 11 #include <stdlib.h> 12 13 float salary=0; 14 15 void newStaff(int *worktime) 16 { 17 //printf("

分支-10. 计算个人所得税

1 /* 2 * Main.c 3 * B10-分支-10. 计算个人所得税(10) 4 * Created on: 2014年5月29日 5 * Author: Boomkeeper 6 * 7 * 测试通过 8 */ 9 10 11 #include <stdio.h> 12 #include <stdlib.h> 13 14 int main() 15 { 16 float salary=0; 17 float *ps=&salary; 18 19 scanf(&qu

分支-10. 计算个人所得税(10)

#include<iostream>#include<iomanip>using namespace std;int main(){    float x;    cin>>x;    cout<<setiosflags(ios::fixed)<<setprecision(2);    if(x<=1600)        cout<<0.00<<endl;    else if(x<=2500)      

分支-08. 高速公路超速处罚(15)

#include<iostream>using namespace std;int main(){    int speed,limit,ex;    cin>>speed>>limit;    ex=100.0*(speed-limit)/limit+0.5;    if(ex<10)        cout<<"OK"<<endl;    else if(ex<50)        cout<<&q