poj 2485(prim最小生成树)

Highways

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They‘re planning to build some highways so that it will be possible
to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town
that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed.

The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between
village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

Hint

Huge input,scanf is recommended.

Source

POJ Contest,Author:[email protected]

求最小生成树的最长边

AC代码:

#include<iostream>
using namespace std;
int G[505][505];
int n;
void prim(){
    int vis[505];
    int dis[505];
    int ans=0;
    for(int i=1;i<=n;i++){
        vis[i]=0;
        dis[i]=999999;
    }
    dis[1]=0;
    for(int i=1;i<=n;i++){
        int v,min=999999;
        for(int j=1;j<=n;j++){
            if(!vis[j] && min>dis[j]){
                min=dis[j];
                v=j;
            }
        }
        vis[v]=1;
        if(ans<min)
            ans=min;
        for(int j=1;j<=n;j++){
            if(!vis[j] && G[v][j] && G[v][j]<dis[j])
                dis[j]=G[v][j];
        }
    }
    cout<<ans<<endl;
}
int main(){
    int T; cin>>T;
    while(T--){
        cin>>n;
        if(n<3 || n>500)
            continue;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                cin>>G[i][j];
        prim();
    }
    return 0;
}

poj 2485(prim最小生成树)

时间: 2024-10-11 22:51:53

poj 2485(prim最小生成树)的相关文章

POJ 2485 Highways (最小生成树prim)

题目大意:    有一个岛国,没有高速公路,交通非常困难.政府意识到了这一问题,他们计划建造一些高速公路,这样可以使任何一对城镇都不离开公路系统.所有公路都是沿直线建造并且是双向的.政府想降低花费,所以想找到一种建造方案,能连接所有的城镇,并且公路的总长度最小.注意题目求的是最小生成树最长的那条边. #include <cstdio> #include <cstring> #include <algorithm> #define N 600 #define INF 0x

POJ 2485 Highways(最小生成树+ 输出该最小生成树里的最长的边权)

Highways Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 23426   Accepted: 10829 Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Fl

poj 2485 Prim裸

Highways Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 34492   Accepted: 15570 Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Fl

POJ 2485 Highways 最小生成树 (Kruskal)

Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that i

Highways - poj 2485 (Prim 算法)

Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 24383   Accepted: 11243 Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian g

poj 2485 求最小生成树中 最大的一个权值

Sample Input 1 //T 3 //n0 990 692 //邻接矩阵990 0 179692 179 0Sample Output 692 prim 1 # include <iostream> 2 # include <cstdio> 3 # include <cstring> 4 # include <algorithm> 5 # include <cmath> 6 # define LL long long 7 using na

POJ 2485 Prim 找最长的边

A国没有高速公路,因此A国的交通很困难.政府意识到了这个问题并且计划建造一些高速公路,以至于可以在不离开高速公路的情况下在任意两座城镇之间行驶. A国的城镇编号为1到N, 每条高速公路连接这两个城镇,所有高速公路都可以在两个方向上使用.高速公路可以自由的相互交叉. A国政府希望尽量减少最长高速公路的建设时间(使建设的最长的高速公路最短),但是他们要保证每个城镇都可以通过高速公路到达任意一座城镇. Input 第一个输入的数字T,代表着T组样例. 接下来输入一个N, 代表一共有N个城镇. 然后读入

poj 2485 Highways (最小生成树)

链接:poj 2485 题意:输入n个城镇相互之间的距离,输出将n个城镇连通费用最小的方案中修的最长的路的长度 这个也是最小生成树的题,仅仅只是要求的不是最小价值,而是最小生成树中的最大权值.仅仅须要加个推断 比較最小生成树每条边的大小即可 kruskal算法 #include<cstdio> #include<algorithm> using namespace std; int f[510],n,m; struct stu { int a,b,c; }t[20100]; int

poj 2485 Highways(最小生成树)

题目链接:http://poj.org/problem?id=2485 Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're plann