IPSec transport mode配置

R1
Router>enable                                         
Router#configure terminal
Router(config)#hostname R1                             
R1(config)#no ip domain-lookup                         
R1(config)#service timestamps debug datetime localtime
R1(config)#service timestamps log  datetime localtime
R1(config)#interface f0/1                        
R1(config-if)#ip address 10.1.1.1 255.255.255.0      
R1(config-if)#no shutdown                     
R1(config-if)#exit                                 
R1(config)#interface f0/0                   
R1(config-if)#ip address 12.1.1.1 255.255.255.0         
R1(config-if)#no shutdown  
R1(config-if)#exit      
R1(config)#interface loop0                   
R1(config-if)#ip address 1.1.1.1 255.255.255.0         
R1(config-if)#no shutdown  
R1(config-if)#exit                       
R1(config)#ip route 0.0.0.0 0.0.0.0 12.1.1.2

R1(config)#interface tunnel10                 
R1(config-if)#tunnel source 12.1.1.1
R1(config-if)#tunnel destination 23.1.1.3   
R1(config-if)# ip address 172.16.1.1 255.255.255.0
R1(config-if)#tunnel mode gre ip  
R1(config-if)#no shutdown

R1(config)#ip route 192.168.1.0 255.255.255.0 tunnel10

R1(config)#crypto isakmp policy 10  
R1(config-isakmp)#authentication pre-share
R1(config-isakmp)#encryption des
R1(config-isakmp)#group 2
R1(config-isakmp)#hash md5
R1(config-isakmp)#exit
R1(config)#crypto isakmp key 6 cisco address 23.1.1.3 255.255.255.0

R1(config)#crypto ipsec transform-set cisco esp-des esp-md5-hmac  
R1(cfg-crypto-trans)#mode tunnel
R1(cfg-crypto-trans)#exit

R1(config)#ip access-list extended interested     
R1(config-ext-nacl)#permit gre host 12.1.1.1 host 23.1.1.3
R1(config-ext-nacl)#exit

R1(config)#crypto map IPSecvpn 10 ipsec-isakmp    
R1(config-crypto-map)#set peer 23.1.1.3
R1(config-crypto-map)#set transform-set cisco
R1(config-crypto-map)#match address interested  
R1(config-crypto-map)#exit
R1(config)#interface f0/0            
R1(config-if)#crypto map IPSecvpn

R1(config)#ip access-list extended nat
R1(config-ext-nacl)#10 permit ip 1.1.1.0 0.0.0.255 any
R1(config-ext-nacl)#exit
R1(config)#int loop0
R1(config-if)#ip nat inside
R1(config-if)#int s0/0
R1(config-if)#ip nat outside
R1(config-if)#exit
R1(config)#ip nat inside source list nat int f0/0 overload

R3
Router>enable                                         
Router#configure terminal
Router(config)#hostname R3                             
R3(config)#no ip domain-lookup                         
R3(config)#service timestamps debug datetime localtime
R3(config)#service timestamps log  datetime localtime
R3(config)#interface f0/0                        
R3(config-if)#ip address 192.168.1.3 255.255.255.0      
R3(config-if)#no shutdown                     
R3(config-if)#exit                                 
R3(config)#interface f0/1                  
R3(config-if)#ip address 23.1.1.3 255.255.255.0         
R3(config-if)#no shutdown  
R3(config-if)#exit

R3(config)#ip route 0.0.0.0 0.0.0.0 23.1.1.2
R3(config)#interface tunnel11                   
R3(config-if)#tunnel source 23.1.1.3
R3(config-if)#tunnel destination 12.1.1.1   
R3(config-if)# ip address 172.16.1.3 255.255.255.0
R3(config-if)#tunnel mode gre ip  
R3(config-if)#no shutdown  
R3(config-if)#exit
R3(config)#ip route 10.1.1.0 255.255.255.0 tunnel11

R3(config)#crypto isakmp policy 10
R3(config-isakmp)#authentication pre-share
R3(config-isakmp)#encryption des
R3(config-isakmp)#group 2
R3(config-isakmp)#hash md5
R3(config-isakmp)#exit
R3(config)#crypto isakmp key 6 cisco address 12.1.1.1 255.255.255.0

R3(config)#crypto ipsec transform-set cisco esp-des esp-md5-hmac
R3(cfg-crypto-trans)#mode tunnel
R3(cfg-crypto-trans)#exit

R3(config)#ip access-list extended interested  
R3(config-ext-nacl)#permit gre host 23.1.1.3 host 12.1.1.1
R3(config-ext-nacl)#exit

R3(config)#crypto map IPSecvpn 10 ipsec-isakmp
R3(config-crypto-map)#set peer 12.1.1.1
R3(config-crypto-map)#set transform-set cisco
R3(config-crypto-map)#match address interested
R3(config-crypto-map)#exit

R3(config)#interface serial 0/1
R3(config-if)#crypto map IPSecvpn

时间: 2024-10-10 10:44:35

IPSec transport mode配置的相关文章

IPSEC VPN 的配置实例

詹柱美 一.实验拓扑: 二.实验要求: 保证两个站点的路由没问题. 在站点A与站点B间配置VPN,保障企业的网络通过互联网连接起来. 三.实验的配置: R1的全部配置: r1#show running-config Building configuration... Current configuration : 597 bytes ! version 12.4 no service timestamps log datetime msec no service timestamps debug

Cisco 3640系列IPsec VPN简单配置

Cisco 3640系列IPsec VPN简单配置 实验拓扑图: 实验步骤: 第一步:配置路由 第二步:匹配的数据包流量(ACL,注意两端要对称) 第三步:IKE的第一阶段(称为 ISAKMP SA) 第四步:IKE的第二阶段(称为IPSEC SA) 第五步:MAP(第二.三.四步的结合) 第六步:应用配置到外网口 模拟Internet步骤如下: 1.路由配置 R1: Router>en Router#conft Enterconfiguration commands, one per line

H3C ipsec ike 协商配置

1. 分几步设置 (1)定义ACL (2)创建 ipsec 安全建议 (3)创建IKE keychain (4)创建IKE profile (5)创建一条IKE协商方式的IPsec安全策略 2.配置 (1) 配置 Device A 配置各接口的IP地址,具体略. 配置 ACL 3101,定义要保护由子网10.1.1.0/24去子网10.1.2.0/24的数据流. <DeviceA> system-view [DeviceA] acl number 3101 [DeviceA-acl-adv-3

7200的GRE(隧道)+ipsec(传输模式+pre-share)配置

R6路由器GRE部分配置 en config t no ip domain-lookup ip classless ip subnet-zero host R6 interface loopback 0 ip address 10.1.1.1 255.255.255.0 interface serial 1/2 ip address 173.16.1.1 255.255.255.252 no shutdown int fa 2/0 ip addr 11.0.0.1 255.0.0.0 no sh

ASA 5520(IOS version 8.4) IKEv2 IPSEC VPN实验配置

1.实验TOP图如下: 2.实验目的: 使用IKEv2实现点到点的IPSECVPN通信,即本示例中192.168.1.100和172.16.1.100之间实现VPN通信. 3.具体配置如下: ASA1配置 interfaceGigabitEthernet0 nameif outside security-level 0 ip address 11.1.1.2 255.255.255.0 ! interfaceGigabitEthernet1 nameif inside security-leve

IPSec VPN经典配置

IPSec VPN配置命令 底层用静态路由连通 R2(config)#ip route 1.1.1.0 255.255.255.0 10.1.1.10 R2(config)#ip route 2.2.2.0 255.255.255.0 202.100.1.10 //这条路由在现实环境中由默认路由代替,由于1111到2222的数据包被加密,Internet上不会出现去往2222的明文数据包. R2(config)#ip route 61.128.1.0 255.255.255.0 202.100.

ip-sec VPN 基本配置实验

准备步骤: 1.给各路由器配置IP地址 2.R1 R3设置一条默认路由,R2只配IP地址,不做任何路由设置. R1: R1(config)#crypto isakmp enable     //开启ike阶段SA协商 R1(config)#crypto isakmp policy 10     //创建ike策略,10为序号,越小越优先. R1(config-isakmp)#authentication pre-share    //开启pre-share作为认证方式 R1(config-isa

Cisco路由器配置GRE over IPsec

拓扑图 实验目的: 通过CRE over IPsec的方式实现R1网段:172.16.10.0/24和R2网段:172.17.10.0/24通信加密. 由于IPsec VPN不支持组播,而GRE支持多种协议,所以一般情况下会选择GRE over IPsec. 配置思路: 通过ACL设置感兴趣流 配置IKE第一阶段 配置IKE第二阶段 新建MAP,并应用于接口 设置路由,下一跳为tunnel 0 配置: R1: 配置接口IP信息 interface Loopback0  ip address 17

华为USG防火墙 IPsec VPN配置

实验拓扑 使用华为ensp 1.2.00.370模拟器 实验需求 USG-1和USG-2模拟企业边缘设备,分别在2台设备上配置NAT和IPsec VPN实现2边私网可以通过VPN互相通信 实验配置 R1 IP地址配置省略 USG-1配置 [USG-1]firewall zone trust          //配置trust区域 [USG-1-zone-trust]add interface g0/0/0    //将接口加入trust区域 [USG-1-zone-trust]quit [US