HDU 5805 NanoApe Loves Sequence(思维)

传送门

NanoApe Loves Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 440    Accepted Submission(s): 205

Problem Description

NanoApe, the Retired Dog, has returned back to prepare for the National Higher Education Entrance Examination!

In math class, NanoApe picked up sequences once again. He wrote down a sequence with n numbers on the paper and then randomly deleted a number in the sequence. After that, he calculated the maximum absolute value of the difference of each two adjacent remained numbers, denoted as F.

Now he wants to know the expected value of F, if he deleted each number with equal probability.

Input

The first line of the input contains an integer T, denoting the number of test cases.

In each test case, the first line of the input contains an integer n, denoting the length of the original sequence.

The second line of the input contains n integers A1,A2,...,An, denoting the elements of the sequence.

1≤T≤10, 3≤n≤100000, 1≤Ai≤109

Output

For each test case, print a line with one integer, denoting the answer.

In order to prevent using float number, you should print the answer multiplied by n.

Sample Input

1 
4 
1 2 3 4

Sample Output

6

Source

BestCoder Round #86

Recommend

wange2014  &nbsp|  &nbspWe have carefully selected several similar problems for you:  5808 5807 5806 5804 5803

Statistic | Submit | Discuss | Note

题目大意:

退役狗 NanoApe 滚回去学文化课啦!

在数学课上,NanoApe 心痒痒又玩起了数列。他在纸上随便写了一个长度为 n 的数列,他又根据心情随便删了一个数,这样他得到了一个新的数列,然后他计算出了所有相邻两数的差的绝对值的最大值。

他当然知道这个最大值会随着他删了的数改变而改变,所以他想知道假如全部数被删除的概率是相等的话,差的绝对值的最大值的期望是多少。

官方题解:

求出前i个数里相邻差值的最大值fi,i到n里相邻差值的最大值gi,那么ans=∑ni=1max(|Ai?1?Ai+1|,fi?1,gi+1)。

时间复杂度O(n)。

个人解题思路:

这个题目应该不是很难的,因为选一个数的概率是 1n 的,然后最后还要乘以 n, 所以 直接就算就行了,首先我们找出最大的前三个数,然后每次判断,当然删掉第一个数 和 最后一个数的时候要特判,删除后的的最大差值是不是与没有删除之前的最大值相等,如果相等的话,加上第二大的差值,否则加上第一大的差值,当在中间的时候,我们需要考虑的是两个数,相当于删除了两个差值,增加了一个差值,我们首先判断增加的那个差值是不是比未删除之前的那个值大,如果比它大的话 就不需要考虑了,直接加上它的后一个数 与 前一个数的差值就行了,否则,判断 删除的那两个差值是不是第一大和第二大,然后 YY 一下就行了。

My Code:

/**
2016 - 08 - 07 上午
Author: ITAK

Motto:

今日的我要超越昨日的我,明日的我要胜过今日的我,
以创作出更好的代码为目标,不断地超越自己。
**/

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
const LL INF = 1e9+5;
const int MAXN = 1e6+5;
const int MOD = 1e9+7;
const double eps = 1e-7;
const double PI = acos(-1);
using namespace std;
LL a[MAXN], sum[MAXN];
inline bool cmp(LL a, LL b)
{
    return a > b;
}
int main()
{
    int T, n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
            scanf("%I64d",&a[i]);
        memset(sum, -1, sizeof(sum));
        for(int i=2; i<=n; i++)
            sum[i-1] = abs(a[i]-a[i-1]);
        sort(sum+1, sum+n, cmp);
        LL ans = 0;
        if(sum[1] == abs(a[1]-a[2]))
            ans += sum[2];
        else
            ans += sum[1];
        if(sum[1] == abs(a[n]-a[n-1]))
            ans += sum[2];
        else
            ans += sum[1];
        for(int i=2; i<n; i++)
        {
            LL t1 = abs(a[i]-a[i-1]);
            LL t2 = abs(a[i]-a[i+1]);
            LL t3 = abs(a[i+1]-a[i-1]);
            if(t3 >= sum[1])
                ans += t3;
            else
            {
                if(t1 == sum[1])
                {
                    if(t2 == sum[2])
                        ans += max(sum[3], t3);
                    else
                        ans += max(sum[2], t3);
                }
                else if(t2 == sum[1])
                {
                    if(t1 == sum[2])
                        ans += max(sum[3], t3);
                    else
                        ans += max(sum[2], t3);
                }
                else
                    ans += sum[1];
            }
        }
        printf("%I64d\n",ans);
    }
    return 0;
}
时间: 2024-12-18 08:46:43

HDU 5805 NanoApe Loves Sequence(思维)的相关文章

HDU 5805 NanoApe Loves Sequence (思维题) BestCoder Round #86 1002

题目:传送门. 题意:题目说的是求期望,其实翻译过来意思就是:一个长度为 n 的数列(n>=3),按顺序删除其中每一个数,每次删除都是建立在最原始数列的基础上进行的,算出每次操作后得到的新数列的相邻两数的差的绝对值的最大值,求这些n个最大值的总和. 题解:把n=3的情况单独拿出来直接算出来,就是abs(data[3]-data[2])+abs(data[2]-data[1])+abs(data[3]-data[1]),然后讨论n>=4的情况.首先遍历求出原始数列的相邻两数的差的绝对值的最大值m

HDU 5805 - NanoApe Loves Sequence (BestCoder Round #86)

先找相邻差值的最大,第二大,第三大 删去端点会减少一个值, 删去其余点会减少两个值,新增一个值,所以新增和现存的最大的值比较一下取最大即可 1 #include <iostream> 2 #include <cstdio> 3 #include <cmath> 4 using namespace std; 5 #define LL long long 6 const int N = 100005; 7 int t, n, p1, p2, p3; 8 LL a[N]; 9

HDU 5805 NanoApe Loves Sequence

处理出每个位置左边的最大值和右边的最大值.然后就可以o(1)计算去掉某位置的最大值了. #pragma comment(linker, "/STACK:1024000000,1024000000") #include<cstdio> #include<cstring> #include<cmath> #include<algorithm> #include<vector> #include<map> #includ

HDU 5806 NanoApe Loves Sequence Ⅱ(尺取+思维)——BestCoder Round #86 1003

传送门 NanoApe Loves Sequence Ⅱ Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)Total Submission(s): 514    Accepted Submission(s): 248 Problem Description NanoApe, the Retired Dog, has returned back to prepare for f

5805 NanoApe Loves Sequence

传送门 NanoApe Loves Sequence Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others) Total Submission(s): 1323    Accepted Submission(s): 521 Description NanoApe, the Retired Dog, has returned back to prepare for the Natio

HDU - 5806 NanoApe Loves Sequence Ⅱ 想法题

http://acm.hdu.edu.cn/showproblem.php?pid=5806 题意:给你一个n元素序列,求第k大的数大于等于m的子序列的个数. 题解:题目要求很奇怪,很多头绪但写不出,选择跳过的题,简称想法题. 首先考虑区间的更新方法:区间左端l不动,右端r滑动, 滑到有k个数>=m时,此区间符合条件,并且发现右端点再往右滑到底,此条件一直符合(因为若加入的数小于"第K大的数",则毫无影响.若不然,加入该数会产生一个新的第k大数,保证>="第K大

HDU 5806 - NanoApe Loves Sequence Ⅱ (BestCoder Round #86)

若 [i, j] 满足, 则 [i, j+1], [i, j+2]...[i,n]均满足 故设当前区间里个数为size, 对于每个 i ,找到刚满足 size == k 的 [i, j], ans += n - j + 1 . i++ 的时候看看需不需要size-- 就可以更新了. 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 using namespace std; 5 #define

HDU 5806 NanoApe Loves Sequence Ⅱ ——(尺取法)

题意:给出一个序列,问能找出多少个连续的子序列,使得这个子序列中第k大的数字不小于m. 分析:这个子序列中只要大于等于m的个数大于等于k个即可.那么,我们可以用尺取法写,代码不难写,但是有些小细节需要注意(见代码注释).我觉得,<挑战程序设计>里的尺取法的内容需要好好的再回顾一下= =. 代码如下: 1 #include <stdio.h> 2 #include <algorithm> 3 #include <string.h> 4 using namesp

HDU 5806 NanoApe Loves Sequence Ⅱ

将大于等于m的数改为1,其余的改为0.问题转变成了有多少个区间的区间和>=k.可以枚举起点,二分第一个终点 或者尺取法. #pragma comment(linker, "/STACK:1024000000,1024000000") #include<cstdio> #include<cstring> #include<cmath> #include<algorithm> #include<vector> #includ