HDU 1518 Square (DFS+剪枝)

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
Sample Input
3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5
Sample Output
yes
no
yes

题意:

用所有的木棒首尾相连,问能否组成一个正方形。

题解:

DFS搜索,另外对一些情况进行剪枝。

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int a[50];
bool vis[50];
int ave;
bool flag;
int n;
void dfs(int cnt,int sum,int k)
{
    if(flag) return ;
    if(cnt==3)//前3个边都选好了,那么最后一条边一定能满足
    {
        flag=true;
        return ;
    }
    for(int i=k;i<n;i++)
    {
        if(!vis[i]&&a[i]+sum<=ave)
        {
            vis[i]=true;
            if(sum+a[i]==ave)
                dfs(cnt+1,0,0);
            else
                dfs(cnt,sum+a[i],i+1);
            if(flag) return ;
            vis[i]=false;
        }
    }
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n;
        int sum=0;
        for(int i=0;i<n;i++)
            cin>>a[i],sum+=a[i];
        if(sum%4)//剪枝,如果不能被4整除,一定不能组成四边形
        {
            cout<<"no"<<endl;
            continue;
        }
        ave=sum/4;
        flag=false;
        memset(vis,false,sizeof(vis));
        dfs(0,0,0);
        if(flag)
            cout<<"yes"<<endl;
        else
            cout<<"no"<<endl;
    }
    return 0;
}
时间: 2024-10-12 12:14:05

HDU 1518 Square (DFS+剪枝)的相关文章

hdu 1518 Square(深搜+剪枝)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1518 题目大意:根据题目所给的几条边,来判断是否能构成正方形,一个很好的深搜应用,注意剪枝,以防超时! 1 #include <iostream> 2 #include <cstdio> 3 #include<algorithm> 4 #include <cstring> 5 using namespace std; 6 int ap[30],visit[30]

hdu 1518 Square (dfs搜索可参考poj1011)

Square Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8589    Accepted Submission(s): 2784 Problem Description Given a set of sticks of various lengths, is it possible to join them end-to-end

hdu 1518 Square(深搜dfs)

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1518 --------------------------------------------------------------------------------------------------------------------------------------------

HDU 1518 Square 搜索

Square Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 11   Accepted Submission(s) : 5 Font: Times New Roman | Verdana | Georgia Font Size: ← → Problem Description Given a set of sticks of vario

hdu 1518 Square 深搜,,,,花样剪枝啊!!!

Square Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9588    Accepted Submission(s): 3127 Problem Description Given a set of sticks of various lengths, is it possible to join them end-to-end

hdu - 1072(dfs剪枝)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1072 思路:深搜每一个节点,并且进行剪枝,记录每一步上一次的s1,s2:如果之前走过的时间小于这一次, 就说明有更短的:路径,所以就不用继续遍历下去. #include<iostream> #include<cstdio> #include<cstring> using namespace std; int a[20][20],step[20][20],tim[20][20

hdu 1044(bfs+dfs+剪枝)

Collect More Jewels Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 6739    Accepted Submission(s): 1564 Problem Description It is written in the Book of The Lady: After the Creation, the cruel

hdu 1518 Square

Problem Description Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square? Input The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number

hdu 1518(dfs)

参考页面: http://www.yuanjiaocheng.net/CSharp/Csharp-keys.html http://www.yuanjiaocheng.net/CSharp/csharp-interface.html http://www.yuanjiaocheng.net/CSharp/Csharp-operators.html http://www.yuanjiaocheng.net/CSharp/Csharp-if-else.html http://www.yuanjiao