UVA 1600 Patrol Robot(机器人穿越障碍最短路线BFS)

UVA 1600 Patrol Robot

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

A robot has to patrol around a rectangular area which is in a form of mxn grid (m rows and n columns). The rows are labeled from 1 to m. The columns are labeled from 1 to n. A cell (ij) denotes the cell in row i and column j in the grid. At each step, the robot can only move from one cell to an adjacent cell, i.e. from (xy) to (x + 1, y), (xy + 1), (x - 1, y) or (xy - 1). Some of the cells in the grid contain obstacles. In order to move to a cell containing obstacle, the robot has to switch to turbo mode. Therefore, the robot cannot move continuously to more than k cells containing obstacles.

Your task is to write a program to find the shortest path (with the minimum number of cells) from cell (1, 1) to cell (mn). It is assumed that both these cells do not contain obstacles.

Input

The input consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.

For each data set, the first line contains two positive integer numbers m and n separated by space (1mn20). The second line contains an integer number k(0k20). The ith line of the next m lines contains n integer aij separated by space (i = 1, 2,..., m;j = 1, 2,...,n). The value of aij is 1 if there is an obstacle on the cell (ij), and is 0 otherwise.

Output

For each data set, if there exists a way for the robot to reach the cell (mn), write in one line the integer number s, which is the number of moves the robot has to make; -1 otherwise.

Sample Input

3
2 5
0
0 1 0 0 0
0 0 0 1 0
4 6
1
0 1 1 0 0 0
0 0 1 0 1 1
0 1 1 1 1 0
0 1 1 1 0 0
2 2
0
0 1
1 0

Sample Output

7
10
-1

题解:求机器人走最短路线,而且可以穿越障碍。    一道典型的BFS遍历的题,用队列实现,找到满足条件的最短路线;    题意很好理解,实现时应该注意判断规定障碍个数和标记走过的点。
BFS比DFS要快很多,一个用队列实现,一个用递归实现,都可以用
BFS的AC代码
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
const int maxn=21;
int n,m,k;
int a[maxn][maxn][maxn];
int b[maxn][maxn];
int dir[4][2]= {-1,0,1,0,0,-1,0,1};
struct node
{
    int x,y,step,zhangai;
    void boom(int nx,int ny,int nstep,int nzhangai)
    {
        x=nx;
        y=ny;
        step=nstep;
        zhangai=nzhangai;
    }
};

int bfs()
{
    queue<node>q;
    while(!q.empty())
        q.pop();
    node u,v;
    u.boom(1,1,0,0);         //起点
    q.push(u);
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        for(int i=0; i<4; i++)
        {
            int xx=u.x;
            int yy=u.y;
            int sstep=u.step;
            int szhangai=u.zhangai;
            xx+=dir[i][0];
            yy+=dir[i][1];
            sstep+=1;
            if(xx>n||xx<1||yy>m||yy<1)
                continue;
            if(b[xx][yy]==1)
                szhangai++;
            else
                szhangai=0;
            if(szhangai>k)
                continue;
            if(a[xx][yy][szhangai]==1)  //如果没有这一步会超时
                continue;
            if(xx==n&&yy==m)
                return sstep;
            v.boom(xx,yy,sstep,szhangai);
            q.push(v);
            a[xx][yy][szhangai]=1;
        }
    }
    return -1;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d %d",&n,&m,&k);
        memset(a,0,sizeof(a));        //每次都要
        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)
                scanf("%d",&b[i][j]);
        int total=bfs();
        printf("%d\n",total);
    }
    return 0;
}

下面的是在网上看的一个用dfs实现的,也很容易懂

#include<iostream>
#include<cstring>
using namespace std;
int n,m,k;
int b[21][21];
int a[21][21][21];
int total;
int xx[4]= {-1,1,0,0};
int yy[4]= {0,0,1,-1};

void dfs(int x,int y,int step,int zhangai)
{
    if(x == n - 1 && y == m - 1)
    {
        total = min(total,step);
        return ;
    }
    for(int i = 0 ; i < 4 ; i++)
    {
        int nx = x + xx[i];
        int ny = y + yy[i];
        int st = zhangai;
        if(b[nx][ny] == 1) st++;
        else
            st = 0;
        if(nx >= 0 && nx < n && ny >= 0 && ny < m)
        {
            if((a[nx][ny][st] < 0 || a[nx][ny][st] > step + 1) && st <= k)
            {
                a[nx][ny][st] = step + 1;
                dfs(nx,ny,step + 1,st);
            }
        }
    }
    return ;
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        memset(a,-1,sizeof(a));
        total = 1<<30;
        cin>>n>>m>>k;
        for(int i = 0 ; i < n ; i++)
            for(int j = 0 ; j < m ; j ++)
                cin>>b[i][j];
        dfs(0,0,0,0);
        if(total != 1<<30 )
            cout<<total<<endl;
        else
            cout<<"-1"<<endl;
    }
    return 0;
}
时间: 2024-10-11 08:28:50

UVA 1600 Patrol Robot(机器人穿越障碍最短路线BFS)的相关文章

UVA 1600 Patrol Robot(机器人穿越障碍最短路线BFS) 解题心得

原题: Description A robot has to patrol around a rectangular area which is in a form of mxn grid (m rows and n columns). The rows are labeled from 1 to m. The columns are labeled from 1 to n. A cell (i, j) denotes the cell in row i and column j in the

UVA 1600 Patrol Robot

带状态的bfs 用一个数(ks)来表示状态-当前连续穿越的障碍数: step表示当前走过的步数: visit数组也加一个状态: 1 #include <iostream> 2 #include <cstring> 3 #include <cstdio> 4 #include <queue> 5 using namespace std; 6 7 const int maxn = 30 ; 8 9 struct node { 10 int x,y; 11 int

UVA 1600 Patrol Robot(BFS扩展)

Patrol Robot Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu Submit Status Description A robot has to patrol around a rectangular area which is in a form of mxn grid (m rows and n columns). The rows are labeled from 1 to m.

UVa 1600 Patrol Robot (习题 6-5)

传送门: https://uva.onlinejudge.org/external/16/1600.pdf 多状态广搜 网上题解: 给vis数组再加一维状态,表示当前还剩下的能够穿越的墙的次数,每次碰到墙,当前的k减去1,碰到0,当前的k变成最初的k. vis[x][y][z]  x, y代表坐标  z表示k  当为真时说明该点剩余穿墙次数为k的状态已出现过 1 #include <bits/stdc++.h> 2 using namespace std; 3 4 typedef struct

UVa 1600 Patrol Robot(BFS)

题意: 给定一个n*m的图, 有一个机器人需要从左上角(1,1)到右下角(n,m), 网格中一些格子是空地, 一些格子是障碍, 机器人每次能走4个方向, 但不能连续穿越k(0<= k <= 20)个障碍物, 求最短路径, 如无法到达输出 -1. 分析:   对于空地, 建一个vis数组记录走过的空地, 然后每次碰到没vis过的空地都把队伍K更新为最大值, vis这块地. 对于墙的情况, 我们可以建一个vis1数组去记录通过墙时候的k值, 如果之前有一个k值比现在要通过的大, 那么我们就不入队,

Uva 1600 Patrol Robot (BFS 最短路/DFS剪枝)

这道题运用的知识点是求最短路的算法.一种方法是利用BFS来求最短路. 需要注意的是,我们要用一个三维数组来表示此状态是否访问过,而不是三维数组.因为相同的坐标可以通过不同的穿墙方式到达. #include <bits/stdc++.h> using namespace std; struct Node{ int r; int c; int g; int cnt; Node(int r,int c,int g,int cnt):r(r),c(c),g(g),cnt(cnt){} }; int v

【UVa】1600 Patrol Robot(dfs)

题目 题目 ? ? 分析 bfs可以搞,但是我还是喜欢dfs,要记忆化不然会T ? ? 代码 #include <cstdio> #include <cstring> #include <algorithm> using namespace std; const int INF=1<<25; int k,n,m,map[25][25],dx[10]={1,-1,0,0},dy[10]={0,0,1,-1},ans; int vis[25][25][25];

1600 - Patrol Robot(BFS)

BFS题,不过多了一个很有意思的条件:不能连续穿越K个障碍,就好像多了一个技能一样,我用pre[][]数组来记录目前的k值: #include<bits/stdc++.h> using namespace std; int a[30][30],T,m,n,k,d[30][30],pre[30][30],air[10]={1,0,-1,0},air2[10]={0,1,0,-1};; typedef pair<int,int> P; P s[450]; int bfs() { que

UVA 1600 Patrol Robert

非常适合A*的一道题. 比普通的迷宫问题加一个信息k表示当前穿过的障碍物的数量. #include<cstdio> #include<cstring> #include<queue> using namespace std; const int MAX = 21; int m,n,k; int C[MAX][MAX][MAX]; int G[MAX][MAX]; int tarx,tary; struct node { int g,h; int x,y;//对于本题 x