hdu 1250 Hat's Fibonacci(高精度数)

//  继续大数,哎、、

Problem Description

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.

F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)

Your task is to take a number as input, and print that Fibonacci number.

Input

Each line will contain an integers. Process to end of file.

Output

For each case, output the result in a line.

Sample Input

100

Sample Output

4203968145672990846840663646

Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

Author

戴帽子的

/**************************************

模拟斐波那契数列 , 不过递推公式变成了 f1 = f2 = f3 = f4 = 1 ,  f(n) = f(n-1) + f(n-2) + f(n-3) +f(n-4) . (n>=5)  , 最大的数有2005位,所以,用大数吧

用的 跟 hdu1042 N! 的方法一样,用 十万 进制解决,每个整形存 10000,当然更大点也可以。。

**************************************/

Code:

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
const int N = 7500;
const int M = 500;
int num[N][M];
void add()
{
    memset(num,0,sizeof(num));
    num[1][1] = num[2][1] = num[3][1] = num[4][1] = 1;
    int i,j,k = 0;
    for(i = 5;i<7500;i++)
        for(j = 1;j<500;j++)
        {
            k += num[i-1][j] + num[i-2][j] + num[i-3][j] + num[i-4][j];// 递推公式
            num[i][j] = k%100000;
            k = k/100000;
        }
        while(k)
        {
            num[i][j++] = k%100000;
            k = k/100000;
        }
}
int main()
{
    int n,i;
    add();
    while(cin>>n)
    {
        for(i = 500-1;i>=0;i--)
        {
            if(num[n][i]!=0)
                break;
        }
        printf("%d",num[n][i--]);
        while(i>0)
            printf("%05d",num[n][i--]);
        printf("\n");
    }
    return 0;
}

hdu 1250 Hat's Fibonacci(高精度数),码迷,mamicode.com

hdu 1250 Hat's Fibonacci(高精度数)

时间: 2024-12-26 14:49:08

hdu 1250 Hat's Fibonacci(高精度数)的相关文章

hdu 1250 Hat&#39;s Fibonacci

Hat's Fibonacci Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 9677 Accepted Submission(s): 3210 Problem Description A Fibonacci sequence is calculated by adding the previous two members the seque

HDU 1250 Hat&#39;s Fibonacci(Java大数相加)+讲解

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1250 Problem Description A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1. F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n -

HDOJ/HDU 1250 Hat&#39;s Fibonacci(大数~斐波拉契)

Problem Description A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1. F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4) Your task is to take

hdu 1250 Hat&#39;s Fibonacci (大数相加)

//a[n]=a[n-1]+a[n-2]+a[n-3]+a[n-4]; # include <stdio.h> # include <algorithm> # include <string.h> # include <iostream> using namespace std; int a[10000][260]={0}; //每个元素可以存储8位数字,所以2005位可以用260个数组元素存储. int main() { int i,j,n; a[1][0

HDU 1250 Hat&#39;s Fibonacci(大数相加)

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1250 Hat's Fibonacci Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 12952    Accepted Submission(s): 4331 Problem Description A Fibonacci sequence

HDU 1250 Hat&#39;s Fibonacci (递推、大数加法、string)

Hat's Fibonacci Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 14776    Accepted Submission(s): 4923   Problem Description A Fibonacci sequence is calculated by adding the previous two members

hdu 1250 Hat&amp;#39;s Fibonacci

点击此处就可以传送hdu 1250 Problem Description A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1. F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4) You

hdoj 1250 Hat&#39;s Fibonacci 【高精度】

Fibonacci... 策略:用Java 做这道题较简单一些,但是,C语言是基础. 用java的话,就是最简单的BigInteger的使用. 下面简单讲一下C语言的做法: 一个12位的整数,可以表示为,3个四位的整数的集合,例如123412341234就可以转化为1234, 1234, 1234.下面的就是按照此原理做的. c代码: #include <stdio.h>//每一个int都代表6个数. #include <string.h> #define M 10000 int

HDUJ 1250 Hat&#39;s Fibonacci

Hat's Fibonacci Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7338    Accepted Submission(s): 2395 Problem Description A Fibonacci sequence is calculated by adding the previous two members th