hdu2637

shǎ崽 OrOrOrOrz

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3654 Accepted Submission(s): 1138
 

Problem Description

Acmer in HDU-ACM team are ambitious, especially shǎ崽, he can spend time in Internet bar doing problems overnight. So many girls want to meet and Orz him. But Orz him is not that easy.You must solve this problem first.
The problem is :
Give you a sequence of distinct integers, choose
numbers as following : first choose the biggest, then smallest, then second
biggest, second smallest etc. Until all the numbers was chosen .
For
example, give you 1 2 3 4 5, you should output 5 1 4 2 3


Input

There are multiple test cases, each case begins with
one integer N(1 <= N <= 10000), following N distinct integers.


Output

Output a sequence of distinct integers described
above.


Sample Input

5
1 2 3 4 5


Sample Output

5 1 4 2 3

#include<iostream>
#include<algorithm>
using namespace std;

int main()
{
    int n,i,flag,j;
    int a[10000];
    while(cin>>n&&n)
    {
        for(i=0;i<n;i++)
            cin>>a[i];
        sort(a,a+n);//默认升序
        flag=0;
        for(i=0,j=n-1;i<=j;i++,j--)
        {
            if(flag==0)    flag=1;
            else
                cout<<" ";
            if(i==j)
                cout<<a[i];
            else
                cout<<a[j]<<" "<<a[i];
        }
        cout<<endl;
    }
    return 0;
}

hdu2637

时间: 2024-08-27 18:10:55

hdu2637的相关文章