ZOJ3469 Food Delivery[区间dp]

Food Delivery


Time Limit: 2 Seconds      Memory Limit: 65536 KB


When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person‘s coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to theN people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain Bi Displeasure Index per minute.

If one‘s Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people‘s Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.

Input

The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then N lines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231 - 1.

Please process to the end-of-file.

Output

For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

Sample Input

5 1 0
1 1
2 2
3 3
4 4
5 5

Sample Output

55

用f[i][j][0]表示送完[i,j]这个区间且送货员停在i 位置,的最小不满值,f[i][j][1]表示送完[i,j]这个区间且送货员停在j位置,的最小不满值。

转移显然。(详见这里

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int N=1003;
int n,m,V,X;
int f[N][N][2];
struct data{
    int p,s;
    bool operator <(const data &a)const{
        return p<a.p;
    }
}d[N],tx;
int main(){
    while(~scanf("%d%d%d",&n,&V,&X)){
        for(int i=1;i<=n;i++) scanf("%d%d",&d[i].p,&d[i].s);
        d[++n].p=X;tx=d[n];memset(f,0x3f,sizeof f);
        sort(d+1,d+n+1);d[n+1]=(data){0,0};
        for(int i=1;i<=n;i++) d[i].s+=d[i-1].s;
        m=lower_bound(d+1,d+n+1,tx)-d;
        f[m][m][0]=f[m][m][1]=0;
        for(int j=m;j<=n;j++){
            for(int i=j-1;i;i--){
                f[i][j][0]=min(f[i+1][j][0]+(d[n].s-d[j].s+d[i].s)*(d[i+1].p-d[i].p),
                                  f[i+1][j][1]+(d[n].s-d[j].s+d[i].s)*(d[j].p-d[i].p));
                f[i][j][1]=min(f[i][j-1][0]+(d[n].s-d[j-1].s+d[i-1].s)*(d[j].p-d[i].p),
                                  f[i][j-1][1]+(d[n].s-d[j-1].s+d[i-1].s)*(d[j].p-d[j-1].p));
            }
        }
        printf("%d\n",min(f[1][n][0],f[1][n][1])*V);
    }
    return 0;
}
时间: 2024-08-04 10:17:23

ZOJ3469 Food Delivery[区间dp]的相关文章

zoj 3469 Food Delivery(区间dp)

Food Delivery Time Limit: 2 Seconds      Memory Limit: 65536 KB When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery. Suppose there are N p

zoj 3469 Food Delivery 区间dp + 提前计算费用

Time Limit: 2 Seconds      Memory Limit: 65536 KB When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery. Suppose there are N people living i

Food Delivery zoj3469 区间dp

Description When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery. Suppose there are N people living in a straight street that is just lies

ZOJ3469 Food Delivery (经典区间dp)

本题和某一年的oi题非常相似,都是经典套路 我们知道我们在送完食物后既可以向前送也可以回头送,这就体现了区间dp的思想 为什么我们这次的区间dp不用枚举第三维k来枚举从哪里送过来呢? 因为送货员不是傻子,他如果送到你这了,那么在你们两之间的可以都顺路送了,所以我们只需要枚举两个位置就行 这题的输入不一定递增,所以建议输入完后排序 #include<iostream> #include<cstdio> #include<cstring> #include<algor

ZOJ 3469 Food Delivery(区间DP)

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4255 题意:n个人订餐.n个人位于一条线上,饭店也在这条线上.每个人有一个脾气值p.若第i分钟得到他预定的饭不满意度为p*i.送饭人的速度已知.求一种送饭顺序使得总不满意度最小. 思路:设f[i][j][0],f[i] [j][1]分别表示将[i,j]区间的送完,最后停在左边或右边的最小不满意度.那么我们在DPf[i][j][0]时可以从f[i+1][j]进行转 移

ZOJ3541:The Last Puzzle(区间DP)

There is one last gate between the hero and the dragon. But opening the gate isn't an easy task. There were n buttons list in a straight line in front of the gate and each with an integer on it. Like other puzzles the hero had solved before, if all b

uva 10003 Cutting Sticks 简单区间dp

// uva 10003 Cutting Sticks 区间dp // 经典的区间dp // dp(i,j)表示切割小木棍i-j所需要的最小花费 // 则状态转移为dp(i,j) = min{dp(i,k) + dp(k,j) + a[j]-a[i]) // 其中k>i && k<j // a[j] - a[i] 为第一刀切割的代价 // a[0] = 0,a[n+1] = L; // dp数组初始化的时候dp[i][i+1]的值为 0,这表示 // 每一段都已经是切割了的,不

黑书例题 Fight Club 区间DP

题目可以在bnuoj.soj等OJ上找到. 题意: 不超过40个人站成一圈,只能和两边的人对战.给出任意两人对战的输赢,对于每一个人,输出是否可能是最后的胜者. 分析: 首先序列扩展成2倍,破环成链. dp[i][j]表示i和j能够相遇对打,那么dp[i][i+n]为真代表可以成为最后胜者. 枚举中间的k,若i和j都能和k相遇,且i和j至少一人能打赢k,那么i和j可以相遇. 复杂度o(n^3) 1 #include<cstdio> 2 #include<cstring> 3 usi

算法复习——区间dp

感觉对区间dp也不好说些什么直接照搬讲义了2333 例题: 1.引水入城(洛谷1514) 这道题先开始看不出来到底和区间dp有什么卵关系···· 首先肯定是bfs暴力判一判可以覆盖到哪些城市····无解直接输出···有解得话就要想想了···· 这道题关键是要发现··如果一个蓄水池所在城市可以覆盖到一些沙漠城市···那么这些沙漠城市肯定是一段····不然假设有一个城市是断开的而两边都被同一个蓄水池流出的水覆盖,这个城市四周的城市都肯定比它矮···(不理解举个反例吧···反正我举不出来)···然后就