POJ 1129 Channel Allocation(暴力搜--涂色问题)

Channel Allocation

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 13295   Accepted: 6806

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby
repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels.

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of
channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet
starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input.

Following the number of repeaters is a list of adjacency relationships. Each line has the form:

A:BCDH

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line
has the form

A:

The repeaters are listed in alphabetical order.

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross.

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels
is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 


题目大意:大意就是给你一些点和一些连线,构成了具有N个结点的无向图,然后要对这个无向图进行染色,使相邻两个结点颜色不同,问最少需要多少种不同的颜色。
思路:就是涂色问题,求相邻的颜色不相同所用的最少的颜色的种类。

#include<iostream>
#include<cstdio>
#include<string.h>
#include<string>
#include<cmath>
#include<queue>
#define LL long long

using namespace std;
struct node
{
    int d,next[30];//分别表示相邻颜色的种数与和当前颜色相邻的颜色
} q[30];
char Map[30];
int main()
{
    int cla,i,j,l,tmp,n;
    while(~scanf("%d",&n)&&n)
    {
        for(i=1; i<=30; i++)
            q[i].d=0;
        getchar();
        for(i=1;i<=n;i++)
        {
            gets(Map);
            l=strlen(Map);
            for(j=0;j<l;j++)
            {
                if(j==1||j==0)continue;
                q[Map[0]-'A'+1 ].next[ ++q[Map[0]-'A'+1].d ]=Map[j]-'A'+1;
            }
        }
        int ma=1,col[30];bool vis[30];
        memset(col,0,sizeof(col));
        for(i=1;i<=n;i++)
        {
            memset(vis,false,sizeof(vis));//当新的颜色被枚举时清空标记数组
            for(j=1;j<=q[i].d;j++)
            {
                int m=q[i].next[j];//与q[i]相邻的颜色分别被枚举出来,一定是将q[i].next[j]的值拿出来,而不是直接vis[col[j]]=true。此题默认按字典所以也对
                vis[col[m] ]=true;//并标记下这种颜色
            }
            for(j=1;j<=n;j++)
            {
                if(!vis[j])//再从小编号开始遍历,开哪种颜色还没有被用
                {
                    col[i]=j;//便把没用的颜色付给当前的要涂色的部分,找到一种编号小的停止
                    break;
                }
            }
            if(ma<j)
            ma=j;
            if(ma==4)//由四色定理知一个图不能多余5种涂色
            break;
        }
        if(ma==1)
            printf("%d channel needed.\n", ma);
        else
            printf("%d channels needed.\n", ma);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-12 09:28:21

POJ 1129 Channel Allocation(暴力搜--涂色问题)的相关文章

poj 1129 -- Channel Allocation

Channel Allocation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 12143   Accepted: 6218 Description When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a s

poj 1129 Channel Allocation (dfs)

链接:poj 1129 题意:如果相邻的中继器使用不同的频道,就不会相互干扰. 给定一些中继器的相邻关系,问至少要选几个不同的频道,使得中继器都不互相干扰. 分析:这题可以转化为无向图的染色问题, 即相邻的点不能染同一种颜色,求至少需要的几种颜色? 本题顶点数最多为26,可以直接用暴力搜索即可 思路:若顶点总数为n,则最多需要n种颜色(编号为1,2...n), 从最小的顶点开始染色,每次将与该顶点相邻的已染色的颜色标记, 再从未标记(未用)的颜色中,选出一个最小的颜色,给该点染色, 所有点染色完

POJ 1129 Channel Allocation(DFS)

Channel Allocation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 13173   Accepted: 6737 Description When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a s

POJ 1129 Channel Allocation DFS 回溯

Channel Allocation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 15546   Accepted: 7871 Description When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a s

DFS/四色定理/poj 1129 Channel Allocation

1 #include<cstdio> 2 #include<cstring> 3 using namespace std; 4 int n; 5 int a[30][30]; 6 int c[30]; 7 8 bool pd(int x,int color) 9 { 10 for (int i=1;i<x;i++) 11 if (a[x][i]==1 && c[i]==color) return false; 12 return true; 13 } 14 1

poj 1129 Channel Allocation(四色定理)

1 #include<iostream> 2 #include<cstdio> 3 #include<cstdlib> 4 #include<cstring> 5 #include<string> 6 #include<queue> 7 #include<algorithm> 8 #include<map> 9 #include<iomanip> 10 #include<climits>

Channel Allocation (poj 1129 dfs)

Language: Default Channel Allocation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 12367   Accepted: 6325 Description When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that ever

Channel Allocation 贪心涂色

Channel Allocation 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 #include <cmath> 5 #include <algorithm> 6 #include <string> 7 #include <vector> 8 #include <set> 9 #include <map> 10

poj 3734 方块涂色 求红色 绿色方块都为偶数的方案数 (矩阵快速幂)

N个方块排成一列 用红,蓝,绿,黄4种颜色去涂色,求红色方块 和绿色方块个数同时为偶数的 方案数 对10007取余 Sample Input 212Sample Output 2//(蓝,黄)6//(红红,蓝蓝,蓝黄,绿绿,黄蓝,黄黄) 1 # include <iostream> 2 # include <cstdio> 3 # include <cstring> 4 # include <algorithm> 5 # include <map>