HDU 1013Digital Roots 吃完饭,水个题。

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 53073    Accepted Submission(s): 16565

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is
repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24
39
0

Sample Output

6
3

九余数定理,弃九法,“弃九法”也叫做弃九验算法,利用这种方法可以验算加、减计算的结果是否错误。把一个数的各位数字相加,直到和是一个一位数(和是9,要减去9得0),这个数就叫做原来数的弃九数。可以用来检验加减乘除算式的正确性

这题是大数,要用字符串。

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#define N 100009
using namespace std;

char s[N];

int main()
{

    while(~scanf("%s",s))
    {
        if(s[0]=='0')break;

        int ans=0;
      int len=strlen(s);
      if(len==1)
      {
          cout<<s<<endl;
          continue;
      }

      for(int i=0;i<len;i++)
      {
          ans+=(s[i]-'0');
      }
      ans=ans%9;
      if(ans==0)
      cout<<9<<endl;
      else
        cout<<ans<<endl;
    }
    return 0;
}
时间: 2024-10-09 20:14:08

HDU 1013Digital Roots 吃完饭,水个题。的相关文章

吃完饭继续来码字了 C++ 析构函数 传值,this指针

话说现在我已经习惯了这种生活,以前俺是中午不睡觉会死星人,现在感觉不睡觉也就是那样了,准备把自己的时间好好安排一下了,由于我是在培训班,所以每天的时间也很紧的,以前打算每天晚上更新博客的,现在看来实现不了了.我决定在每天中午,回顾前天学习的内容,并巩固上午所学的.我想这应该是我学习效率最高的方法了.在这感谢一下@奋斗的小歌谢谢你的鼓励,我想这将是我以后坚持不下去的动力,我会坚持的不就是6个月吗?加油!! 好了,废话不说了,进入今天的主题吧! 析构函数:就是用来释放对象的.c++中一切都是按对象来

hdu 1301 Jungle Roads 一个很水的题 AC率也可以知道了 但是题目很难理解啊 英语渣o(╯□╰)oKruskal算法

Jungle Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4725    Accepted Submission(s): 3471 Problem Description The Head Elder of the tropical island of Lagrishan has a problem. A burst o

祛百病的薏米红豆汤——能当饭吃、当水喝的仙家养生小偏方

还有朋友问我是不是所有人都能喝薏米红豆汤,有禁忌吗?其实,这个汤是养生佳品,没有什么副作用,但针对不同的人,则可以适当地做一些加减法.     肾虚的人,可在薏米红豆汤中加一些黑豆.因为黑色入肾,豆的形状也跟肾十分相似,以形补形,是补肾的佳品. --<黄帝内经·素问·宣明五气> 薏米红豆汤每天应该喝多少呢?我建议大家从5月初开始喝,一直可以喝到10月份.熬了以后可以随意喝. 有的人在我的博客中看到过这个偏方,反馈给我很多信息,并且还有一些疑问,借此机会,我就大家最关注的问题,再详细地解答一下.

IT行业是吃青春饭的吗?

作者:杨中科 1.“it专业的学生太多了,而且就业压力很大”是吗?     现在各个大学为了赚钱拼命扩招,所以不仅IT专业的学生人比较多,而且其他专业的学生人数也比较多,“僧多粥少”就通常意味着就业压力大.但是反过来看,现在很多IT企业都存在“人才荒”的问题,也就是很多企业都招不到合适的人才,我认识一些做IT人力资源方面工作的朋友,他们都普遍反映现在企业里很难招到合适的人才.初看起来很奇怪“每年有很多IT专业大学生毕业,很多都找不到工作”,而“企业每年都缺人,招不到合适的人才”,造成这种奇怪的“

HDU 1862 EXCEL排序 (排序水题)

Problem Description Excel可以对一组纪录按任意指定列排序.现请你编写程序实现类似功能. Input 测试输入包含若干测试用例.每个测试用例的第1行包含两个整数 N (<=100000) 和 C,其中 N 是纪录的条数,C 是指定排序的列号.以下有 N 行,每行包含一条学生纪录.每条学生纪录由学号(6位数字,同组测试中没有重复的学号).姓名(不超过8位且不包含空格的字符串).成绩(闭区间[0, 100]内的整数)组成,每个项目间用1个空格隔开.当读到 N=0 时,全部输入结

HDU 4007 Dave (基本算法-水题)

Dave Problem Description Recently, Dave is boring, so he often walks around. He finds that some places are too crowded, for example, the ground. He couldn't help to think of the disasters happening recently. Crowded place is not safe. He knows there

荣经堂养生:吃完鸡蛋不能立即做七件事

鸡蛋是很好的营养品之一,富含多种人体必需的物质,但是在中医学中,任何事物都相生相克,鸡蛋也不例外,因为吃完鸡蛋后,有些事情不能立即做.以下是7件吃完鸡蛋不能立即做的事情. 1.吃完鸡蛋后不要立即吃糖 鸡蛋不可以跟味精一起煮,相信很多主妇都已经知晓.但是你可能不知道,鸡蛋不可以跟糖一起煮或者吃鸡蛋后吃糖也是不行的.很多地方有吃糖水荷包蛋的习惯,其实,那会使鸡蛋蛋白质中的氨基酸形成果糖基赖氨酸的结合物.而这种物质不易被人体吸收,所以会对健康会产生不良作用. 2.吃完鸡蛋后不要立即吃柿子 吃完鸡蛋后吃

Java 并发专题 :闭锁 CountDownLatch 之一家人一起吃个饭

最近一直整并发这块东西,顺便写点Java并发的例子,给大家做个分享,也强化下自己记忆. 每天起早贪黑的上班,父母每天也要上班,话说今天定了个饭店,一家人一起吃个饭,通知大家下班去饭店集合.假设:3个人在不同的地方上班,必须等到3个人到场才能吃饭,用程序如何实现呢? 作为一名资深屌丝程序猿,开始写代码实现: package com.zhy.concurrency.latch; public class Test1 { /** * 模拟爸爸去饭店 */ public static void fath

HDU 1800 Flying to the Mars (水题)

Flying to the Mars Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 11099    Accepted Submission(s): 3572 Problem Description In the year 8888, the Earth is ruled by the PPF Empire . As the popul