HDU-1040-As Easy As A+B(诚如题目所说和A+B一样简单-插入排序水过)

As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 45268    Accepted Submission(s): 19340

Problem Description

These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.

Give you some integers, your task is to sort these number ascending (升序).

You should know how easy the problem is now!

Good luck!

Input

Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in
the same line.

It is guarantied that all integers are in the range of 32-int.

Output

For each case, print the sorting result, and one line one case.

Sample Input

2
3 2 1 3
9 1 4 7 2 5 8 3 6 9

Sample Output

1 2 3
1 2 3 4 5 6 7 8 9

Author

lcy

Recommend

We have carefully selected several similar problems for you:  1096 1090 1091 1021 1093

让你见识一下什么叫大水神,插入排序水过......(前几天看算法导论,特么看了半天就看懂一个插入!!)

#include<iostream>
#include<cstdio>
using namespace std;
int a[10000];
int main()
{
    int t,i,j,n,target;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(i=1;i<n;i++)
        {
            j=i;
            target=a[i];
            while(j>0&&target<a[j-1])
            {
                a[j]=a[j-1];
                j--;
            }
            a[j]=target;
        }
        for(i=0;i<n;i++)
        {
            if(i!=n-1)
                printf("%d ",a[i]);
            else
                printf("%d\n",a[i]);
        }
    }
    return 0;
}
时间: 2024-11-09 12:54:16

HDU-1040-As Easy As A+B(诚如题目所说和A+B一样简单-插入排序水过)的相关文章

hdu 1040 As Easy As A+B

As Easy As A+B Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 53368    Accepted Submission(s): 22939 Problem Description These days, I am thinking about a question, how can I get a problem as

HDU 1040.As Easy As A+B【排序】【如题(水!水!水!)】【8月24】

As Easy As A+B Problem Description These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights. Give you some integers, your task is to s

杭电 HDU 1040 As Easy As A+B

As Easy As A+B Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 43019    Accepted Submission(s): 18379 Problem Description These days, I am thinking about a question, how can I get a problem as

HDU 1040 As Easy As A+B (排序。。。水题)

题意:给定n个数,让你从小到大排序. 析:不说什么了. 代码如下: #include <cstdio> #include <iostream> #include <cstring> #include <algorithm> #include <cmath> using namespace std; const int maxn = 1000 + 5; int a[maxn]; int main(){ int T, n; cin >>

hdu 1040 As Easy As A+B(排序)

题意:裸排序 思路:排序 #include<iostream> #include<stdio.h> #include<algorithm> using namespace std; int a[1000]; int main(){ int t,n,i; scanf("%d",&t); while(t--){ scanf("%d",&n); for(i=0;i<n;++i) scanf("%d&quo

HDU 1040

As Easy As A+B Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 35088 Accepted Submission(s): 15142 Problem Description These days, I am thinking about a question, how can I get a problem as easy a

杭电OJ(HDU)-ACMSteps-Chapter Two-《An Easy Task》《Buildings》《decimal system》《Vowel Counting》

http://acm.hdu.edu.cn/game/entry/problem/list.php?chapterid=1§ionid=2 1.2.5 #include<stdio.h> /* 题意:找闰年. if((i%4==0 && i%100!=0) || i%400==0)count++; 3 2005 25 1855 12 2004 10000 2108 1904 43236 */ int main() { int t,y,n; int i,count=0; whil

HDU 4565 So Easy!

线性推,矩阵乘法+快速幂求通项. 传送门:点击打开链接 #include <cstdio> #include <cstring> #include <cmath> #include <iostream> using namespace std; #define LL long long struct Mat{ LL f[2][2]; }; LL MOD; Mat mul(Mat a,Mat b) { LL i,j,k; Mat c; memset(c.f,0

HDU 5058 So easy (set容器大法好)

题目链接:HDU 5058 So easy 题意:给出两个序列,问这个两个序列构成的集合是否相同. set大法好! AC代码: #include<stdio.h> #include<set> #include<map> using namespace std; #define ll __int64 set<ll> ss1,ss2; set<ll>::iterator it; int main() { ll n,i; while(scanf(&qu