NYOJ592 spiral grid 【BFS】

spiral grid

时间限制:2000 ms  |  内存限制:65535 KB

难度:4

描述
Xiaod has recently discovered the grid named "spiral grid".

Construct the grid like the following figure. (The grid is actually infinite. The figure is only a small part of it.)

Considering traveling in it, you are free to any cell containing a composite number or 1, but traveling to any cell containing a prime number is disallowed. In addition, traveling from a prime number is disallowed,
either. You can travel up, down, left or right, but not diagonally. Write a program to find the length of the shortest path between pairs of nonprime numbers, or report it‘s impossible.

输入
Each test case is described by a line of input containing two nonprime integer 1 <=x, y<=10,000.
输出
For each test case, display its case number followed by the length of the shortest path or "impossible" (without quotes) in one line.
样例输入
1 4
9 32
10 12
样例输出
Case 1: 1
Case 2: 7
Case 3: impossible

构图的时候要格外细心。

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <queue>
#define abs(a) (a) > 0 ? (a) : -(a)
using std::queue;

int map[102][102], vis[102][102], prime[10002] = {1, 1};
int x, y, mov[][2] = {0, 1, 0, -1, 1, 0, -1, 0};
struct Node{
	int x, y, steps;
};
queue<Node> Q;

void preprocess(){
	//画图的时候要细心
	int count = 10000, x = 2, y = 2;
	for(int i = 1; i <= 100; ++i)
		map[1][i] = count--;
	for(int i = 2; i <= 100; ++i)
		map[i][100] = count--;
	for(int i = 99; i > 0; --i)
		map[100][i] = count--;
	for(int i = 99; i > 1; --i)
		map[i][1] = count--;
	map[2][2] = count--;
	while(count > 0){
		while(!map[x][y+1]) map[x][++y] = count--;
		while(!map[x+1][y]) map[++x][y] = count--;
		while(!map[x][y-1]) map[x][--y] = count--;
		while(!map[x-1][y]) map[--x][y] = count--;
	}
}

Node getX(){
	Node t = {0};
	for(int i = 1; i < 101; ++i)
		for(int j = 1; j < 101; ++j){
			if(map[i][j] == x){
				t.x = i; t.y = j;
				return t;
			}
		}
}

void getPrime(){
	for(int i = 2; i <= 100; ++i){
		if(prime[i]) continue;
		for(int j = i * i; j <= 10000; j += i)
			prime[j] = 1;
	}
}

int check(Node t){
	if(t.x < 1 || t.y < 1 || t.x > 100 || t.y > 100)
		return 0;
	if(vis[t.x][t.y] || !prime[map[t.x][t.y]])
		return 0;
	return 1;
}

void BFS(){
	Node temp, now;
	while(!Q.empty()) Q.pop();
	now = getX();
	if(x == y){
		printf("0\n"); return;
	}
	Q.push(now);

	while(!Q.empty()){
		now = Q.front();
		Q.pop();

		for(int i = 0; i < 4; ++i){
			temp = now;
			temp.x += mov[i][0];
			temp.y += mov[i][1];
			++temp.steps;

			if(check(temp)){
				if(map[temp.x][temp.y] == y){
					printf("%d\n", temp.steps);
					return;
				}
				vis[temp.x][temp.y] = 1;
				Q.push(temp);
			}
		}
	}
	printf("impossible\n");
}

int main(){
	getPrime();
	preprocess();
	int times = 1;
	while(scanf("%d%d", &x, &y) == 2){
		printf("Case %d: ", times++);
		memset(vis, 0, sizeof(vis));
		BFS();
	}
	return 0;
}

NYOJ592 spiral grid 【BFS】

时间: 2024-10-26 08:45:50

NYOJ592 spiral grid 【BFS】的相关文章

HDU1242 Rescue 【BFS】

Rescue Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16314    Accepted Submission(s): 5926 Problem Description Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is

【bfs】【中等难度】tyvj P1234 - bench与奔驰

P1234 - bench与奔驰 From zhangbh001    Normal (OI) 总时限:10s    内存限制:128MB    代码长度 限制:64KB P1234 - bench与奔驰 背景 Background 公园里有个人在练开奔驰 - -!,但是总是撞在bench上 (众人曰:狼来了,快跑啊!) 描述 Description 公园里的bench与奔驰都是无敌的,不会被撞坏.由于开奔驰的人比较"有特点",总是向上下左右四个方向开,而且只会在撞到椅子之后改变方向(

hdoj 1312 Red and Black 【BFS】

题意:一共有四个方向,从'@'出发,找能到达'.'的个数, #是不能通过的. 策略:广搜. 这道题属于最简单的bfs了. 代码: #include<stdio.h> #include<string.h> #include<queue> using std::queue; bool vis[25][25]; char s[25][25]; int n, m; int ans = 0; struct node{ int x, y; }; node st; const int

HDU 1253 胜利大逃亡 NYOJ 523【BFS】

胜利大逃亡 Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 24608    Accepted Submission(s): 9427 Problem Description Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会. 魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的

NYOJ 284 坦克大战 【BFS】+【优先队列】

坦克大战 时间限制:1000 ms  |  内存限制:65535 KB 难度:3 描述 Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. What we are discussing is a simple edition of this game. Given a map that co

【BFS】uva10047The Monocycle

/* 本题的特殊之处,到达一个格子时,因为朝向不同,以及接触地面的颜色不同, 会处于不同的状态::::::::: 把(x, y, d, c)作为一个结点,表示所在位置(x, y),方向为d,颜色为c;;;;; ------------------------------------------------------------------------ 在方向上我们把前,左,右编号为0,1,2:::: 颜色,从蓝色开始编号为0,1,2,3:::::::::: ------------------

【BFS】uva11624Fire!

/* bfs宽度遍历 -------------------------------------------------------------------------- 对人和火同时进行bfs,,注意应该先火后人,即如果在人到达该格子前,格子已经着火 则不应该走,最后人走到边界无路可走,则IMPOSSIBLE!!!!!!!!!!!! --------------------------------------------------------------------------- 两次bfs

【bfs】hdu 1104 Remainder

[bfs]hdu 1104 Remainder 题目链接:hdu 1104 Remainder 很不错的一道搜索题目,但是有几个关键问题要注意. 最短路径,果断bfs+Queue 路径的存储问题,之前只想把每一步的计算结果存储到queue(int)Q中,后来发现路径无法记录,就选择存储节点的方式并用string保存路径,queue(node)Q,开一个临时的节点node p,每进行一次运算就更新它的路径string+'op',最终输出的一定是完整路径!! 但最关键的是取模!!!!! discus

Poj 3087 Shuffle&#39;m Up 【BFS】

Shuffle'm Up Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 6556 Accepted: 3077 Description A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of pok