hdu 3037 Saving Beans 组合数取模模板题。。

Saving Beans

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2707    Accepted Submission(s): 1014

Problem Description

Although winter is far away, squirrels have to work day and night to save beans. They need plenty of food to get through those long cold days. After some time the squirrel family thinks that they have to solve a problem. They suppose
that they will save beans in n different trees. However, since the food is not sufficient nowadays, they will get no more than m beans. They want to know that how many ways there are to save no more than m beans (they are the same) in n trees.

Now they turn to you for help, you should give them the answer. The result may be extremely huge; you should output the result modulo p, because squirrels can’t recognize large numbers.

Input

The first line contains one integer T, means the number of cases.

Then followed T lines, each line contains three integers n, m, p, means that squirrels will save no more than m same beans in n different trees, 1 <= n, m <= 1000000000, 1 < p < 100000 and p is guaranteed to be a prime.

Output

You should output the answer modulo p.

Sample Input

2
1 2 5
2 1 5

Sample Output

3
3

Hint

Hint

For sample 1, squirrels will put no more than 2 beans in one tree. Since trees are different, we can label them as 1, 2 … and so on.
The 3 ways are: put no beans, put 1 bean in tree 1 and put 2 beans in tree 1. For sample 2, the 3 ways are:
 put no beans, put 1 bean in tree 1 and put 1 bean in tree 2.

尼玛看了一天,推导了一天。。真不容易

题解传送门:http://blog.csdn.net/wukonwukon/article/details/7341270

组合数取模需要用的到,

快速幂取模传送门:http://blog.csdn.net/lsldd/article/details/5506933

插板法:http://blog.sina.com.cn/s/blog_7cc6f2770100red3.html

费马小定理:http://baike.baidu.com/view/263807.htm

其中除法取模还需要求逆元。

代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
#define SIZE 100010
using namespace std ;
long long f[SIZE] ;

long long modPow(long long a , long long n , long long p)
{
	long long ret = 1 , A=a ;
	while(n)
	{
		if(n & 1)
			ret = (ret*A)%p ;
		A = (A*A)%p ;
		n >>= 1 ;
	}
	return ret ;
}

void fact(long long p)
{
	f[0] = 1 ;
	for(int i = 1 ; i <= p ; ++i)
	{
		f[i] = f[i-1]*i%p ;
	}
}

long long lucas(long long a , long long b , long long p)
{
	long long re = 1 ;
	while(a && b)
	{
		long long aa = a%p , bb = b%p ;
		if(aa<bb)
			return 0 ;
		re = re*f[aa]*modPow(f[bb]*f[aa-bb]%p,p-2,p)%p ;
		a /= p ;
		b /= p ;
	}
	return re ;
}

int main()
{
	int t ;
	scanf("%d",&t) ;
	while(t--)
	{
		long long n , m , p ;
		scanf("%lld%lld%lld",&n,&m,&p) ;
		fact(p) ;
		printf("%lld\n",lucas(n+m,m,p)) ;
	}
	return 0 ;
}

与君共勉

时间: 2024-10-10 22:09:30

hdu 3037 Saving Beans 组合数取模模板题。。的相关文章

HDU 3037 Saving Beans(Lucas定理模板题)

Problem Description Although winter is far away, squirrels have to work day and night to save beans. They need plenty of food to get through those long cold days. After some time the squirrel family thinks that they have to solve a problem. They supp

HDU 3037 Saving Beans (Lucas定理)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3037 推出公式为C(n + m, m) % p, 用Lucas定理求大组合数取模的值 代码: #include <stdio.h> #include <string.h> #include <algorithm> using namespace std; int t; long long n, m, p; long long pow(long long n, long lo

hdu 3037 Saving Beans(组合数学)

hdu 3037 Saving Beans 题目大意:n个数,和不大于m的情况,结果模掉p,p保证为素数. 解题思路:隔板法,C(nn+m)多选的一块保证了n个数的和小于等于m.可是n,m非常大,所以用到Lucas定理. #include <cstdio> #include <cstring> #include <algorithm> using namespace std; typedef long long ll; ll n, m, p; ll qPow (ll a

HDU 3037 Saving Beans(lucas定理)

题目大意:豆子数i (1~m)分到n颗树上.  树可以为空,那么对于每个i,分配方式是 C(n+i-1,n-1)......于是我用for(i=0-->m)做,不幸超时,m太大. 不过竟然公式可以化简: for(int i=0;i<=m;i++) C(n+i-1,n-1)=C(n+i-1,i) 组合原理: 公式 C(n,k) = C(n-1,k)+C(n-1,k-1) C(n-1,0)+C(n,1)+...+C(n+m-1,m) = C(n,0)+C(n,1)+C(n+1,2)+...+C(n

HDU 3037 Saving Beans (Lucas法则)

主题链接:pid=3037">http://acm.hdu.edu.cn/showproblem.php?pid=3037 推出公式为C(n + m, m) % p. 用Lucas定理求大组合数取模的值 代码: #include <stdio.h> #include <string.h> #include <algorithm> using namespace std; int t; long long n, m, p; long long pow(lo

HDU 3037 Saving Beans(Lucas定理的直接应用)

解题思路: 直接求C(n+m , m) % p , 由于n , m ,p都非常大,所以要用Lucas定理来解决大组合数取模的问题. #include <string.h> #include <iostream> #include <algorithm> #include <vector> #include <queue> #include <set> #include <map> #include <string&g

[ACM] hdu 3037 Saving Beans (Lucas定理,组合数取模)

Saving Beans Problem Description Although winter is far away, squirrels have to work day and night to save beans. They need plenty of food to get through those long cold days. After some time the squirrel family thinks that they have to solve a probl

HDU 3037 Saving Beans 多重集合的结合 lucas定理

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=3037 题目描述: 要求求x1 + x2 + x3 + ...... + xn <= m 非负整数解的个数, 结果对P取模, 输入的变量是n, m, p, P一定是素数 解题思路: x1 + ... + xn = m 非负整数解的个数是C(n+m-1, n) , 所以答案就是 C(n+0-1, 0) + C(n+1-1, 1) + ...... C(n+m-1, n) 对P取模, 由于组合数公式C(

HDU 3037 Saving Beans

/* hdu3037 http://acm.hdu.edu.cn/showproblem.php?pid=3037 lucas 模板题 */ #include <cstdio> #include <cmath> const long long Nmax=100005; long long p; long long ex_gcd(long long a,long long b,long long &x,long long &y)//solve x,y in a*x+b