分组并查集 hdu 1829

A Bug‘s Life

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 10063    Accepted Submission(s): 3288

Problem Description

Background

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy
to identify, because numbers were printed on their backs.

Problem

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space.
In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption
about the bugs‘ sexual behavior, or "Suspicious bugs found!" if Professor Hopper‘s assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

Source

TUD Programming Contest 2005, Darmstadt, Germany

题意:

t组数据,每组n个人,m对有暧昧关系的,问是否存在 gay ?

代码如下:

//考察知识点:分组并查集,听说有两种办法,但是只会这一种
//相较于一般的并查集,分组并查集,在查找父节点的函数方面没有做改动,
//在合并的时候 出现了选择性。主要改变在于merge函数上面。
//变动为
/*
void merge(int x,int y)
{
	int fx=find(x);
	int fy=find(y-max);
	if(fx==fy)
	{
		flag=0;
		return ;
	}
	fy=find(y);
	if(fx!=fy)
	father[fx]=fy;
}
*/ 

#include<stdio.h>
#define max 2020
int father[2*max];
int flag;
int find(int x)
{
	int r=x;
	while(r!=father[r])
	r=father[r];
	return r;
}
void merge(int x,int y)
{
	int fx=find(x);
	int fy=find(y-max);
	if(fx==fy)
	{
		flag=0;
		return ;
	}
	fy=find(y);
	if(fx!=fy)
	{
		father[fx]=fy;
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	int a,b,m,n,count=1;
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(int i=1;i<=max+n;++i)
		{
			father[i]=i;
		}
		flag=1;
		for(int i=1;i<=m;++i)
		{
			scanf("%d%d",&a,&b);
			if(flag)
			{
				merge(a,b+max);
				merge(b,a+max);
			}
		}
		printf("Scenario #%d:\n",count++);
		if(flag)
		{
			printf("No suspicious bugs found!\n\n");
		}
		else
		printf("Suspicious bugs found!\n\n");
	}
	return 0;
}
时间: 2024-11-10 01:31:45

分组并查集 hdu 1829的相关文章

(并查集) hdu 1829

A Bug's Life Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 9503    Accepted Submission(s): 3048 Problem Description Background Professor Hopper is researching the sexual behavior of a rare sp

hdu 1829 A Bug&#39;s Life(分组并查集(偏移量))

A Bug's Life Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 9204    Accepted Submission(s): 2961 Problem Description Background Professor Hopper is researching the sexual behavior of a rare sp

HDU1829 - A Bug&#39;s Life 分组并查集

HDU1829 - A Bug's Life : http://acm.hdu.edu.cn/showproblem.php?pid=1829 题意:首先输入T,接下来是T组测试数据.每组测试数据第一行输入N,M代表共有N个人,接下来有M行输入.每行有两个数a和b,代表编号为a和b的两个人是异性.输入结束后判断是否存在错误的信息.如N = 3,M = 3,接下来是3组输入.1  2,2  3,1  3.此组数据是错的,因为1 和 3都和2是异性,说明1 和 3是同性,但第三组数据又说1和3是异性

并查集 -- HDU 1232 UVALA 3644

并查集: 1 int pa[maxn],Rank[maxn]; 2 ///初始化 x 集合 3 void make_set(int x) 4 { 5 pa[x]=x; 6 Rank[x]=0; 7 } 8 ///递归查找 x 所在的集合 9 int find_set(int x) 10 { 11 if(pa[x]!=x) pa[x]=find_set(pa[x]); 12 return pa[x]; 13 } 14 ///更新根节点,如果不更新可能会暴栈 15 void mix(int x,in

集合问题 离线+并查集 HDU 3938

题目大意:给你n个点,m条边,q个询问,每条边有一个val,每次询问也询问一个val,定义:这样条件的两个点(u,v),使得u->v的的价值就是所有的通路中的的最长的边最短.问满足这样的点对有几个. 思路:我们先将询问和边全部都按照val排序,然后我们知道,并查集是可以用来划分集合的,所以我们就用并查集来维护每一个集合就行了. //看看会不会爆int!数组会不会少了一维! //取物问题一定要小心先手胜利的条件 #include <bits/stdc++.h> using namespac

并查集 hdu 1856

More is better Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others) Total Submission(s): 16863    Accepted Submission(s): 6205 Problem Description Mr Wang wants some boys to help him with a project. Because the projec

(并查集) hdu 2473

Junk-Mail Filter Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 6389    Accepted Submission(s): 2025 Problem Description Recognizing junk mails is a tough task. The method used here consists o

(枚举+并查集) hdu 1598

find the most comfortable road Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4096    Accepted Submission(s): 1768 Problem Description XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超级

(并查集) hdu 4750

Count The Pairs Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)Total Submission(s): 952    Accepted Submission(s): 422 Problem Description   With the 60th anniversary celebration of Nanjing University of Science