Wormholes POJ 3259【SPFA】

http://poj.org/problem?id=3259

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ‘s farms
comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000
seconds.

Input

Line 1: A single integer, FF farm descriptions follow.

Line 1 of each farm: Three space-separated integers respectively: NM, and W

Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected
by more than one path.

Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES


/*
题目大意:虫洞问题,如今有n个点。m条边,
代表如今能够走的通路。比方从a到b和从b到a须要花费c时间,
如今在地上出现了w个虫洞,
虫洞的意义就是你从a到b花费的时间是-c(时间倒流,而且虫洞是单向的)。如今问你从某个点開始走,能回到从前

事实上就是推断是否存在负环
*/
#include <cstdio>
#include <cstring>
#include <queue>
#define MAXN 550
#define MAXM 10000
#define INF 0x3f3f3f3f
using namespace std;
struct Edge
{
	int u, v, w;
	int next;//下一个结构体变量的下标
}edge[MAXM];
int head[MAXN];//下标为起点u,值为相应结构体下标
int vis[MAXN];//推断是否增加队列了
int used[MAXN];
int num;
int N;
int low[MAXN];//存最短路径
void Add_Edge(int u, int v, int w)//加边
{
	Edge E={u, v, w, head[u]};//初始化结构体
	edge[num]=E;//直接赋值
	head[u]=num++;
}
bool SPFA(int s)
{
	int i, j;
	queue<int> Q;
	memset(low, INF, sizeof(low));
	memset(vis, 0, sizeof(vis));
	memset(used,0,sizeof(used));
	vis[s] = 1;
	low[s]=0;
	Q.push(s);
	used[s]++;
	while(!Q.empty())
	{
		int u=Q.front();
		Q.pop();
		vis[u]=0;//出队列了,不在队列就变成0
		for(j = head[u]; j != -1; j = edge[j].next)
		{
			int v = edge[j].v;
			if(low[v] > low[u] + edge[j].w)
			{
				low[v] = low[u] + edge[j].w;
				if(!vis[v] )
			 	{
			 		vis[v]=1;
			 		Q.push(v);
			 		used[v]++;
			 		if(used[v]>N) return 0;
			 	}
			}
		}
	}
	return 1;
}
int main()
{
	int u, v, w;
	int T;
	int M, W;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d%d", &N, &M, &W);
		memset(head, -1, sizeof(head));
		num=0;
		while(M--)
		{
			scanf("%d%d%d", &u, &v, &w);
			Add_Edge(u, v, w);
			Add_Edge(v, u, w);//无向边
		}
		while(W--)
		{
			scanf("%d%d%d", &u, &v, &w);
			Add_Edge(u, v, -w);
		}
		if(!SPFA(1)) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}

时间: 2024-11-09 11:02:47

Wormholes POJ 3259【SPFA】的相关文章

POJ 2449 Remmarguts&#39; Date【SPFA】【A*】

Remmarguts' Date Time Limit: 4000MS Memory Limit: 65536K Total Submissions: 21978 Accepted: 5982 Description "Good man never makes girls wait or breaks an appointment!" said the mandarin duck father. Softly touching his little ducks' head, he to

POJ2253&amp;ZOJ1942--Frogger【SPFA】单源最短路变形

链接:http://poj.org/problem?id=2253 题意:一个青蛙在一块石头上,看到了另一个青蛙在另一块石头上,它想跳过去找它,如果距离太远它就需要借助别的石头当跳板,两块石头之间的青蛙距离被定义成两块石头之间所有路径中最大跳跃距离的最小值,求两个青蛙之间的青蛙距离. poj2263和它类似,链接:http://poj.org/problem?id=2263 解题报告:Here 这是最短路的变形,每两点之间都有路可以跳,更新最短路的值,权值记录成目前到这一点的最小青蛙距离就行了

HDU1224 Free DIY Tour 【SPFA】

Free DIY Tour Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3939    Accepted Submission(s): 1262 Problem Description Weiwei is a software engineer of ShiningSoft. He has just excellently fulf

boj 454 帮帮小叮当【SPFA】

题目链接:http://code.bupt.edu.cn/problem/p/454/ 454. 帮帮小叮当 时间限制5000 ms 内存限制 65536 KB 题目描述 小叮当刚刚学会了传送门的使用方法,可是它不小心跌落到二维空间一个 n * m 的矩阵格子世界的入口(1,1)处, 他得知出口在(n,m)处,每穿越一个格子门,它的体力值会下降. 又饿又累的他 IQ 已经降为负数了,聪明的你,能帮他规划一下路线,使得它体力值下降的最少吗? 每一行有且仅有一个传送门,但是小叮当上课睡着了,只学会了

HDU1142 A Walk Through the Forest 【SPFA】+【记忆化搜索】

A Walk Through the Forest Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5688    Accepted Submission(s): 2089 Problem Description Jimmy experiences a lot of stress at work these days, especial

HDU1217 Arbitrage 【SPFA】

Arbitrage Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4460    Accepted Submission(s): 2032 Problem Description Arbitrage is the use of discrepancies in currency exchange rates to transform

HDU3339 In Action 【SPFA】+【01背包】

In Action Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4099    Accepted Submission(s): 1306 Problem Description Since 1945, when the first nuclear bomb was exploded by the Manhattan Project

POJ 2411【题解】Mondriaan&#39;s Dream 状压DP

题目链接:http://poj.org/problem?id=2411 把每一行当作一个二进制状态. 1表示是一个竖着的1*2的方格. 0表示其他状态. 那么显然当i-1的状态k能转移到i的j: 1.j 和 k 的按位与为0.(有1必须要0,0也可以有1) 2.j 和 k 按位或每一段0都有偶数个.(表示横着的长方形) 那么就可以预处理一下合格的点. 然后状压DP. 代码如下: #include<cstdio> using namespace std; int n,m; long long f

【SPFA】POJ1860-Currency Exchange

[题目大意] 给出每两种货币之间交换的手续费和汇率,求出从当前货币s开始交换,能否赚. [思路] 反向运用SPFA,判断是否有正环.每次队首元素出队之后,判断一下到源点s的距离是否增大,增大则返回true.一开始判断正环的思路如果有一个元素入队超过n次,则说明存在正环.后来发现这个思路是不适用的,因为这个正环中并不一定包含源点..要注意的是:题目中的m并不是边数,边数应该是m*2!所以开数组的时候要尤其注意数组不能开小了.由于C++的判定中如果没有崩掉,不会返回RE只会返回WA,我纠结了好久才找