POJ2375 Cow Ski Area (强连通)(缩点)

Cow Ski Area

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3323   Accepted: 919

Description

Farmer John‘s cousin, Farmer Ron, who lives in the mountains of Colorado, has recently taught his cows to ski. Unfortunately, his cows are somewhat timid and are afraid to ski among crowds of people at the local resorts, so FR has decided to construct his own private ski area behind his farm.

FR‘s ski area is a rectangle of width W and length L of ‘land
squares‘ (1 <= W <= 500; 1 <= L <= 500). Each land square
is an integral height H above sea level (0 <= H <= 9,999). Cows
can ski horizontally and vertically between any two adjacent land
squares, but never diagonally. Cows can ski from a higher square to a
lower square but not the other way and they can ski either direction
between two adjacent squares of the same height.

FR wants to build his ski area so that his cows can travel between
any two squares by a combination of skiing (as described above) and ski
lifts. A ski lift can be built between any two squares of the ski area,
regardless of height. Ski lifts are bidirectional. Ski lifts can cross
over each other since they can be built at varying heights above the
ground, and multiple ski lifts can begin or end at the same square.
Since ski lifts are expensive to build, FR wants to minimize the number
of ski lifts he has to build to allow his cows to travel between all
squares of his ski area.

Find the minimum number of ski lifts required to ensure the cows can
travel from any square to any other square via a combination of skiing
and lifts.

Input

* Line 1: Two space-separated integers: W and L

* Lines 2..L+1: L lines, each with W space-separated integers corresponding to the height of each square of land.

Output

*
Line 1: A single integer equal to the minimal number of ski lifts FR
needs to build to ensure that his cows can travel from any square to any
other square via a combination of skiing and ski lifts

Sample Input

9 3
1 1 1 2 2 2 1 1 1
1 2 1 2 3 2 1 2 1
1 1 1 2 2 2 1 1 1

Sample Output

3SB题,还花了好长时间,不开心,不写题解了。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <time.h>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#define inf 0x3f3f3f3f
#define mod 10000
typedef long long ll;
using namespace std;
const int N=505;
const int M=250005;
int s,t,n,m,cnt,tim,top,cut,k;
int head[M],dfn[M],low[M],stack1[M];
int num[M],in[M],out[M],vis[M],w[N][N];
int dis[4][2]= {0,1,1,0,-1,0,0,-1};
bool flag=false;
struct man {
    int to,nxt;
} edg[M*10];
void addedg(int u,int v) {
    edg[cnt].to=v;
    edg[cnt].nxt=head[u];
    head[u]=cnt++;//printf("!!!%d %d\n",u,v);system("pause");
}
void init() {
    cnt=0;
    tim=0;
    top=cut=k=0;
    memset(head,-1,sizeof head);
    memset(dfn,0,sizeof dfn);
    memset(low,0,sizeof low);
    memset(stack1,0,sizeof stack1);
    memset(num,0,sizeof num);
    memset(in,0,sizeof in);
    memset(out,0,sizeof out);
    memset(vis,0,sizeof vis);
    memset(edg,0,sizeof edg);
    memset(w,0,sizeof w);
}
void Tarjan(int u) {
    int v;
    low[u] = dfn[u] = ++tim;
    stack1[top++] = u;
    vis[u] = 1;
    for(int e = head[u]; e != -1; e = edg[e].nxt)
    {
        v = edg[e].to;
        if(!dfn[v])
        {
            Tarjan(v);
            low[u] = min(low[u], low[v]);
        }
        else if(vis[v])
        {
            low[u] = min(low[u], dfn[v]);
        }
    }
    if(low[u] == dfn[u])
    {
        cut++;
        do
        {
            v = stack1[--top];
            num[v] = cut;
            vis[v] = 0;
        }while(u != v);
    }
}
void build(int i,int j,int d)
{
    int xx=i+dis[d][0];
    int yy=j+dis[d][1];
    int u=i*m+j,v=xx*m+yy;
    if(xx>=0&&yy<m&&yy>=0&&xx<n){
        if(w[i][j]>=w[xx][yy])addedg(u,v);
        if(w[i][j]<=w[xx][yy])addedg(v,u);
    }
    return;
}
int main() {
    while(~scanf("%d%d",&m,&n)) {
        init();
        for(int i=0; i<n; i++) {
            for(int j=0; j<m; j++) {
                scanf("%d",&w[i][j]);
            }
        }
        for(int i = 0; i < n; i++) {
            for(int j = 0; j < m; j++) {
                for(int d = 0; d < 2; d++) {
                    build(i,j,d);
                }
            }
        }
        for(int i=0; i<n*m; i++)if(!dfn[i])Tarjan(i);
        for(int i=0; i<n*m; i++) {
            for(int j=head[i]; j!=-1; j=edg[j].nxt) {
                int v=edg[j].to;
                if(num[i]!=num[v])out[num[i]]++,in[num[v]]++;
            }
        }
        int father=0,son=0;
        for(int i=1; i<=cut; i++) {
            if(in[i]==0)father++;
            if(out[i]==0)son++;
        }
        if(cut==1)printf("0\n");
        else printf("%d\n",max(father,son));
    }
    return 0;
}
时间: 2024-10-11 13:21:52

POJ2375 Cow Ski Area (强连通)(缩点)的相关文章

POJ2375 Cow Ski Area 【强连通分量】+【DFS】

Cow Ski Area Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 2323   Accepted: 660 Description Farmer John's cousin, Farmer Ron, who lives in the mountains of Colorado, has recently taught his cows to ski. Unfortunately, his cows are some

POJ 2375 Cow Ski Area (强连通分量)

题目地址:POJ 2375 对每一个点向与之相邻并h小于该点的点加有向边. 然后强连通缩点.问题就转化成了最少加几条边使得图为强连通图,取入度为0和出度为0的点数的较大者就可以.注意,当强连通分量仅仅有一个的时候.答案是0,而不是1. 代码例如以下: #include <iostream> #include <string.h> #include <math.h> #include <queue> #include <algorithm> #in

POJ2375 Cow Ski Area (添最少边构造强连通分量的某个与入度出度相关的结论)

题意:本题描述了一片滑雪场,并且规定奶牛从一个点只能向它相邻的并且高度不大于它的点运动,现在想要在某些点对之间加上缆车使得奶牛也可以从较低点到达较高点,问最少需要多少辆这样的缆车就可以使得奶牛可以从任意一个点运动到滑雪场的每个角落. 思路:即问至少加多少条边使图变成强联通图,先缩点成DAG. 不难知道强连通分量的所有节点的入度和出度均不为0,可以统计DAG上的入度和出度为0的个数分别是a,b.然后答案即为max(a,b). 只是发现入度为0和出度为0的点可以按某种方式相连接总能构造出一个强连通分

POJ2375 Cow Ski Area【Tarjan】【强连通分量】

题目链接: http://poj.org/problem?id=2375 题目大意: 有一片供奶牛滑雪的滑雪场,可供滑雪的区域是W(宽)*L(长)的矩阵.上边有W*L个点.规定 奶牛从一个点只能向它上.下.左.右相邻的并且高度不大于它的点运动.现在想要在某些 点对之间架设缆车,使得奶牛可以从较低的地方想较高的地方运动,那么问题来了:最少需 要多少辆这样的缆车就可以使奶牛从每个点运动到可供滑雪区域的每个角落. 思路: 把奶牛符合从点u移动到点v的条件当做一条单向边.那么所有点和边就可以构成有向图.

POJ 2375 Cow Ski Area(强连通)

POJ 2375 Cow Ski Area 题目链接 题意:给定一个滑雪场,每个点能向周围4个点高度小于等于这个点的点滑,现在要建电缆,使得任意两点都有路径互相可达,问最少需要几条电缆 思路:强连通缩点,每个点就是一个点,能走的建边,缩点后找入度出度为0的个数的最大值就是答案,注意一开始就强连通了答案应该是0 代码: #include <cstdio> #include <cstring> #include <stack> #include <algorithm&

D - Cow Ski Area

Description Farmer John's cousin, Farmer Ron, who lives in the mountains of Colorado, has recently taught his cows to ski. Unfortunately, his cows are somewhat timid and are afraid to ski among crowds of people at the local resorts, so FR has decided

POJ 2375 Cow Ski Area【tarjan】

题目大意:一个W*L的山,每个山有个高度,当且仅当一个山不比它相邻(有公共边的格子)的山矮时能够滑过去,现在可以装化学电梯来无视山的高度滑雪,问最少装多少电梯使得任意两点都可到达 思路:最后一句话已经把强连通模型裸裸地说出来了 那问题变成了一个图最小加几条边变成强连通图的经典问题,比较一下出度为0和入度为0的点的个数的大小即可,还有个特例只有一个SCC的情况 #include<cstdio> #include<string.h> #include<iostream> #

poj2186 强连通缩点

Popular Cows Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 29141   Accepted: 11779 Description Every cow's dream is to become the most popular cow in the herd. In a herd of N (1 <= N <= 10,000) cows, you are given up to M (1 <= M &

Light OJ 1168 Wishing Snake 强连通缩点+哈密顿通路

题目来源:Light OJ 1168 Wishing Snake 题意:有点难看懂题意 看了一个小时再加别人的代码才懂意思 从0开始 输入的那些每一对u v 都要经过 就是从0到到达那些点 思路:首先缩点 每一个强连通分量里面的点都是可达的 缩点后的图是有向无环图 如果从0这个强连通分量可以出去到2个强连通分量 那么这两个强连通分量是不可能相互可达 所以可行的方案就是所有的强连通分量连成一线 一个一个串起来 除了第一个 出度是1入度是0和最后一个出度是0入度是1 其他都是入度等于出度是1 特判只