ADB启动不起来的问题

Problem Description

We have a special convex that all points have the same distance to origin point.

As you know we can get N segments after linking the origin point and the points on the convex. We can also get N angles between each pair of the neighbor segments.

Now give you the data about the angle, please calculate the area of the convex.

Input

There are multiple test cases.

The first line contains two integer N and D indicating the number of the points and their distance to origin. (3 <= N <= 10, 1 <= D <= 10)

The next lines contains N integers indicating the angles. The sum of the N numbers is always 360.

Output

For each test case output one float numbers indicating the area of the convex. The printed values should have 3 digits after the decimal point.

Sample Input

4 1
90 90 90 90
6 1
60 60 60 60 60 60

Sample Output

2.000
2.598
多边形分成多个三角形,利用面积s=1/2*d*d*sin(角度的弧度)
#include<stdio.h>
#include<math.h>
#define PI 3.1415926
int main()
{
    int n;
    double d,c,sum;
    while(scanf("%d%lf",&n,&d)>0)
    {
        sum=0;
        while(n--)
        {
            scanf("%lf",&c);
            sum+=sin(c/180*PI);
        }
        sum=sum/2*d*d;
        printf("%.3lf\n",sum);
    }
}

ADB启动不起来的问题

时间: 2024-10-17 08:08:51

ADB启动不起来的问题的相关文章

android下使用adb启动程序或者服务

使用 adb install hello.apk可以安装一个apk但并不能启动它,启动它要使用adb shell am的方法 启动Activity: adb shell am start -n 包名/包名+类名(-n 类名,-a action,-d date,-m MIME-TYPE,-c category,-e 扩展数据,等). 比如 adb shell am start -n AndroidExport.com/AndroidExport.com.AndroidExportActivity

adb 启动失败的原因和修改adb端口号

在我们使用Android Studio的时候,有时候就会出现adb打开失败或者启动不了的情况. adb 启动失败的原因:有其他程序占用了adb默认启动的端口号(像我就遇到过,每次只要提前启动了酷狗音乐,adb就会启动失败~这是要我们专心写代码,不要边听歌边撸0.0) 打不开的情况下的解决方案就是打开Android Studio的Terminal终端 使用以下命令: //关闭adb服务 adb kill-server //再重启adb服务 adb start-server 结果:(终端输出以下代码

adb命令查看apk信息, adb启动你的apk

1.用adb获得手机里面某个apk的应用信息.版本信息 adb shell dumpsys package com.sy.a268 2.列出所有 adb shell dumpsys 3.用adb启动apk adb shell am start -n com.sy.a268/com.sy.a268.MainActivity 4.随机产生事件给某个应用程序, 随机产生500个事件给程序.你会发现你的程序不断的被点击,旋转! adb  shell  monkey -p  com.sy.a268  -v

Android DDMS ADB启动失败错误解决!

ADB server didn't ACK && make sure the plugin is properly configured! adb启动失败一般是端口被占用! 解决方法和步骤: 1.输入命令netstat -ano | findstr "5037"  2.查看到端口2152被占用. 输入命令TASKLIST | findstr "2152"获取到最终被占用的进程名称,在任务管理器中结束进程,重启adb即可.

adb启动activity、service、发送broadcast

一.adb启动activity: $ adb shell$ am start -n {包(package)名}/{包名}.{活动(activity)名称} 如:启动浏览器 # am start -n com.android.browser/com.android.browser.BrowserActivity 二.adb启动service: $ adb shell$ am startservice -n {包(package)名}/{包名}.{服务(service)名称} 如:启动自己应用中一个

Android Studio ADB启动失败解决方法

在用Android studio启动自己的Android代码的时候,出现adb not responding. 解决方法: 1.输入netstat -aon|findstr "5037",可以看到进程号为5196的进程(这个进程号因机器和时间而异)在占用5037端口(adb需要使用此端口). 2.打开任务管理器,选择“进程”选项卡,点击选项栏“查看-选择列...”,勾选“PID(进程标识符)”,点确定.会看到每个进程都会显示它们的PID了.找到进程号为5196的进程,结束这个进程,ki

关于通过adb启动Activity、activity、service以及发送broadcast的命令

一.启动activity: $ adb shell$ am start -n {包名}/{包名}.{活动名称} 如:启动一个名叫MainActivity的活动 # am start -n com.example.test/com.example.test.MainActivity 二.启动service: $ adb shell$ am startservice -n {包名}/{包名}.{服务名称} 如:启动一个名叫MyService的服务 # am startservice -n com.e

用adb 启动camera

adb shell am start -a android.media.action.STILL_IMAGE_CAMERA  启动camera adb shell input keyevent 27 //camera 键 adb shell input keyevent 4  //back 键 com.android.camera2  是高通camera的packge 名 adb uninstall com.android.camera2

PC端使用adb启动和关闭Android机顶盒上的软件。

1.启动一个程序使用命令: adb shell am start 包名/类名 或分两步走: $ adb shell      $ am start -n {包(package)名}/{包名}.{活动(activity)名称} 2.关闭一个程序: adb shell am force-stop  包名