HDU 3974 Assign the task(并查集)

Problem Description

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are
your subordinates as well. If you are nobody‘s boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever
a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.

Input

The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)

Output

For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.

Sample Input

1
5
4 3
3 2
1 3
5 2
5
C 3
T 2 1
 C 3
T 3 2
C 3

Sample Output

Case #1:
-1
1
2

题意:给你一些属性关系,一但上级被派了某项任务,那么他的所有下属都被

派了这项任务,对于操作(T,X,Y)我们记录此操作节点的被赋予的任务和时间戳。

找某个节点在做什么任务时就找所有上级中最近的时间戳。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<string>
#include<iostream>
#include<queue>
#include<cmath>
#include<map>
#include<stack>
#include<bitset>
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
typedef long long LL;
typedef pair<int,int>pil;
const int maxn=50000+100;
struct node{
    int val;
    int time;
}e[maxn];
int pre[maxn];
int t,n,m;
int main()
{
    int x,y;
    int cas=1;
    char str[3];
    scanf("%d",&t);
    while(t--)
    {
        CLEAR(pre,-1);
        scanf("%d",&n);
        REPF(i,1,n)
        {
            e[i].val=-1;
            e[i].time=-1;
        }
        REPF(i,1,n-1)
        {
            scanf("%d%d",&x,&y);
            pre[x]=y;
        }
        scanf("%d",&m);
        int T=0;
        printf("Case #%d:\n",cas++);
        while(m--)
        {
            scanf("%s",str);
            if(str[0]=='T')
            {
                scanf("%d%d",&x,&y);
                e[x].val=y;
                e[x].time=++T;
            }
            else
            {
                scanf("%d",&x);
                int val=e[x].val;
                int time=e[x].time;
                while(x!=-1)
                {
                    if(e[x].time>time)
                    {
                        val=e[x].val;
                        time=e[x].time;
                    }
                    x=pre[x];
 //                   cout<<"fuck "<<endl;
                }
                printf("%d\n",val);
            }
        }
    }
    return 0;
}
时间: 2024-10-18 12:30:48

HDU 3974 Assign the task(并查集)的相关文章

HDU 3974 Assign the task 并查集/图论/线段树

Assign the task Time Limit: 1 Sec  Memory Limit: 256 MB 题目连接 http://acm.hdu.edu.cn/showproblem.php?pid=3974 Description There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the l

HDU 3974 Assign the task(树 并查集)

题意  公司中有n个员工  除了boss  每个员工都有自己的上司  自己下属的下属也是自己的下属  当给一个员工分配任务时  这个员工会把任务也分配到自己的所有下属   每个员工都只做最后一个被分配的任务  对于每个C x  输出员工x正在做的任务  没有就输出-1 把员工的关系数建成类似并查集的结构  把每个直接分配任务的员工的任务和任务分配时间保存起来  查询时只要找这个员工所有父节点中最晚分配的任务 #include <bits/stdc++.h> using namespace st

HDU 3974 Assign the task

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3974 解题思路:深搜设置时间戳,然后线段树上更新查询即可. 第一次写,还算顺利(尽管wa了两发). 代码: 1 const int maxn = 5e4 + 5; 2 //静态链表前向星保存图 3 struct Edge{ 4 int to, next; 5 int val; 6 }; 7 int head[maxn], tot; 8 Edge edges[maxn]; 9 //dfs 时间戳 -

hdu 3974 Assign the task(线段树)

题目链接 http://acm.hdu.edu.cn/showproblem.php?pid=3974 题意:给定一棵树,50000个节点,50000个操作,C x表示查询x节点的值,T x y表示更新x节点及其子节点的值为y 大致把边存一下那一棵树来举例子 2 3 5 4 1 例如像这样的一棵树,可以将2->1,3->2,4->3,1->4,5->5按照dfs序来编号,然后用线段树进行区间修改,稍微想一想 应该都会了. #include <iostream> #

HDU 3974 Assign the task(线段树)

描述There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordin

HDU 3974 Assign the task(dfs编号+线段树成段更新)

题意:给定点的上下级关系,规定如果给i分配任务a,那么他的所有下属.都停下手上的工作,开始做a. 操作 T x y 分配x任务y,C x询问x的当前任务: Sample Input 1 5 4 3 3 2 1 3 5 2 5 C 3 T 2 1 C 3 T 3 2 C 3 Sample Output Case #1: -1 1 2 思路: 利用dfs深度优先遍历重新编号,使一个结点的儿子连续.然后成段更新. 2:1-5 5:2-2 3:3-5 1:4-4 4:5-5 #include<iostr

HDU 3974 Assign the task(dfs时间戳+线段树成段更新)

题意:给定点的上下级关系,规定假设给i分配任务a.那么他的全部下属.都停下手上的工作,開始做a. 操作 T x y 分配x任务y,C x询问x的当前任务: Sample Input 1 5 4 3 3 2 1 3 5 2 5 C 3 T 2 1 C 3 T 3 2 C 3 Sample Output Case #1: -1 1 2 思路: 利用dfs深度优先遍历又一次编号.使一个结点的儿子连续. 然后成段更新. 代码: #include<iostream> #include<cstdio

HDU 3974 Assign the task 简单搜索

根据Rex 的思路才知道可以这么写. 题目意思还是很好理解的,就是找到当前雇员最近的任务. 做法是,可以开辟一个 tim 变量,每次有雇员得到昕任务时候 ++tim 然后取寻找最近的任务的时候写一个搜索就可以 核心代码: while(num != -1){ num = a[num].leader; if(ttime < a[num].time){ ans = a[num].work; ttime = a[num].time; } } Source code: //#pragma comment(

HDU - 3974 Assign the task (线段树区间修改+构建模型)

https://cn.vjudge.net/problem/HDU-3974 题意 有一棵树,给一个结点分配任务时,其子树的所有结点都能接受到此任务.有两个操作,C x表示查询x结点此时任务编号,T x y表示给x结点分配编号为y的任务. 分析 题目读起来就很有区间修改的味道,将一个区间变为一个值.问题在于怎么把这棵树对应到区间上. 对于一个结点,其控制的范围是它的子树,对应区间范围可以看作是以dfs序表示的区间.好像有点绕..就是给每个结点再对应一个dfs序,然后在dfs时把这个点控制的子树看