Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, … , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, …
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1
Scenario #2:
impossible
Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
解题思路
水DFS。注意搜索的顺序,因为要求字典序输出!
代码
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 30;
int vis[maxn][maxn];
int kase = 0;
int width,high;
int cnt;
struct node {
int x;
char y;
};
node s[maxn*maxn];
bool dfs(int x,int y)
{
if(x < 1 || x > high || y < 1 || y > width) return false;
if(vis[x][y] == 1) return false;
s[cnt].x = x;
vis[x][y] = 1;
s[cnt++].y = y+‘A‘-1;
if(cnt == width*high) return true;
if(dfs(x-1,y-2) || dfs(x+1,y-2) || dfs(x-2,y-1) || dfs(x+2,y-1) || dfs(x-2,y+1) || dfs(x+2,y+1) || dfs(x-1,y+2) || dfs(x+1,y+2)) return true;
cnt --;
vis[x][y] = 0;
return false;
}
int main()
{
int n;
scanf("%d",&n);
while(n--) {
for(int i = 0 ; i < maxn*maxn ; i ++) {
s[i].x = 0;
s[i].y = 0;
}
memset(vis,0,sizeof(vis));
scanf("%d%d",&high,&width);
printf("Scenario #%d:\n",++kase);
cnt = 0;
if(!dfs(1,1)) {printf("impossible\n");if(n!=0)printf("\n");continue;}
for(int i = 0 ; i < cnt ; i ++) printf("%c%d",s[i].y,s[i].x);
printf("\n");
if(n != 0) printf("\n");
}
return 0;
}
POJ2488 A Knight's Journey 骑士巡游 DFS