POJ2488 A Knight's Journey 骑士巡游 DFS

Description

Background

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, … , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, …

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.

If no such path exist, you should output impossible on a single line.

Sample Input

3

1 1

2 3

4 3

Sample Output

Scenario #1:

A1

Scenario #2:

impossible

Scenario #3:

A1B3C1A2B4C2A3B1C3A4B2C4

解题思路

水DFS。注意搜索的顺序,因为要求字典序输出!

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 30;
int vis[maxn][maxn];
int kase = 0;
int width,high;
int cnt;
struct node {
    int x;
    char y;
};
node s[maxn*maxn];
bool dfs(int x,int y)
{
    if(x < 1 || x > high || y < 1 || y > width) return false;
    if(vis[x][y] == 1) return false;
    s[cnt].x = x;
    vis[x][y] = 1;
    s[cnt++].y = y+‘A‘-1;
    if(cnt == width*high) return true;
    if(dfs(x-1,y-2) || dfs(x+1,y-2) || dfs(x-2,y-1) || dfs(x+2,y-1) || dfs(x-2,y+1) || dfs(x+2,y+1) || dfs(x-1,y+2) || dfs(x+1,y+2)) return true;
    cnt --;
    vis[x][y] = 0;
    return false;
}
int main()
{
    int n;
    scanf("%d",&n);
    while(n--) {
        for(int i = 0 ; i < maxn*maxn ; i ++) {
            s[i].x = 0;
            s[i].y = 0;
        }
        memset(vis,0,sizeof(vis));
        scanf("%d%d",&high,&width);
        printf("Scenario #%d:\n",++kase);
        cnt = 0;
        if(!dfs(1,1)) {printf("impossible\n");if(n!=0)printf("\n");continue;}
        for(int i = 0 ; i < cnt ; i ++) printf("%c%d",s[i].y,s[i].x);
        printf("\n");
        if(n != 0) printf("\n");
    }
    return 0;
}

POJ2488 A Knight's Journey 骑士巡游 DFS

时间: 2024-10-26 11:51:53

POJ2488 A Knight's Journey 骑士巡游 DFS的相关文章

POJ2488:A Knight&#39;s Journey(dfs)

http://poj.org/problem?id=2488 Description Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey around the world. Whenever a knight moves, it is two squares in one directi

poj2488 A Knight&#39;s Journey裸dfs

A Knight's Journey Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 35868   Accepted: 12227 Description Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey ar

poj-2488 a knight&#39;s journey(搜索题)

Time limit1000 ms Memory limit65536 kB Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey around the world. Whenever a knight moves, it is two squares in one direction a

POJ2488 A Knight&#39;s Journey

Description BackgroundThe knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular

快速切题 poj2488 A Knight&#39;s Journey

A Knight's Journey Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 31195   Accepted: 10668 Description Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey ar

POJ 2488 -- A Knight&#39;s Journey(骑士游历)

POJ 2488 -- A Knight's Journey(骑士游历) 题意: 给出一个国际棋盘的大小,判断马能否不重复的走过所有格,并记录下其中按字典序排列的第一种路径. 经典的"骑士游历"问题 输入:第一行,整数n,接下来是n行,每一行为p和q,p为行数,q为列数,p用1...p编号,q用A...Q编号 马的走法:每步棋先横走或直走一格,然后再往外斜走一格;或者先斜走一格,最后再往外横走或竖走一格(即走"日"字).可以越子,没有中国象棋中的"蹩马腿&

pku 2488 A Knight&#39;s Journey (搜索 DFS)

A Knight's Journey Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 28697   Accepted: 9822 Description Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey aro

poj2488--A Knight&#39;s Journey(dfs,骑士问题)

A Knight's Journey Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 31147   Accepted: 10655 Description Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey ar

poj2488(A Knight&#39;s Journey)

题目地址:A Knight's Journey 题目大意: 骑士按照日字形走,给你p*q的棋盘,问你骑士能否走遍棋盘的所有位置,输出骑士走的路线序列p(1.2....)q(A.B...) 按照字典序输出,如果不能输出 'impossible' . 解题思路: 搜索.因为是遍历全图所有点,所以必然经过A1. 又因为按字典序,既然A1可以经过,所以必然可以从A1开始. 注意: 1.按照字典序输出意思为(先安A.B.C...)排序输出. const int dirx[]={-1,1,-2,2,-2,2