POJ 2251 <Dungeon Master> <搜索>

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon
description starts with a line containing three integers L, R and C (all
limited to 30 in size).

L is the number of levels making up the dungeon.

R and C are the number of rows and columns making up the plan of each level.

Then there will follow L blocks of R lines each containing C
characters. Each character describes one cell of the dungeon. A cell
full of rock is indicated by a ‘#‘ and empty cells are represented by a
‘.‘. Your starting position is indicated by ‘S‘ and the exit by the
letter ‘E‘. There‘s a single blank line after each level. Input is
terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.

If it is not possible to escape, print the line

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!


题意:3维迷宫逃生问题。题解:搜索吧。AC代码:
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
char a[35][35][35];
int judge[35][35][35];
int zz[6][3] = { { 1,0,0 },{ 0,1,0 },{ -1,0,0 },{ 0,-1,0 },{ 0,0,1 },{ 0,0,-1 } };
struct {int l, r, c;int step;}str[30000];
int bfs(void);
int l, r, c;

int pd(int x, int y, int z)
{
    if (a[x][y][z] != ‘#‘&&x >= 0 && x<l&&y >= 0 && y<r&&z >= 0 && z<c&&!judge[x][y][z])return 1;
    else return 0;
}

int x00,y00,z00;

int main()
{

    int i, j, k;
    while (scanf("%d %d %d", &l, &r, &c) && l )
    {
        for (i = 0;i < l;++i)
        {
            for (j = 0;j<r;++j)
            {
                for (k = 0;k<c;++k)
                {
                    scanf(" %c", &a[i][j][k]);
                    judge[i][j][k] = 0;
                    if (a[i][j][k] == ‘S‘)
                    {
                        x00 = i;
                        y00 = j;
                        z00 = k;
                    }
                }
            }
        }
        k = bfs();
        if (k)
        {
            printf("Escaped in %d minute(s).\n", k);
            continue;
        }
        printf("Trapped!\n");
    }
    return 0;
}

int bfs()
{
    int qian = 0, hou = 0, x, y, z, tx, ty, tz, k, cn;
    str[hou].l = x00;
    str[hou].r = y00;
    str[hou].c = z00;
    str[hou].step = 0;
    hou++;
    judge[x00][y00][z00] = 1;
    while (qian<hou)
    {
        x = str[qian].l;
        y = str[qian].r;
        z = str[qian].c;
        cn = str[qian].step;
        for (k = 0;k<6;++k)
        {
            tx = x + zz[k][0];
            ty = y + zz[k][1];
            tz = z + zz[k][2];
            if (pd(tx, ty, tz))
            {

                if (a[tx][ty][tz] == ‘E‘)return cn + 1;
                judge[tx][ty][tz] = 1;
                str[hou].l = tx;
                str[hou].r = ty;
                str[hou].c = tz;
                str[hou].step = cn + 1;
                hou++;
            }
        }
        qian++;
    }
    return 0;
}
时间: 2024-09-28 06:03:16

POJ 2251 <Dungeon Master> <搜索>的相关文章

POJ 2251 Dungeon Master --- 三维BFS(用BFS求最短路)

POJ 2251 题目大意: 给出一三维空间的地牢,要求求出由字符'S'到字符'E'的最短路径,移动方向可以是上,下,左,右,前,后,六个方向,每移动一次就耗费一分钟,要求输出最快的走出时间.不同L层的地图,相同RC坐标处是相连通的.(.可走,#为墙) 解题思路:从起点开始分别往6个方向进行BFS(即入队),并记录步数,直至队为空.若一直找不到,则困住. /* POJ 2251 Dungeon Master --- 三维BFS(用BFS求最短路) */ #include <cstdio> #i

POJ 2251 Dungeon Master(地牢大师)

p.MsoNormal { margin-bottom: 10.0000pt; font-family: Tahoma; font-size: 11.0000pt } h1 { margin-top: 5.0000pt; margin-bottom: 5.0000pt; text-align: left; font-family: 宋体; font-weight: bold; font-size: 24.0000pt } span.10 { font-family: "Times New Rom

POJ 2251:Dungeon Master(三维BFS)

Dungeon Master Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 16178 Accepted: 6268 Description You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled wit

POJ 2251 Dungeon Master(三维6方向BFS)

B - Dungeon Master Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 2251 Appoint description:  System Crawler  (2015-03-28) Description You are trapped in a 3D dungeon and need to find the quicke

BFS POJ 2251 Dungeon Master

题目传送门 1 /* 2 BFS:这题很有意思,像是地下城,图是立体的,可以从上张图到下一张图的对应位置,那么也就是三维搜索,多了z坐标轴 3 */ 4 #include <cstdio> 5 #include <algorithm> 6 #include <cstring> 7 #include <queue> 8 using namespace std; 9 10 const int MAXN = 33; 11 const int INF = 0x3f3

poj 2251 三维地图bfs

三维地图 poj 2251 #include<iostream> #include<queue> #include<cstdio> #include<cstring> using namespace std; char map[35][35][35]; int l,r,c; bool book[35][35][35]; // 定义 东西南北和上下 struct dis{ int x,y,z; int step; dis(int x,int y,int z,i

POJ - 2251 Dungeon Master(三维BFS)

题目链接:http://poj.org/problem?id=2251 题意:三维BFS. 题解:大水题,只不过多加了两个方向 1 //poj2251 2 #include <queue> 3 #include <cstring> 4 #include <iostream> 5 #include <algorithm> 6 using namespace std; 7 int sx,sy,sz,ex,ey,ez,L,R,C; 8 const int INF=

poj 2251 Dungeon Master(bfs)

题目链接  http://poj.org/problem?id=2251 题意:一个立体空间, 输入三个数,L,R,C,代表有L个平面,R行,C列,.代表可以走,#代表不能走,S代表开始点,E代表结束点,问从S开始走,对每个位置,有六个走法,即空间的六个方向的走法(上下东南西北),一分钟可以走一个点,问从S走到E点,最少可以经过多少分钟,若不能到达,则输出Trapped! 简单的三维bfs随便做一下就可以了. #include <iostream> #include <cstring&g

(广搜)Dungeon Master -- poj -- 2251

链接: http://poj.org/problem?id=2251 Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 21370   Accepted: 8299 Description You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may

poj 2251(广搜求两点之间的距离)

题目链接:http://poj.org/problem?id=2251 Dungeon Master Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 16682   Accepted: 6491 Description You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit