PTA 10-排序5 PAT Judge (25分)

题目地址

https://pta.patest.cn/pta/test/16/exam/4/question/677

5-15 PAT Judge   (25分)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, NN (\le 10^4≤10?4??), the total number of users, KK (\le 5≤5), the total number of problems, and MM (\le 10^5≤10?5??), the total number of submissions. It is then assumed that the user id‘s are 5-digit numbers from 00001 to NN, and the problem id‘s are from 1 to KK. The next line contains KK positive integers p[i] (i=1, ..., KK), where p[i]corresponds to the full mark of the i-th problem. Then MM lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1?1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_scoreobtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id‘s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

/*
评测结果
时间	结果	得分	题目	编译器	用时(ms)	内存(MB)	用户
2017-07-06 22:51	答案正确	25	5-15	gcc	153	2
测试点结果
测试点	结果	得分/满分	用时(ms)	内存(MB)
测试点1	答案正确	13/13	13	1
测试点2	答案正确	3/3	2	1
测试点3	答案正确	3/3	14	1
测试点4	答案正确	3/3	2	1
测试点5	答案正确	3/3	153	2

思路:因为是结构体排序,如果省事可以做结构体的swap,不过开销太大。虽然能过也能过,但这题考察的应该是间接排序,那就拿间接排序做了。

对于分数相同采取的措施:因为总分数不高,若把AC数量作为第二关键字,那么算一个排序分数出来就好了,为总分x10+全过次数。
因为用的插排,ID顺序不会乱,所以ID是递增有序的。
如果要求再复杂点只能做个比较函数了,传进去处理完给个返回值,看哪个该排在前面。

容易踩的坑——对提交分数为-1的处理:题读了好几遍才明白这里的细节,编译失败算0,不算未提交
但是不能直接算作0,虽然在分数上计作0,但是应该在用户信息表中额外维护一个该用户是否成功提交过的标识符。

对重复AC的处理——刚开始最后一个点拿不到分数,因为有重复满分提交。
发现此时没有把AC次数+1的判断嵌套到上面的if里面,属于失误。
*/
#include <stdio.h>
#define UNSUBMITTED -1
#define MAXN 100000
#define MAXK 5
struct userinfo
{
	int totalScore;
	int allClearCount;
	int rank;
	int pointForSort;
	int eversubmitted;
} gUserInfo[MAXN];

int gProblemTable[MAXK];
int gSubmissions[MAXN][MAXK];
int gRanklist[MAXN];

void InitSubmissions(int N,int K)
{
	int i,j;
	for(i=0;i<N;i++)
		for(j=0;j<K;j++)
			gSubmissions[i][j]=UNSUBMITTED;
}
void InitRanklist()
{
	int i;
	for(i=0;i<MAXN;i++)
		gRanklist[i]=i;
}

void CalcTotalScore(int N,int K)
{
	int i,j;
	for(i=0;i<N;i++)
		for(j=0;j<K;j++)
		{
			if(gSubmissions[i][j]>0)
				gUserInfo[i].totalScore+=gSubmissions[i][j];
		}
}

void IndriectInsertionSort(int N)
{
	int i,j,temp;
	for(i=1;i<N;i++)
	{
		j=i;
		temp=gRanklist[j];
		while(j>0)
		{
			if (gUserInfo[temp].pointForSort>gUserInfo[gRanklist[j-1]].pointForSort)
			{
				gRanklist[j]=gRanklist[j-1];
				j--;
			}
			else break;
		}
		gRanklist[j]=temp;
	}
}

void MakeRank(int N)
{
	int i;
	gUserInfo[gRanklist[0]].rank=1;
	for(i=1;i<N;i++)
	{
		if(gUserInfo[gRanklist[i]].totalScore==gUserInfo[gRanklist[i-1]].totalScore)
			gUserInfo[gRanklist[i]].rank=gUserInfo[gRanklist[i-1]].rank;
		else
			gUserInfo[gRanklist[i]].rank=i+1;
	}
}

void CalcPointForSort(int N)
{
	int i;
	for(i=0;i<N;i++)
	{
		gUserInfo[i].pointForSort=gUserInfo[i].totalScore*10+gUserInfo[i].allClearCount;
	}
}

int main()
{
	int i,j,N,K,M;
	int ID,pID,score;
	scanf("%d %d %d",&N,&K,&M);
	InitSubmissions( N, K);
	for(i=0;i<K;i++)
	{
		scanf("%d",&gProblemTable[i]);
	}
	for(i=0;i<M;i++)
	{
		scanf("%d %d %d",&ID,&pID,&score);
		if(score!= -1)
			gUserInfo[ID-1].eversubmitted=1;
		else
			score=0;
		if(score>gSubmissions[ID-1][pID-1]) //只有比上一次大才处理,可以防止重复AC
			{
				gSubmissions[ID-1][pID-1]=score;
				if(score==gProblemTable[pID-1])
					gUserInfo[ID-1].allClearCount++;
			}
	}
	CalcTotalScore(N,K); //计算每个用户总分
	CalcPointForSort(N); //把分数x10然后加上ac次数作为排序依据
	InitRanklist(); //初始化间接的排名表
	IndriectInsertionSort(N); //排序
	MakeRank(N); //计算每个用户的名次

	for(i=0;i<N;i++)
	{
		if(gUserInfo[gRanklist[i]].eversubmitted==0)
			continue;
		printf("%d %05d %d",gUserInfo[gRanklist[i]].rank,gRanklist[i]+1,gUserInfo[gRanklist[i]].totalScore);
		for(j=0;j<K;j++)
		{
			if(gSubmissions[gRanklist[i]][j]== UNSUBMITTED)
				printf(" -");
			else
				printf(" %d",gSubmissions[gRanklist[i]][j]);
		}
		printf("\n");
	}

}

  

 
时间: 2024-10-10 04:40:45

PTA 10-排序5 PAT Judge (25分)的相关文章

PTA 5-15 PAT Judge (25分)

/* * 1.主要就用了个sort对结构体的三级排序 */ #include "iostream" #include "algorithm" using namespace std; int perfectScore[6]; struct Node { int id; int score[6] = {-2,-2,-2,-2,-2,-2}; /* 记录每一题的分数 初始化为-2代表没答题 */ int totalScore = 0; /* 记录总分 */ int pe

PATA1075 PAT Judge (25 分)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT. Input Specification: Each input file contains one test case. For each case, the first line

【PAT甲级】1075 PAT Judge (25 分)

题意: 输入三个正整数N,K,M(N<=10000,K<=5,M<=100000),接着输入一行K个正整数表示该题满分,接着输入M行数据,每行包括学生的ID(五位整数1~N),题号和该题得分(-1表示没通过编译).输出排名,学生ID,总分和每一题的得分,第一优先为总分降序,第二优先为题目AC数降序,第三优先为学生ID升序(提交但未通过编译得分为0,未提交得分为-,不输出没有提交或者提交全都未通过编译的学生信息). trick: 测试点4为有学生先交了得到分的程序后该题后来又交了未通过编译

PTA乙级 (*1095 解码PAT准考证 (25分))

1095 解码PAT准考证 (25分) https://pintia.cn/problem-sets/994805260223102976/problems/1071786104348536832 题目大意:给出一组学生的准考证号和成绩,准考证号包含了等级(乙甲顶),考场号,日期,和个人编号信息,并有三种查询方式查询一:给出考试等级,找出该等级的考生,按照成绩降序,准考证升序排序查询二:给出考场号,统计该考场的考生数量和总得分查询三:给出考试日期,查询改日期下所有考场的考试人数,按照人数降序,考

1025 PAT Ranking (25 分)

1025 PAT Ranking (25 分) Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately

PAT 1075. PAT Judge (25)

题目地址:http://pat.zju.edu.cn/contests/pat-a-practise/1075 此题主要考察细节的处理,和对于题目要求的正确理解,另外就是相同的总分相同的排名的处理一定要熟练,还有就是编译没有通过为零分,没有提交显示为"-": #include <cstdio> #include <vector> #include <algorithm> using namespace std; const int NUM=10001

1025 PAT Ranking (25分)

1025 PAT Ranking (25分) 1. 题目 2. 思路 设置结构体, 先对每一个local排序,再整合后排序 3. 注意点 整体排序时注意如果分数相同的情况下还要按照编号排序 4. 代码 #include<cstdio> #include<cmath> #include<cstring> #include<algorithm> using namespace std; struct stu{ int location_number; char

PAT Advanced 1093 Count PAT&#39;s (25分)

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters. Now given any string, you are supposed to tell the numb

PTA乙级 (*1030 完美数列 (25分))

1030 完美数列 (25分) https://pintia.cn/problem-sets/994805260223102976/problems/994805291311284224 #include <iostream> #include <vector> #include <algorithm> typedef long long ll; using namespace std; int main() { int n; ll p; cin>>n>