HDU4664

<span size="+0"><strong><span style="font-family:Arial;font-size:12px;color:green;font-weight: bold;">Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total ubmission(s): 3088    Accepted Submission(s): 1700</span></strong></span>

Problem Description

One day when you are going to clear all your browsing history, you come up with an idea: You want to figure out what your most valued site is. Every site is given a value which equals to the sum of ASCII values of all characters in
the URL. For example aa.cc has value of 438 because 438 = 97 + 97 + 46 + 99 + 99. You just need to print the largest value amongst all values of sites.

Things are simplified because you found that all entries in your browsing history are of the following format: [domain], where [domain] consists of lower-case Latin letters and “.” only. See the sample input for more details.

Input

There are several test cases.

For each test case, the first line contains an integer n (1 ≤ n ≤ 100), the number of entries in your browsing history.

Then follows n lines, each consisting of one URL whose length will not exceed 100.

Input is terminated by EOF.

Output

For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a number indicating the desired answer.

Sample Input

1
aa.cc
2
www.google.com
www.wikipedia.org

Sample Output

Case 1: 438
Case 2: 1728

给你许多字符串,求和最大的,直接输出和。下面是代码。

#include <stdio.h>
#include <string.h>
int main()
{
    int n,i,j,l,cc;
    int wbx=1;
    char a[1000];
    while(scanf("%d",&n)!=EOF)
    {
       cc=-1;
        for(i=0;i<n;i++)
        {
            int sum=0;
            scanf("%s",a);
            for(j=0;a[j];j++)
                sum+=a[j];
            if(sum>cc)
                cc=sum;
        }
        if(wbx)
        {
            printf("Case %d: %d\n",wbx,cc);
            wbx++;
        }
    }
    return 0;
}
时间: 2024-08-14 11:26:09

HDU4664的相关文章