HDOJ 5375 Gray code DP

标准格雷码的性质:二进制a1 a2 ... an,对应的格雷码为a1 (a1 xor a2) ... (an-1 xor an) 题目就可以转为O(n)的dp dp[i][j]表示二进制第i位为j时前i位对应最大分数.

Gray code

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 298    Accepted Submission(s): 163

Problem Description

The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed to prevent spurious output from electromechanical
switches. Today, Gray codes are widely used to facilitate error correction in digital communications such as digital terrestrial television and some cable TV systems.

Now , you are given a binary number of length n including ‘0’ , ’1’ and ‘?’(? means that you can use either 0 or 1 to fill this position) and n integers(a1,a2,….,an) . A certain binary number corresponds to a gray code only. If the ith bit of this gray code
is 1,you can get the point ai.

Can you tell me how many points you can get at most?

For instance, the binary number “00?0” may be “0000” or “0010”,and the corresponding gray code are “0000” or “0011”.You can choose “0000” getting nothing or “0011” getting the point a3 and a4.

Input

The first line of the input contains the number of test cases T.

Each test case begins with string with ‘0’,’1’ and ‘?’.

The next line contains n (1<=n<=200000) integers (n is the length of the string).

a1 a2 a3 … an (1<=ai<=1000)

Output

For each test case, output “Case #x: ans”, in which x is the case number counted from one,’ans’ is the points you can get at most

Sample Input

2
00?0
1 2 4 8
????
1 2 4 8

Sample Output

Case #1: 12
Case #2: 15

Hint

https://en.wikipedia.org/wiki/Gray_code

http://baike.baidu.com/view/358724.htm

Source

2015 Multi-University Training Contest 7

/* ***********************************************
Author        :CKboss
Created Time  :2015年08月11日 星期二 20时56分37秒
File Name     :HDOJ5375.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>

using namespace std;

const int maxn=200200;

int n;
char str[maxn];
int a[maxn];
int dp[maxn][2];

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);

    int cas=1,T_T;
    scanf("%d",&T_T);
    while(T_T--)
    {
        scanf("%s",str);
        n=strlen(str);
        for(int i=0;i<n;i++)
        {
            scanf("%d",a+i);
            dp[i][0]=dp[i][1]=0;
        }

        if(str[0]=='1'||str[0]=='?') dp[0][1]=a[0];

        for(int i=1;i<n;i++)
        {
            if(str[i]=='0')
            {
                if(str[i-1]=='?'||str[i-1]=='1') dp[i][0]=max(dp[i][0],dp[i-1][1]+a[i]);
                if(str[i-1]=='?'||str[i-1]=='0') dp[i][0]=max(dp[i][0],dp[i-1][0]);
            }
            else if(str[i]=='1')
            {
                if(str[i-1]=='?'||str[i-1]=='0') dp[i][1]=max(dp[i][1],dp[i-1][0]+a[i]);
                if(str[i-1]=='?'||str[i-1]=='1') dp[i][1]=max(dp[i][1],dp[i-1][1]);
            }
            else if(str[i]=='?')
            {
                /// ? --> 0
                if(str[i-1]=='?'||str[i-1]=='1') dp[i][0]=max(dp[i][0],dp[i-1][1]+a[i]);
                if(str[i-1]=='?'||str[i-1]=='0') dp[i][0]=max(dp[i][0],dp[i-1][0]);
                /// ? --> 1
                if(str[i-1]=='?'||str[i-1]=='0') dp[i][1]=max(dp[i][1],dp[i-1][0]+a[i]);
                if(str[i-1]=='?'||str[i-1]=='1') dp[i][1]=max(dp[i][1],dp[i-1][1]);
            }
        }

		int ans=max(dp[n-1][0],dp[n-1][1]);

        printf("Case #%d: %d\n",cas++,ans);
    }

    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-12-19 20:34:18

HDOJ 5375 Gray code DP的相关文章

hdu 5375 Gray code dp

#include<stdio.h> #include<string.h> #include<algorithm> using namespace std; const int N=200000+5; const int inf=1<<24; int dp[N][2],a[N]; char s[2*N]; int main() { int n,m,i,_; scanf("%d",&_); for(int k=1;k<=_;k+

hdoj 5375 Gray Code

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5375 编码规则:tmp = XOR(gr[i],gr[i-1]); 算是找规律的题目吧,考虑?前后字符和?数目的奇偶性就可以了,一个小trick就是当碰到需要减的时候是减问号区间内最小的那个, 然后就是调试的问题: 字符串从数组第二位开始存放,scanf("%s",s+1); 当用到min和max的时候记得每次使用前要清空. 1 #include<stdio.h> 2 cons

hdu 5375 Gray code(DP)

hdu 5375 Gray code Problem Description The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed

HDU 5375 Gray code (简单dp)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5375 题面: Gray code Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 626    Accepted Submission(s): 369 Problem Description The reflected binary cod

hdu 5375 - Gray code(dp) 解题报告

Gray code Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 684    Accepted Submission(s): 402 Problem Description The reflected binary code, also known as Gray code after Frank Gray, is a binary

HDU 5375——Gray code——————【dp||讨论】

Gray code Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 569    Accepted Submission(s): 337 Problem Description The reflected binary code, also known as Gray code after Frank Gray, is a binary

HDU HDU 5375 Gray code(二进制和格雷码)

Description: The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed to prevent spurious outpu

HDU 5375 Gray code(模拟)

Gray code Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 65    Accepted Submission(s): 35 Problem Description The reflected binary code, also known as Gray code after Frank Gray, is a binary n

HDU 5375(2015多校7)-Gray code(dp)

题目地址:HDU 5375 题意:给你一个二进制串,带'?'的位置可以由你来决定填'1'还是'0',补充完整之后转换成格雷码表示,每一个位置都有一个权值a[i],只有格雷码为'1'的位可以加上权值,问你最终权值之和最大为多少. 思路:首先要明白二进制码和格雷码是如何转换的: dp[i][0]表示第i位为0的时候的最大值,dp[i][1]表示第i位为1的时候的最大值.对于第i位的最大值由dp[i-1][0],dp[i-1][1]和当前权值a[i]得到.当前的位的二进制码有0,1,?三种情况,所以就