POJ 题目3061 Subsequence(水题)

Subsequence

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9422   Accepted: 3797

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum
of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The
input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Source

Southeastern Europe 2006

ac代码

#include<stdio.h>
#include<string.h>
#define min(a,b) (a>b?b:a)
__int64 a[101000];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,i,j;
		__int64 k;
		scanf("%d%I64d",&n,&k);
		a[0]=0;
		for(i=1;i<=n;i++)
		{
			__int64 x;
			scanf("%I64d",&x);
			a[i]=a[i-1]+x;
		}
		int ans=100010;
	//	int i,j;
		i=j=1;
		while(i<=n&&j<=n)
		{
			while(j<=n&&a[j]-a[i-1]<k)
			{
				j++;
			}

			if(j<=n)
			{
				ans=min(ans,j-i+1);
				i++;
			}
			else
				break;
		}
		if(ans==100010)
			ans=0;
		printf("%d\n",ans);
	}
}
时间: 2024-10-13 17:41:45

POJ 题目3061 Subsequence(水题)的相关文章

poj 1006:Biorhythms(水题,经典题,中国剩余定理)

Biorhythms Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 110991   Accepted: 34541 Description Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical,

POJ 1488 Tex Quotes --- 水题

POJ 1488 题目大意:给定一篇文章,将它的左引号转成 ``(1的左边),右引号转成 ''(两个 ' ) 解题思路:水题,设置一个bool变量标记是左引号还是右引号即可 /* POJ 1488 Tex Quotes --- 水题 */ #include <cstdio> #include <cstring> int main() { #ifdef _LOCAL freopen("D:\\input.txt", "r", stdin); #

Poj 1094 拓扑排序 水题

Sad..这么水的题WA了无数发,题目要看仔细啊,留下来做个警告把 #include <cstdio> #include <cstring> #include <algorithm> #include <climits> #include <string> #include <iostream> #include <map> #include <cstdlib> #include <list> #i

poj 2369 Permutations 置换水题

找循环节求lcm就够了,若答案是12345应该输出1,被坑了下. #include<iostream> #include<cstdio> #include<cstring> #include<string> #include<algorithm> #include<cmath> using namespace std; #define INF 0x3FFFFFF #define MAXN 2222 #define eps 1e-6 i

poj 1002:487-3279(水题,提高题 / hash)

487-3279 Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 236746   Accepted: 41288 Description Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phras

poj 1003:Hangover(水题,数学模拟)

Hangover Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 99450   Accepted: 48213 Description How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're as

poj 2497 Strategies 模拟水题

水题,直接贴代码. //poj 2497 //sep9 #include <iostream> #include <algorithm> using namespace std; int a[32]; int main() { int cases,c=0; scanf("%d",&cases); while(cases--){ int tot,n; scanf("%d%d",&tot,&n); int x2,y2,t;

POJ 2538 WERTYU(水题)

[题目简述]:题意很简单,没有trick. [分析]:其实这题还是挺有趣的,在 算法竞赛入门经典中也有这一题. 详见代码: // 120K 0Ms /* 边学边做 -- */ // 字符串:WERTYU #include<iostream> using namespace std; char *s = "`1234567890-=QWERTYUIOP[]\\ASDFGHJKL;'ZXCVBNM,./"; //注意这里的这个"\"要打两次,不然会被误认为

POJ 2365【YY水题】

题目链接:POJ 2365 Rope Rope Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7488   Accepted: 2624 Description Plotters have barberically hammered N nails into an innocent plane shape, so that one can see now only heads. Moreover, pursuing th