一、实验拓扑图
二、各设备配置
framrelay配置如下:
interface Serial0/1
no ip address
encapsulation frame-relay
serial restart-delay 0
clockrate 64000
no frame-relay inverse-arp
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 102 interface Serial0/2 201
frame-relay route 103 interface Serial0/3 301
!
interface Serial0/2
no ip address
encapsulation frame-relay
serial restart-delay 0
clockrate 64000
no frame-relay inverse-arp
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 201 interface Serial0/1 102
!
interface Serial0/3
no ip address
encapsulation frame-relay
serial restart-delay 0
clockrate 64000
no frame-relay inverse-arp
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 301 interface Serial0/1 103
R1配置如下:
interface Loopback0
ip address 172.16.1.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
ip address 192.168.1.1 255.255.255.0
encapsulation frame-relay
ip ospf network broadcast
serial restart-delay 0
frame-relay map ip 192.168.1.2 102 broadcast
frame-relay map ip 192.168.1.3 103 broadcast
no frame-relay inverse-arp
!
router ospf 10
router-id 172.16.1.1
log-adjacency-changes
network 172.16.1.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
!
R2配置如下:
interface Loopback0
ip address 172.16.2.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
ip address 192.168.1.2 255.255.255.0
encapsulation frame-relay
ip ospf network broadcast
serial restart-delay 0
frame-relay map ip 192.168.1.1 201 broadcast
no frame-relay inverse-arp
!
router ospf 10
router-id 172.16.2.1
log-adjacency-changes
network 172.16.2.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
!
R3配置如下:
interface Loopback0
ip address 172.16.3.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/1
ip address 192.168.1.3 255.255.255.0
encapsulation frame-relay
ip ospf network broadcast
serial restart-delay 0
frame-relay map ip 192.168.1.1 301 broadcast
no frame-relay inverse-arp
!
router ospf 10
router-id 172.16.3.1
log-adjacency-changes
network 172.16.3.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
!
三、相关调试命令
frame-relay switching
debug ip ospf events
debug ip ospf packet
show ip ospf
show ip ospf database
show ip ospf interface
show ip ospf neighbor
show ip route