ZOJ 1584:Sunny Cup 2003 - Preliminary Round(最小生成树&&prim)

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network

In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please
be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the
group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS‘s have received the message.

A sample is shown below:

A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS‘s favorate brand
of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.

Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS‘s favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.

Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.

Sample Input

1

3

10 20 30

0 100 200

100 0 300

200 300 0

Sample Output

370

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<cmath>
#define MAXN 1005
#define INF 0x1f1f1f1f

using namespace std;

using namespace std;

int n, ans, cas;      //QS适配器的个数,结果,测试数据组数;
int lowcost[MAXN];    //充当Prim算法中的两个数组lowcost和nearvex的作用;
int adapt[MAXN];    //每个QS喜欢的适配器的价格;
int Edge[MAXN][MAXN];  //邻接矩阵;

void Init()
{
    scanf("%d", &n);
    for(int i=0; i<n; i++) scanf("%d", &adapt[i]);   //输入价格;
    for(int i=0; i<n; i++)
    {
        for(int j=0; j<n; j++)      //邻接矩阵初始化;
        {
            scanf("%d", &Edge[i][j]);
            if(i == j) Edge[i][j] = INF;
            else Edge[i][j] += (adapt[i]+adapt[j]);
        }
    }
    memset( lowcost, 0, sizeof(lowcost) );
    ans = 0;
}

void Prim()    //Prim算法核心;
{
    lowcost[0] = -1;    //从顶点0开始构造最小生成树;
    for(int i=1; i<n; i++) lowcost[i] = Edge[0][i];
    for(int i=1; i<n; i++)       //把其他n-1个顶点扩展到生成树当中;
    {
        int min = INF, k;
        for(int j=0; j<n; j++)      //找到当前可用的权值最小的边;
        {
            if(lowcost[j] != -1 && lowcost[j] < min)
            {
                k = j;
                min = lowcost[j];
            }
        }
        ans += min;
        lowcost[k] = -1;    //把顶点k扩展进来;
        for(int i=0; i<n; i++) if(Edge[k][i] < lowcost[i])
            {
                lowcost[i] = Edge[k][i];
            }
    }
    printf("%d\n", ans);
}

int main()
{
    scanf("%d", &cas);
    while(cas--)
    {
        Init();
        Prim();
    }
    return 0;
}
时间: 2024-11-01 15:02:22

ZOJ 1584:Sunny Cup 2003 - Preliminary Round(最小生成树&&prim)的相关文章

ZOJ 1584:Sunny Cup 2003 - Preliminary Round(最小生成树&amp;amp;&amp;amp;prim)

Sunny Cup 2003 - Preliminary Round April 20th, 12:00 - 17:00 Problem E: QS Network In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they

ZOJ 1586 QS Network(最小生成树 prim)

题意  输入n  然后输入n个数  代表连接时每个站点自身的消耗   然后输入n*n的矩阵  第i行第j列的数代表第i个站点和第j个站点之间路上的花费  链接i,j两个节点的总花费为两站点自身花费加上路上的花费  求⑩这n个站点连通的最小总花费 又是裸的最小生成树  给点的就用prim咯 #include<cstdio> #include<cstring> #include<algorithm> using namespace std; const int N = 10

ZOJ 3204 Connect them (C) 最小生成树kruskal

Connect them Time Limit: 1 Second      Memory Limit: 32768 KB You have n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN). All connections are two-way (that is connecting computers i and j is the sa

DP VK Cup 2012 Qualification Round D. Palindrome pairs

题目地址:http://blog.csdn.net/shiyuankongbu/article/details/10004443 1 /* 2 题意:在i前面找回文子串,在i后面找回文子串相互配对,问有几对 3 DP:很巧妙的从i出发向两头扩展判断是否相同来找回文串 4 dpr[i] 代表记录从0到i间的回文子串的个数,dpl[i] 代表记录i之后的回文子串个数 5 两两相乘就行了 6 详细解释:http://blog.csdn.net/shiyuankongbu/article/details

[记忆化搜索] zoj 3681 E - Cup 2

题目链接: http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3681 E - Cup 2 Time Limit: 2 Seconds      Memory Limit: 65536 KB The European Cup final is coming. The past two World Cup winners, Spain and Italy, will contest the decider at Kiev's

[dp] zoj 3682 E - Cup 3

题目链接: http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3682 E - Cup 3 Time Limit: 3 Seconds      Memory Limit: 65536 KB The 2012 Europe Cup was over and Spain won the Championship. The fans of Spain want to hold some activities to celebra

poj1789Truck History(最小生成树prim算法)

题目链接: 啊哈哈,点我点我 思路:根据字符串中不同的长度建图,然后求图的最小生成树.. 题目: Truck History Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 18272   Accepted: 7070 Description Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vege

poj2031Building a Space Station(最小生成树prim)

题目链接: 啊哈哈,点我点我 题意: 就是空间站之间有很多球形的东西,然后这些球可能相交,如果相加那么距离为0,否则距离为两球表面的距离,最后求联通这些球形实验室所需要的最小距离... 思路: 相信大家都学过圆相交吧,类推到球是一样的,当两球的距离大于两球的半径之和的时候,说明两球不想交,反之则两球相交,转换成公式为d-(r1+r2)>0则说明两球不相交... 建图后基本上就是套模板了... 题目: Building a Space Station Time Limit: 1000MS   Me

poj1861 最小生成树 prim &amp; kruskal

// poj1861 最小生成树 prim & kruskal // // 一个水题,为的只是回味一下模板,日后好有个照应不是 #include <cstdio> #include <algorithm> #include <cstring> #include <vector> #include <iostream> using namespace std; const int MAX_N = 1008; const int INF =