PAT_A1064 Complete Binary Search Tree

Complete Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node‘s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node‘s key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4这道题如果不清楚一个知识点的话就很难做,一开始我一直在判断到底什么时候最后一排没满,到底要加多少,但是,其实,如果你了解完全二叉树性质的话,这道题就能迎刃而解:完全二叉树的叶可以不满,其他都要求要满。若完全二叉树任何一个节点序号为x(从1开始)那么,该节点的左子节点的序号为2x,右子节点的序号为2x+1。这样我们可以通过递归(中序排列顺序)每个节点的左右子节点(退出条件为序号是否超过n),然后我们很容易得到,每个被递归(中序排列顺序)的节点的值和排完序的数组的关系:
那就是排序二叉树的中序遍历是按照顺序递增的,递归第一次结束进行赋值是把排完序的数组第一个(最小值)赋值,紧接着第二个赋值第二小的(你也可以仔细想一想完全二叉树的从小到大的顺序在树上是怎么样的,以及递归(中序排列)为什么能够解决。AC代码:
#include <stdio.h>
#include <algorithm>
using namespace std;
struct tree{
	int num;
	tree* left;
	tree* right;
};
int ans[1010];
int a[1010];
int t, n;
void binary(int i)
{
	if(i > n)
		return ;
	binary(2 * i);
	ans[i] = a[t++];
	binary(2 * i + 1);
};
int main(void)
{
	scanf("%d", &n);
	for(int i = 0; i < n; i++)
	{
		scanf("%d", &a[i]);
	}
	sort(a, a + n);
	binary(1);
	for(int i = 1; i <= n; i++)
	{
		printf("%d", ans[i]);
		if(i < n)
			printf(" ");
	}
	return 0;
}

  

感谢自:https://blog.csdn.net/hy971216/article/details/81838750的题解报告

原文地址:https://www.cnblogs.com/jacobfun/p/11594266.html

时间: 2024-08-01 08:53:50

PAT_A1064 Complete Binary Search Tree的相关文章

A1064. Complete Binary Search Tree (30)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a node contains only nodes with keys greate

PAT1064. Complete Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a node contains only nodes with keys greate

Complete Binary Search Tree

本博客的代码的思想和图片参考:好大学慕课浙江大学陈越老师.何钦铭老师的<数据结构> Complete Binary Search Tree 1 Question A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:The left subtree of a node contains only nodes with keys less than

数据结构--图(中)--树之习题选讲Complete Binary Search Tree

Complete Binary Search Tree 完全 二叉 搜索数 题意理解 二叉搜索数 左小右大 完全二叉树 结构规律 完全二叉搜索数 到底用什么数据结构来表示这个树呢?链表还是数组. 1.由于是完全二叉树,所以我们能准确的算出来左子树有多少个结点.   完全二叉树+n个树 -> 左子树的个数 2.左子树的个数能推出根节点的大小,左子树4个,那么根节点一定是第5位数 左子树的个数->根节点的值 3.这个思维:当我们确定了根节点之后,我们可以很容易的通过递归来确定其他的结点      

1064. Complete Binary Search Tree (30)

题目如下: A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a node contains only nodes with keys

04-树8. Complete Binary Search Tree (30)

04-树8. Complete Binary Search Tree (30) 时间限制 100 ms 内存限制 65536 kB 代码长度限制 8000 B 判题程序 Standard 作者 CHEN, Yue A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only

04-树6 Complete Binary Search Tree

刚开始只发现了中序遍历是从小到大顺序的.一直在找完全二叉树的层结点间规律...放弃了 不曾想,完全二叉树的规律早就知道啊.根结点为i,其左孩子结点2*i, 右孩子结点2*i+1. 结合此两者即可解决问题! A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nod

pat1064. Complete Binary Search Tree (30)

1064. Complete Binary Search Tree (30) 时间限制 100 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only

04-树5 Complete Binary Search Tree

这题也是第二次做,本想第一次做时参考的算法会和老师讲的一样,不想老师讲的算法用在这题感觉还不如思雪园友的算法(http://www.cnblogs.com/sixue/archive/2015/04.html)来的简单,不过老师给的思路是一种挺通用的思路,可以用来解决一系列的问题,但我目前看着有点吃力.我坚持认为对全局变量的使用需十分谨慎,能不用就不用,所以为了不出现全局变量,就无辜多了一串参数.实现代码如下,题目在代码下方 1 #include <stdio.h> 2 #include &l