[并查集] POJ 2236 Wireless Network

Wireless Network

Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 25022   Accepted: 10399

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

Source

POJ Monthly,HQM

原题大意:给两个整数N和d,N为电脑的个数,d为无线传播的最远距离。

接下来给N行,表示N台电脑的坐标。

直到输入结束,都会输入一个字符,如果为O,则再输入一个整数x表示编号为x的电脑被修好。

如果为S,再输入两个整数x,y,询问x与y之间是否连通。

解题思路:对于每台电脑一旦修好,判断与它可以连通的点的集合并合并。

询问的时候用并查集寻找即可。其实还是一个裸并查集。

#include<stdio.h>
#include<string.h>
#include<math.h>
#define dist(x1,y1,x2,y2) (x1-x2)*(x1-x2)+(y1-y2)*(y1-y2)
int father[10050],n,d;
bool ingragh[10050];
struct node
  {
  	 int x,y;
  }node[10050];
int find(int x)
  {
  	 if(x==father[x]) return (x);
  	 else father[x]=find(father[x]);
  	 return (father[x]);
  }
void merge(int x,int y)
  {
  	 int find_x=find(x);
  	 int find_y=find(y);
  	 if(find_x!=find_y&&dist(node[x].x,node[x].y,node[y].x,node[y].y)<=d*d)
	       father[find_x]=find_y;
  	 return;
  }
void init()
  {
  	 int i;
  	 for(i=1;i<=n;++i) father[i]=i;
  	 memset(ingragh,false,sizeof(ingragh));
  }
int main()
  {
  	 int i,query1,query2;
  	 char c;
  	 scanf("%d%d",&n,&d);
  	 init();
  	 for(i=1;i<=n;++i) scanf("%d%d",&node[i].x,&node[i].y);
	 while(~scanf("%c%d",&c,&query1))
	   {
	   	  if(c==‘O‘)
			 {
			    for(i=1;i<=n;++i) if(ingragh[i]) merge(i,query1);
			    ingragh[query1]=true;
		     }
		  else
	   	  if(c==‘S‘)
	   	    {
	   	  	   scanf("%d",&query2);
	   	  	   if(ingragh[query1]&&ingragh[query2])
	   	  	     {
				    if(find(query1)==find(query2))
					   {
					     printf("SUCCESS\n");
				         continue;
				       }
			     }
			   printf("FAIL\n");
		    }
	   }
  	 return 0;
  }

  

时间: 2024-08-07 17:01:29

[并查集] POJ 2236 Wireless Network的相关文章

POJ 2236 Wireless Network ||POJ 1703 Find them, Catch them 并查集

POJ 2236 Wireless Network http://poj.org/problem?id=2236 题目大意: 给你N台损坏的电脑坐标,这些电脑只能与不超过距离d的电脑通信,但如果x和y均能C通信,则x和y可以通信.现在给出若干个操作, O p 代表修复编号为p的电脑 S p q代表询问p和q是不是能通信. 思路: 并查集即可.. 如果修复了一台电脑,则把与它相连距离不超过d的且修复了的放在一个集合里面. #include<cstdio> #include<cstring&

poj 2236:Wireless Network(并查集,提高题)

Wireless Network Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 16065   Accepted: 6778 Description An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computer

POJ 2236 Wireless Network (并查集)

Wireless Network Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 18066   Accepted: 7618 Description An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computer

POJ - 2236 Wireless Network(简单并查集)

Wireless Network Time Limit: 10000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u Submit Status Description An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap co

poj 2236 Wireless Network (并查集)

链接:http://poj.org/problem?id=2236 题意: 有一个计算机网络,n台计算机全部坏了,给你两种操作: 1.O x 修复第x台计算机 2.S x,y 判断两台计算机是否联通 联通的条件: 两台都修复好了,求距离小于d 思路: 数据很小,我们可以没修复一台就直接枚举已经修复的计算机找到距离小于d的,放到一个并查集里,查询的话直接查询是否再同一个并查集里就好了 实现代码: //while(scanf("\n%c", &ope) != EOF) #inclu

poj 2236 Wireless Network 【并查集】

Wireless Network Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 16832   Accepted: 7068 Description An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computer

poj 2236 Wireless Network(并查集)

题目大意: 给你N台电脑,从1-N.一个数字,表示两台计算机的最大通信距离,超过这个距离就无法进行通信.然后分别告诉这些电脑的坐标,接下来有两种操作,第一种O表示这点电脑修好,第二种S,表示测试这两台电脑能不能进行正常的通信   解题思路: 并查集的简单应用,对每次修好的电脑对其它已经修好的电脑遍历,如果距离小于等于最大通信距离就将他们合并.之后判断2台电脑是不是一个集合中就KO了 1 #pragma comment(linker, "/STACK:1024000000,1024000000&q

POJ 2236 Wireless Network

Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 18146   Accepted: 7660 Description An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpec

POJ - 2236 Wireless Network (并查集)

https://cn.vjudge.net/problem/POJ-2236 题意 有一个计算机网络的所有线路都坏了,网络中有n台计算机,现在你可以做两种操作,修理(O)和检测两台计算机是否连通(S),只有修理好的计算机才能连通.连通有个规则,两台计算机的距离不能超过给定的最大距离D(一开始会给你n台计算机的坐标).检测的时候输出两台计算机是否能连通. 分析 注意审题..只有修理好的才能算联通.于是把所有修理好的并一起就行了. #include <iostream> #include <