HDU 1102 Constructing Roads (裸的并查集)

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13210    Accepted Submission(s): 4995

Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village
C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village
i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

题目意思:有n个村庄,编号1-n,以矩阵的形式给出任意两个村庄之间的距离,然后告诉已经有q个村庄已经修好了路,问现在要打算使所有村庄都联通需要修路的最小长度。

思路就是构造一棵最小生成树,所以将距离排序,从小到大依次并入,直到集合数为1为止。

#include <cstdio>
#include <cstdlib>
#include <vector>
#include <algorithm>

using namespace std;

const int MAXX = 102;

typedef struct Road{
	int x, y, dist;
	Road(int ix, int iy, int idist){
		x = ix;
		y = iy;
		dist = idist;
	}
}road;

int n,roads,length;
vector<road> vec;

int pre[MAXX];
bool yes[MAXX][MAXX] = { 0 };

void init(int n){
	for (int i = 1; i <= n; ++i){
		pre[i] = i;
	}
}

int root(int x){
	if (x != pre[x]){
		pre[x] = root(pre[x]);
	}
	return pre[x];
}

bool merge(int x, int y){
	int fy = root(y);
	int fx = root(x);

	bool mark = false;

	if (fx != fy){
		pre[fx] = fy;
		mark = true;
		--roads;
	}

	return mark;
}

bool cmp(road a, road b){
	return a.dist < b.dist;
}

int main(){

	//freopen("in.txt", "r", stdin);
	int dist, t, x, y;

	while (scanf("%d", &n) != EOF){
		roads = n - 1;
		vec.clear();
		memset(yes, 0, sizeof(yes));

		for (int i = 1; i <= n; ++i){
			for (int j = 1; j <= n; ++j){
				scanf("%d", &dist);
				if (i == j || i > j)continue;//重复的路径不进行添加
				vec.push_back(road(i, j, dist));
			}
		}

		sort(vec.begin(), vec.end(), cmp);

		init(n);

		scanf("%d", &t);

		while (t--){
			scanf("%d %d", &x, &y);
			merge(x, y);
			yes[x][y] = true;
		}

		length = 0;
		vector<road>::iterator ite = vec.begin();
		for (; ite != vec.end() && roads != 0; ++ite){
			x = (*ite).x;
			y = (*ite).y;
			dist = (*ite).dist;
			if (yes[x][y])continue;
			if (merge(x, y))length += dist;
		}

		printf("%d\n", length);
	}
	return 0;
}

HDU 1102 Constructing Roads (裸的并查集)

时间: 2024-11-02 23:28:19

HDU 1102 Constructing Roads (裸的并查集)的相关文章

HDU 1102 Constructing Roads, Prim+优先队列

题目链接:HDU 1102 Constructing Roads Constructing Roads Problem Description There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are conne

hdu 1102 Constructing Roads (Prim算法)

题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=1102 Constructing Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 21947    Accepted Submission(s): 8448 Problem Description There are N villa

hdu 1102 Constructing Roads (最小生成树)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1102 Constructing Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 14172    Accepted Submission(s): 5402 Problem Description There are N villa

HDU 1102 Constructing Roads (最小生成树)

最小生成树模板(嗯……在kuangbin模板里面抄的……) 最小生成树(prim) /** Prim求MST * 耗费矩阵cost[][],标号从0开始,0~n-1 * 返回最小生成树的权值,返回-1表示原图不连通 */ const int INF = 0x3f3f3f3f; const int MAXN = 110; bool vis[MAXN]; int lowc[MAXN]; int map[MAXN][MAXN]; int Prim(int cost[][MAXN], int n) {

hdu 1102 Constructing Roads Kruscal

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1102 题意:这道题实际上和hdu 1242 Rescue 非常相似,改变了输入方式之后, 本题实际上更适合用Prim来做. 用Kruscal的话要做一些变化. /*Constructing Roads Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s)

HDU 1102 Constructing Roads【简单最小生成树,Prime算法+Kruskal算法】

Constructing Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 20765    Accepted Submission(s): 7934 Problem Description There are N villages, which are numbered from 1 to N, and you should

HDU 1102 Constructing Roads(kruskal)

Constructing Roads There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B,

hdu 1102 Constructing Roads 最小生成树Prim算法AC 水~~~

Constructing Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 15230    Accepted Submission(s): 5826 Problem Description There are N villages, which are numbered from 1 to N, and you should

HDU - 1102 - Constructing Roads (最小生成树--prim算法!!)

Constructing Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 14890    Accepted Submission(s): 5674 Problem Description There are N villages, which are numbered from 1 to N, and you should