CCNP第二天 帧中继综合实验

实验题如图所示: 要求全网可达 R5为帧中继交换机 R6 和 R1之间为快速以太网接口

所使用的拓扑为CCNA标准版拓扑图,如下所示:

---------------------------------------------------------------------------------------------------------------------------------

1.首先在帧中继交换机上打通各条PVC

frsw#conf t
frsw(config)#no ip routing         // 关闭路由器的路由功能
frsw(config)#frame-relay switching      // 打开帧中继交换功能
frsw(config)#int s1/0
frsw(config-if)#encapsulation frame-relay
frsw(config-if)#frame-relay intf-type dce
frsw(config-if)#frame-relay route 102 interface s1/1 201
frsw(config-if)#frame-relay route 103 interface s1/2 301
frsw(config-if)#frame-relay route 104 interface s1/3 401

frsw(config-if)#int s1/1
frsw(config-if)#encapsulation frame-relay
frsw(config-if)#frame-relay intf-type dce
frsw(config-if)#frame-relay route 201 interface s1/0 102

frsw(config-if)#int s1/2
frsw(config-if)#encapsulation frame-relay
frsw(config-if)#frame-relay intf-type dce
frsw(config-if)#frame-relay route 301 interface s1/0 103
frsw(config-if)#frame-relay route 304 interface s1/3 403

frsw(config-if)#int s1/3
frsw(config-if)#encapsulation frame-relay
frsw(config-if)#frame-relay intf-type dce
frsw(config-if)#frame-relay route 403 interface s1/2 304
frsw(config-if)#frame-relay route 401 interface s1/0 104

目前为止,帧中继上的pvc都已经打通了,下面进行客户端的配置
-------------------------------------------------------------------------

2. 各个客户端接口的配置

R1(config)#int s1/2
R1(config-if)#encapsulation frame-relay
R1(config-if)#no shutdown

R1(config)#int s1/2.1 multipoint       // 多点子接口
R1(config-subif)#ip add 123.1.1.1 255.255.255.0
R1(config-subif)#frame-relay interface-dlci 102
R1(config-fr-dlci)#frame-relay interface-dlci 103  

R1(config)#int s1/2.2 point-to-point       // 点到点子接口
R1(config-subif)#ip add 14.1.1.1 255.255.255.0  
R1(config-subif)#frame-relay interface-dlci 104

R2(config)#int s1/2
R2(config-if)#encapsulation frame-relay
R2(config-if)#ip add 123.1.1.2 255.255.255.0
R2(config-if)#no shutdown

R3(config)#int s1/2
R3(config-if)#encapsulation frame-relay
R3(config-if)#no shutdown

R3(config)#int s1/2.1 point-to-point
R3(config-subif)#ip add 123.1.1.3 255.255.255.0
R3(config-subif)#frame-relay interface-dlci 301

R3(config)#int s1/2.2 multipoint
R3(config-subif)#ip add 34.1.1.1 255.255.255.0
R3(config-subif)#frame-relay interface-dlci 304

R4(config)#int s1/2
R4(config-if)#encapsulation frame-relay
R4(config-if)#no shutdown

R4(config)#int s1/2.1 point-to-point
R4(config-subif)#ip add 34.1.1.2 255.255.255.0
R4(config-subif)#frame-relay interface-dlci 403

R4(config)#int s1/2.2 point-to-point
R4(config-subif)#ip add 14.1.1.2 255.255.255.0
R4(config-subif)#frame-relay interface-dlci 401

目前为止所有客户端接口子接口都已经配置完成了,下面进行测试
用R1 分别ping R2 R3 R4
用R3 ping R4 应该都是可以ping 通的 若不行 请仔细检查前面的配置 和各接口是否开启

PS: 建议多点子接口和物理接口手写Map,因为多点子接口和物理接口自动生成Map速度太慢,而点对点子接口不能手写Map,就算写了,也没有作用,因为点对点不关注第三层的IP地址。
-----------------------------------------------------------------------------------

然后给每个路由器配环回 起eigrp协议

1.环回略

R1的环回1.1.1.1    R2的环回2.2.2.2      ……

2.分别在每个路由器上起eigrp协议

R1(config)#router eigrp 90
R1(config-router)#no auto-summary
R1(config-router)#network 123.0.0.0
R1(config-router)#network 1.0.0.0
R1(config-router)#network 14.0.0.0

R2(config)#router eigrp 90
R2(config-router)#no auto-summary
R2(config-router)#network 123.0.0.0
R2(config-router)#network 2.0.0.0

R3(config)#router eigrp 90
R3(config-router)#no auto-summary
R3(config-router)#network 123.0.0.0
R3(config-router)#network 34.0.0.0
R3(config-router)#network 3.0.0.0

R4(config)#router eigrp 90
R4(config-router)#no auto-summary
R4(config-router)#network 14.0.0.0
R4(config-router)#network 34.0.0.0

目前为止,等待路由条目收敛完成后R1 R3 R4 的路由条目应该收敛齐全(除了R6)
而R2 没有34.0.0.0/24 和 3.0.0.0/24 这两天路由条目
-----------------------------------------------------------------------

内网访问外网 缺省和Nat

1.缺省
R1(config)#ip route 0.0.0.0 0.0.0.0 16.1.1.2
R1(config)#router eigrp 90
R1(config-router)#redistribute static      // 重发布

2.Nat
R1(config)#access-list 1 permit any
R1(config)#ip nat inside source list 1 interface f0/0 overload

R1(config)#int f0/0
R1(config-if)#ip nat outside

R1(config)#int s1/2.1
R1(config-subif)#ip nat inside

R1(config)#int s1/2.2
R1(config-subif)#ip nat inside

PS: 1.ip nat inside时,必须把每个子接口当做一个物理接口而不能把 s1/2当做inside

  2.有缺省和汇总的时候为了安全起见,应该防止路由黑洞的出现,所以该在所有做过汇总的路由器R2-R6上写一条空接口路由条目

   eg: R2(config)# ip router 192.168.1.0 255.255.255.240 null 0

      ……

       R6(config)# ip router 192.168.1.0 255.255.255.0 null 0    // 因为R6在s1/1上做过一次对R2-R6上的/24位的汇总

看到这里您辛苦了,谢谢 : )

—————————————————————————————————————————————————————————————————————————————

声明:

  本文为 大Yi巴狼 对自己所学的知识整理和实现。

  本文档欢迎自由转载,但请务必保持本文档完整或注明来之本文档。本文档未经 大Yi巴狼 同意,不得用于商业用途。最后,如果您能从这个简单文档里获得些许帮助,大Yi巴狼 将对自己的一点努力感到非常高兴;由于作者本人水平有限,如果本文档中包含的错误给您造成了不便,在此提前说声抱歉。

  祝身体健康,工作顺利。

CCNP第二天 帧中继综合实验

时间: 2024-10-14 08:57:39

CCNP第二天 帧中继综合实验的相关文章

【CCNP】路由策略综合实验

实验拓扑: 首先借助红茶三杯耿叔的拓扑图,来说明实验需求 然后自己用GNS3搭了一下拓扑 首先当初刚看耿叔的视频里这个图的时候,大脑很乱,因为需求比较复杂,可以使用的方法也多种多样,有点无从下手的感觉.等听完耿叔讲解后,才感觉豁然开朗,好了,不多说. 实验步骤: 进行基本配置 SW1 no ip routing ! R1 f0/0:192.168.12.1/24 l0:172.16.1.1/24 R2 f0/1:192.168.12.2/24 f0/0:192.168.23.2/24 f1/0:

CCNP第四天 OSPF综合实验(1)

ospf综合实验(1) 本实验主要考察ospf中的接口上的多种工作方式 实验如图所示: 所用拓扑为CCNP标准版,如图: ------------------------------------------------------------------------------------------------------------------------------------- 1. 全网可达 由于CCNP中帧中继是默认全部开启,而且是全连通的,所以在物理接口和多点子接口上建议关闭逆向a

CCNP第三天 EIGRP综合实验

实验题如图所示:其中R2连R3 R5为快速以太网线,其他均为串线,帧中继默认是富曼斯(全连网状结构),即所有接入的路由之间的PVC都已经打通,所有  要关闭R5和R8的逆向arp功能,来手工配置R5到R8的Map 实验所使用的拓扑为CCNP标准版拓扑图,如下: -----------------------------------------------------------------------------------------------------------------------

Linux运维实战之DNS综合实验

本次博文主要是对Linux系统中DNS知识的总结. DNS的基础知识(参见http://sweetpotato.blog.51cto.com/533893/1596973) DNS的基础配置(参见http://sweetpotato.blog.51cto.com/533893/1598225) DNS的高级配置(参见http://sweetpotato.blog.51cto.com/533893/1607383) [本次博文的主要内容] 1.以一个综合案例总结Linux系统中DNS的配置 2.B

小型交换综合实验

实验要求:PC1和PC2通过DHCP服务器获取地址 PC机和服务器能够连接到外网 PC机可以远程管理交换机 首先配置DHCP服务器:(拓扑中交换机 pc 服务器均用思科3640路由器模拟)n conf t server dhcp ip dhcp pool vlan10 network 192.168.10.0 /24 default-router 192.168.10.254   (给动态地址分配网关) ip dhcp pool vlan20 network 192.168.20.0 /24 d

NAT--PAT--RIP--DHCP-------小综合实验

NAT--PAT--RIP--DHCP-------小综合实验 一:实验拓扑 二:实验要求 1:要求pc机1和3属于vlan 10,2和4属于vlan 20. 2:要求sw1是三层交换机,要求所有的网关都在sw1上. 3:要求所有pc机都可以上互联网. 4:要求R2可以通过用户名和密码方式远程控制sw1 5:要求sw2和sw3可用通过密码方式被远程控制,且可以在第四条要求的基础上通过跳板技术被远程控制. 6:要求RIP协议实现全网互通. 7:要求自动分配pc机的ip. 三:实验步骤 第一步:实现

路由交换综合实验(用HSRP、OSPF、VTP、DHCP、ACL等)

综合实验 实验要求: 1.添加vlan10,vlan20,vlan30,vlan40,SW1与SW2之间做以太网通道,与交换机SW3.4.5.6之间做trunk链路. 2.vpcs1分配vlan10,真机分配vlan20,vpcs2分配vlan30,web服务分配vlan40, 3.在SW1与SW2上配置PVST+负载均衡,vlan10.vlan20为根网桥,vlan30.vlan40为备份根网桥,SW2与SW1相反, 4.添加DHCP地址池自动获取地址(DHCP服务的DNS地址为88.88.8

【Linux程序设计】之环境系统函数综合实验

这个系列的博客贴的都是我大二的时候学习Linux系统高级编程时的一些实验程序,都挺简单的.贴出来纯粹是聊胜于无. 实验题目:Linux环境下系统函数综合实验 实验目的:熟悉并掌握Linux环境下数学函数.字符函数.系统时间与日期函数.环境控制函数.内存分配函数以及数据结构中常用函数的使用方法. 一.Linux环境下数学函数的使用 设计程序,满足如下要求: 1.使用rand函数产生10个介于1到10之间的随机数值.要求在程序中对每行代码添加注释. 1 #include<stdio.h> 2 #i

eigrp综合实验

上配置,供参考 INTERNET: Current configuration : 1192 bytes ! version 12.4 service timestamps debug datetime msec service timestamps log datetime msec no service password-encryption ! hostname INTERNET ! boot-start-marker boot-end-marker ! ! no aaa new-mode