ZOJ 3609 Modular Inverse

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3609

题面:

Modular Inverse


Time Limit: 2 Seconds      Memory Limit: 65536 KB



The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1x (mod m).
This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn‘t exist, output "Not Exist".

Sample Input

3
3 11
4 12
5 13

Sample Output

4
Not Exist
8

解题:

乍一看,应该是中国剩余定理,还是什么线性同余方程,不过当初学这块没学好,仔细一看可以水过,等复习后,再来补充其他解法。

思路:

因为(a*x)%m==1%m,可以写作(a*(x‘+n*m))%m==1%m,当x的值超过m时,其实已经重复了,而m的范围在0到1000,所以直接暴就好了。

比较坑的是,写的时候,直接就把右边写作1了,没考虑到m=1的情况。因此,细节还是相当重要的,提交前,需要仔细检查一下边界数据。

代码:

#include <iostream>
#include <algorithm>
#include <string>
#include <iomanip>
#include <cstdio>
#include <cstring>
using namespace std;

int main()
{
    int t,a,m,x;
    bool flag;
    scanf("%d",&t);
    while(t--)
    {
    	scanf("%d%d",&a,&m);
    	if(m==1)
		{
		  printf("1\n");
		  continue;
		}
        flag=false;
        for(int i=1;i<=m;i++)
        {
           if((a*i)%m==1)
           {
             flag=true;
             printf("%d\n",i);
             break;
           }
        }
        if(!flag)printf("Not Exist\n");
    }
	return 0;
}
时间: 2024-08-12 07:08:37

ZOJ 3609 Modular Inverse的相关文章

ZOJ 3609 Modular Inverse (水题)

Modular Inverse Time Limit: 2 Seconds      Memory Limit: 65536 KB The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m). Input There are multiple test cases. Th

ZOJ 3609 Modular Inverse 解线性模方程

点击打开链接 Modular Inverse Time Limit: 2 Seconds      Memory Limit: 65536 KB The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m). Input There are multiple test ca

ZOJ 3609 Modular Inverse(扩展欧几里德)

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4712 The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m). Input There are multiple test cases.

ZOJ - 3609 —— Modular Inverse 【乘法逆,扩展欧几里得】

题目:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4712 1. 这题数据范围太小,直接暴力即可 2. 不过其实这题也是很“直白的”求乘法逆的题目,即当b=1的特殊的模线性方程问题ax≡b mod(n),可以通过扩展欧几里得算法求解:   ax≡b mod(n) => (ax) mod n = b mod n => ax=k1*n+r ... (1) b=k2n+r    ... (2)  (1)-(2)=>ax-

ZOJ 4712: Modular Inverse

Modular Inverse ///@author Sycamore, ZJNU; ///@date 8/6/2017 ///@ref stanford-acm-master #include<bits/stdc++.h> using namespace std; typedef long long ll; int mod(int a, int b) { return ((a%b) + b) % b; } int extended_euclid(int a, int b, int &

【ZOJ】3609 Modular Inverse

1. 题目描述求乘法逆元. 2. 基本思路利用扩展gcd求逆元,模板题目. 3. 代码 1 /* 3609 */ 2 #include <iostream> 3 #include <sstream> 4 #include <string> 5 #include <map> 6 #include <queue> 7 #include <set> 8 #include <stack> 9 #include <vector

Modular Inverse(模逆元,扩展欧几里德)

Modular Inverse Time Limit: 2 Seconds      Memory Limit: 65536 KB The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m). Input There are multiple test cases. Th

Modular Inverse(zoj3609+欧几里德)

Modular Inverse Time Limit: 2 Seconds      Memory Limit: 65536 KB The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m). Input There are multiple test cases. Th

寒假 D3 D Modular Inverse

Modular Inverse Time Limit: 2 Seconds                                     Memory Limit: 65536 KB The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m). Input Th