(状态压缩DP) poj 2978

Colored stones

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 1734   Accepted: 819

Description

You are given a row of m stones each of which has one of k different colors. What is the minimum number of stones you must remove so that no two stones of one color are separated by a stone of a different color?

Input

The input test file will contain multiple test cases. Each input test case begins with a single line containing the integers m and k where 1 ≤ m ≤ 100 and 1 ≤ k ≤ 5. The next line contains m integers x1, …, xmeach of which takes on values from the set {1, …, k}, representing the k different stone colors. The end-of-file is marked by a test case with m = k = 0 and should not be processed.

Output

For each input case, the program should the minimum number of stones removed to satisfy the condition given in the problem.

Sample Input

10 3
2 1 2 2 1 1 3 1 3 3
0 0

Sample Output

2

Hint

In the above example, an optimal solution is achieved by removing the 2nd stone and the 7th stone, leaving three “2” stones, three “1” stones, and two “3” stones. Other solutions may be possible.

题目大意:有N≤100个石头排成一列,每个石头都有颜色编号≤5,求扔掉最少的石头,使得任意两个相同颜色的石头之间没有其他颜色的石头[多组数据]

题解:很明显的状态压缩DP,但我一开始竟然想到搜索剪枝(扔掉该扔的以后一定成了几个颜色的排列=5!,加点优化应该能过)

DP[i][j][k] 前 i 个 最后留下的石子颜色为 j 用 k 记录颜色的出现情况

囧。。。DP太神了。。不得不服!

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
int m,k;
int a[105],dp[105][6][(1<<5)+2];
int main()
{
    while(scanf("%d%d",&m,&k)!=EOF)
    {
        if(m==0&&k==0)
            break;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=m;i++)
        {
            scanf("%d",&a[i]);
            a[i]--;
        }
        for(int i=1;i<=m;i++)
            dp[i][a[i]][1<<a[i]]=1;
        for(int i=1;i<m;i++)
        {
            for(int j=0;j<k;j++)
            {
                for(int t=0;t<(1<<k);t++)
                {
                    if(dp[i][j][t])
                    {
                        int temp=dp[i][j][t];
                        int ret=a[i+1];
                        int ins=(1<<ret);
                        if(ret==j)
                        {
                            dp[i+1][j][t]=max(dp[i+1][j][t],temp+1);
                        }
                        else if(ins&t)
                        {
                            dp[i+1][j][t]=max(dp[i+1][j][t],temp);
                        }
                        else
                        {
                            dp[i+1][j][t]=max(dp[i+1][j][t],temp);
                            dp[i+1][ret][t|ins]=max(dp[i+1][ret][t|ins],temp+1);
                        }
                    }
                }
            }
        }
        int ans=1;
        for(int i=0;i<k;i++)
        {
            for(int j=0;j<(1<<k);j++)
                ans=max(ans,dp[m][i][j]);
        }
        printf("%d\n",m-ans);
    }
    return 0;
}

  

时间: 2024-10-22 14:50:55

(状态压缩DP) poj 2978的相关文章

状态压缩dp poj 3254 hdu5045

近来感觉状态压缩dp的强大性(灵活利用了二进制运算很关键)...于是做了俩提来看看..毕竟队友是专业的dp,我只是管中窥豹下而已..日后有机会再与之玩耍玩耍...ps:如果上天再给我一次机会,当年我愿意选择状态dp而不是网络流(只针对目前比赛出题潮流) 经典问题,不相邻/禁点方案数问题.poj3254 #include<iostream> #include<cstdio> using namespace std; int n,m; int dp[5000][15]; int yu[

状态压缩DP——POJ 2923

对应POJ题目:点击打开链接 Exponentiation Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 2923 Description Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortu

(状态压缩DP) poj 2441

Arrange the Bulls Time Limit: 4000MS   Memory Limit: 65536K Total Submissions: 3709   Accepted: 1422 Description Farmer Johnson's Bulls love playing basketball very much. But none of them would like to play basketball with the other bulls because the

(状态压缩dp) poj 3254

Corn Fields Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 8729   Accepted: 4651 Description Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yumm

POJ 3254 Corn Fields 状态压缩DP (C++/Java)

http://poj.org/problem?id=3254 题目大意: 一个农民有n行m列的地方,每个格子用1代表可以种草地,而0不可以.放牛只能在有草地的,但是相邻的草地不能同时放牛, 问总共有多少种方法. 思路: 状态压缩的DP. 可以用二进制数字来表示放牧情况并判断该状态是否满足条件. 这题的限制条件有两个: 1.草地限制. 2.相邻限制. 对于草地限制,因为输入的时候1是可以种草地的. 以"11110"草地分析,就只有最后一个是不可以种草的.取反后得00001  .(为啥取反

poj 2411 Mondriaan&#39;s Dream(状态压缩+dp)

 题意:用1*2砖块铺满n*m的房间. 思路转自:http://www.cnblogs.com/scau20110726/archive/2013/03/14/2960448.html 因为这道题输入范围在11*11之间,所以可以先打表直接输出.......... 状态压缩DP 经典覆盖问题,输入n和m表示一个n*m的矩形,用1*2的方块进行覆盖,不能重叠,不能越出矩形边界,问完全覆盖完整个矩形有多少种不同的方案 其中n和m均为奇数的话,矩形面积就是奇数,可知是不可能完全覆盖的.接着我们来看

POJ 3254 Corn Fields 状态压缩DP

题目链接:http://poj.org/problem?id=3254 思路:状态压缩DP,状态方程为dp[i][j] += (dp[i-1][k]) code: #include <stdio.h> #include <string.h> #define N 500 const int MOD = 100000000; int dp[15][N],ant[N],n,m,k,map[15]; bool ok(int x) { if(x&(x<<1))return

POJ 3691 (AC自动机+状态压缩DP)

题目链接:  http://poj.org/problem?id=3691 题目大意:给定N的致病DNA片段以及一个最终DNA片段.问最终DNA片段最少修改多少个字符,使得不包含任一致病DNA. 解题思路: 首先说一下AC自动机在本题中的作用. ①字典树部分:负责判断当前0~i个字符组成的串是否包含致病DNA,这部分靠字典树上的cnt标记完成. ②匹配部分:主要依赖于匹配和失配转移关系的计算,这部分非常重要,用来构建不同字符间状态压缩的转移关系(代替反人类的位运算). 这也是必须使用AC自动机而

poj 3254 Corn Fields ,状态压缩DP

题目链接 题意: 一个矩阵里有很多格子,每个格子有两种状态,可以放牧和不可以放牧,可以放牧用1表示,否则用0表示,在这块牧场放牛,要求两个相邻的方格不能同时放牛,即牛与牛不能相邻.问有多少种放牛方案(一头牛都不放也是一种方案) state[i] 表示对于一行,保证不相邻的方案 状态:dp[i][ state[j] ]  在状态为state[j]时,到第i行符合条件的可以放牛的方案数 状态转移:dp[i][ state[j] ] =Sigma dp[i-1][state'] (state'为符合条