Shopaholic

Description

Lindsay is a shopaholic. Whenever there is a discount of the kind where you can buy three items and only pay for two, she goes completely mad and feels a need to buy all items in the store. You have given up on curing her for this disease, but try to limit
its effect on her wallet.

You have realized that the stores coming with these offers are quite selective when it comes to which items you get for free; it is always the cheapest ones. As an example, when your friend comes to the counter with seven items, costing 400, 350, 300, 250,
200, 150, and 100 dollars, she will have to pay 1500 dollars. In this case she got a discount of 250 dollars. You realize that if she goes to the counter three times, she might get a bigger discount. E.g. if she goes with the items that costs 400, 300 and
250, she will get a discount of 250 the first round. The next round she brings the item that costs 150 giving no extra discount, but the third round she takes the last items that costs 350, 200 and 100 giving a discount of an additional 100 dollars, adding
up to a total discount of 350.

Your job is to find the maximum discount Lindsay can get.

Input

The first line of input gives the number of test scenarios, 1 <= t <= 20. Each scenario consists of two lines of input. The first gives the number of items Lindsay is buying, 1 <= n <= 20000. The next line gives the prices of these items,
1 <= pi <= 20000.

Output

For each scenario, output one line giving the maximum discount Lindsay can get by selectively choosing which items she brings to the counter at the same time.

Sample Input

1

6

400 100 200 350 300 250

Sample Output

400

//在排序的过程中之前用冒泡排序超时,用sort排序则不超时

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
bool compare(int x,int y)
{
	return x>y;
}
int main()
{
	int t;
	int a[30000];
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			int n,i,j;
		    cin>>n;
		    int count=0;
		    for(i=0;i<n;i++)
				cin>>a[i];
		   /* for(i=0;i<n;i++)//冒泡排序
			{
				for(j=0;j<n-i-1;j++)
				{
				if(a[j]<a[j+1])
					swap(a[j],a[j+1]);
				}
			}*/
			sort(a,a+n,compare);
		    for(i=0;i<n;i++)
			{
				if((i+1)%3==0)
					count+=a[i];
			}
		    cout<<count<<endl;
		}
	}
	return 0;
}
时间: 2024-08-10 17:47:46

Shopaholic的相关文章

1438. Shopaholic

Constraints Time Limit: 1 secs, Memory Limit: 32 MB Description Lindsay is a shopaholic. Whenever there is a discount of the kind where you can buy three items and only pay for two, she goes completely mad and feels a need to buy all items in the sto

Sicily Online Judge 1438. Shopaholic (快排,隔三求和)

1438. Shopaholic Constraints Time Limit: 1 secs, Memory Limit: 32 MB Description Lindsay is a shopaholic. Whenever there is a discount of the kind where you can buy three items and only pay for two, she goes completely mad and feels a need to buy all

UVa 11369 Shopaholic

题意: 又到了剁手的季节,购物狂们开始行动,超市也开始行动,规定是:每买三件,可以省去1件最便宜的价格. 给出买的商品数,和每个商品的价值,求出购物狂一共赚了多少钱,呵呵. 思路: 把数据从大到小拍序,把3的倍数的商品价值相加,就是答案. 实现:重写C++STL里的sort()函数的比较函数 bool compare(); 代码: 1 #include <iostream> 2 #include <cstring> 3 #include <cstdio> 4 #incl

HDOJ(HDU) 1678 Shopaholic

Problem Description Lindsay is a shopaholic. Whenever there is a discount of the kind where you can buy three items and only pay for two, she goes completely mad and feels a need to buy all items in the store. You have given up on curing her for this

ZOJ 2883 Shopaholic【贪心】

解题思路:给出n件物品,每买三件,折扣为这三件里面最便宜的那一件即将n件物品的价值按降序排序,依次选择a[3],a[6],a[9]----a[3*k] Shopaholic Time Limit: 2 Seconds      Memory Limit: 65536 KB Lindsay is a shopaholic. Whenever there is a discount of the kind where you can buy three items and only pay for

HDU 1678 Shopaholic(简单数学题 贪心)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1678 Problem Description Lindsay is a shopaholic. Whenever there is a discount of the kind where you can buy three items and only pay for two, she goes completely mad and feels a need to buy all items in

hdu 1678(Shopaholic )(最大折扣)(水题,cheapest)

Shopaholic Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1693    Accepted Submission(s): 954 Problem Description Lindsay is a shopaholic. Whenever there is a discount of the kind where you ca

(HDU)1708 -- Shopaholic (购物狂)

题目链接:https://vjudge.net/problem/HDU-1708 刚开始写了一个呆萌模拟TLE蠢代码: 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 #include <cmath> 5 #include <algorithm> 6 7 using namespace std; 8 9 char ans[100000]; 10 char temp[

Maximal Discount

Description: Linda is a shopaholic. Whenever there is a discount of the kind where you can buy three items and only pay for two, she goes completely mad and feels a need to buy all items in the store. You have given up on curing her for this disease,