杭电1253 胜利大逃亡

胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 24756    Accepted Submission(s): 9478

Problem Description

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

Input

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output

对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input

1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0

Sample Output

11

这道题是三维数组,立体的,不过和走迷宫那种平面的是一样的

代码:

#include<stdio.h>

#include<queue>

using namespace std ;

int a[60][60][60] ;//用来存0,1的

int A , B , C, T ;

struct node

{

int x , y , z ,step ;//分别代表x,y,z坐标,和步数

} ;

//代表6个方向,不同的走法

int dir[6][3] = {0 , 0 , 1 , 0 , 0 , -1, 0 , 1 , 0 , -1 , 0 , 0 , 0 , -1 , 0 , 1 , 0 , 0 } ;

//判断是否越界和此点是否为0

bool judge(int x,int y, int z)

{

if(x >= 0 && x < A && y >= 0 && y < B && z >= 0 && z < C && a[x][y][z] == 0)

return 1 ;

return 0 ;

}

//利用广搜进行扩充

int BFS()

{

queue <node> q ;

node start , next ;//代表开始的一组和接下来的一组

int k , x, y ,z ;

start.x = start. y = start.z  = start.step = 0 ;

q.push ( start ) ;

a[0][0][0] = 1 ;

while(!q.empty())

{

start = q.front() ;

q.pop();

if(start.step >= T)

return -1 ;//如果超过了魔王回来的时间就返回-1

next.step = start.step + 1 ;

for(k = 0 ;k < 6 ; k++)

{

next.x = x = cur.x + dir[k][0] ;

next.y = y = cur.y + dir[k][1] ;

next.z = z = cur.z + dir[k][2] ;

if(judge(x , y , z))

{

//当这三个点达到了门的前一步,直接返回其步数

if(x == A - 1 && y == B-1 && z == C-1)

return next.step ;

a[x][y][z] = 1 ;//走过的点都标记为1,不能往回走

q.push(next) ;

}

}

}

return -1 ;

}

int main()

{

int k = 0 ;

scanf("%d",&k) ;

while(k--)

{

scanf("%d%d%d%d" , &A , &B , &C , &T );

int i = 0  , j = 0 , q = 0  ;

for(i = 0 ;i < A ; i++)

{

for(j = 0 ; j < B ; j++)

{

for(q = 0 ; q < C ; q++)

{

scanf("%d",&a[i][j][q]);

}

}

}

int count = 0 ;//记录分钟数

if(a[A-1][B-1][C-1])

count = -1 ;//如果在门的前一步为1,即不能通过,直接返回-1

else

count = BFS();

printf("%d\n",count);

}

return 0 ;

}

杭电1253 胜利大逃亡,布布扣,bubuko.com

时间: 2024-10-24 05:49:16

杭电1253 胜利大逃亡的相关文章

HDU 1253 胜利大逃亡(BFS)

#include <iostream> #include <cstdlib> #include <cstdio> #include <queue> #include <cstring> using namespace std; struct node{ int x,y,z,step; }; int ma[51][51][51]; int A,B,C,T; int mv[6][3] = {{1,0,0},{0,1,0},{0,0,1},{-1,0,

HDU 1253 胜利大逃亡 NYOJ 523【BFS】

胜利大逃亡 Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 24608    Accepted Submission(s): 9427 Problem Description Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会. 魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的

[ACM] hdu 1253 胜利大逃亡 (三维BFS)

胜利大逃亡 Problem Description Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会. 魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出

hdu 1253 胜利大逃亡(简单题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1253 题目大意:在所给的时间能顺利离开城堡. 1 #include <iostream> 2 #include <cstdio> 3 #include <queue> 4 #include <cstring> 5 using namespace std; 6 int map[55][55][55],visit[55][55][55],a,b,c,T; 7 int

hdoj 1253 胜利大逃亡

胜利大逃亡 Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 28023    Accepted Submission(s): 10632 Problem Description Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会. 魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的

HDU 1253 胜利大逃亡

胜利大逃亡 Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 30841    Accepted Submission(s): 11509 Problem Description Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会. 魔 王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C

poj 2251Dungeon Master+hdu 1253 胜利大逃亡(bfs)

Dungeon Master Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 18875   Accepted: 7324 Description You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled

HDU 1253 胜利大逃亡(三维BFS)

胜利大逃亡 Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会. 魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignat

hdu 1253 胜利大逃亡(bfs)

胜利大逃亡 Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 29504    Accepted Submission(s): 11124 Problem Description Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会. 魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的