PAT 1090 Highest Price in Supply Chain[较简单]

1090 Highest Price in Supply Chain(25 分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one‘s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10?5??), the total number of the members in the supply chain (and hence they are numbered from 0 to N?1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S?i?? is the index of the supplier for the i-th member. S?root??for the root supplier is defined to be ?1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 10?10??.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

题目大意:也是一个销售链,给出一个树结构,求数的高度,并且在最高的叶节点有几个。

//这个和1079是类似的,都是使用dfs吧!传参进去一定要有level咯,记住maxLevel和每个叶节点的层数即可。

#include <iostream>
#include<stdio.h>
#include<cmath>
#include<vector>
using namespace std;
double p,r;
vector<int> tree[100001];
int book[100001];
int maxL=0;
void dfs(int index,int level){
    if(tree[index].size()==0){
        book[index]=level;
        if(level>maxL)
            maxL=level;
        return ;
    }
    for(int i=0;i<tree[index].size();i++)
        dfs(tree[index][i],level+1);
}

int main() {
    int n;
    scanf("%d %lf %lf",&n,&p,&r);
    int temp,root=-1;
    for(int i=0;i<n;i++){
        scanf("%d",&temp);
        if(temp!=-1){
            tree[temp].push_back(i);
        }
        else root=i;
    }
    dfs(root,0);
    int ct=0;
    for(int i=0;i<n;i++){
        if(book[i]==maxL)
            ct++;
    }
    printf("%.2f %d",p*pow(1+r/100,maxL),ct);
    return 0;
}

//一次通过,简直非常开心了!我应该把关于树的深度遍历,高度,这些东西都掌握了。非常开心。

1.树的dfs都是有结构的,非常简单。

2.需要记录叶节点的高度。

原文地址:https://www.cnblogs.com/BlueBlueSea/p/9522846.html

时间: 2024-08-29 14:23:39

PAT 1090 Highest Price in Supply Chain[较简单]的相关文章

PAT 1090. Highest Price in Supply Chain (25)(DFS啊 )

题目链接:http://www.patest.cn/contests/pat-a-practise/1090 A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone o

PAT 1090. Highest Price in Supply Chain

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone on the chain buys products from one's supplier in a pric

1090. Highest Price in Supply Chain (25)【树】——PAT (Advanced Level) Practise

题目信息 1090. Highest Price in Supply Chain (25) 时间限制200 ms 内存限制65536 kB 代码长度限制16000 B A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)– everyone involved in moving a product from supplier to customer. Starting from o

1090. Highest Price in Supply Chain (25)

时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplie

1090 Highest Price in Supply Chain (25 分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone on the chain buys products from one's supplier in a pric

1090 Highest Price in Supply Chain (25 分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone on the chain buys products from one's supplier in a pric

PAT (Advanced Level) 1090. Highest Price in Supply Chain (25)

简单dfs. #include<cstdio> #include<cstring> #include<cmath> #include<algorithm> #include<map> #include<queue> #include<stack> #include<vector> using namespace std; const int maxn=100000+10; vector<int>g[

PAT:1090. Highest Price in Supply Chain (25) AC

#include<stdio.h> #include<vector> using namespace std; const int MAX=100010; int DEPest=0,times=0; vector<int> child[MAX]; //child[父亲][孩子] 二维数组表示树形结构 void DFS(int root,int depth) { if(child[root].size()==0) //叶子节点开始判断深度 { if(depth>DE

1090 highest price in supply chain

p,r用double类型,pat多题如果用float会WA AC代码 #include <vector> #include <cstdio> #include <cmath> using namespace std; int main(){ int n; double p,r; scanf("%d %lf %lf",&n,&p,&r); r /= 100.0; vector<int> s; vector<in