PAT Advanced 1029 Median (25分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

这题考察归并,在归并过程中,到中间数字即可

#include <iostream>
using namespace std;
int arr[1000000] = {0}, arr2[1000000] = {0}, arr3[1000000] = {0};
int main() {
    int M, N;
    scanf("%d", &M);
    for(int i = 0; i < M; i++)
        scanf("%d", arr+i);
    scanf("%d", &N);
    for(int i = 0; i < N; i++)
        scanf("%d", arr2+i);
    int i = 0, j = 0, k = 0;
    while(i < M && j < N) {
        if(arr[i] < arr2[j]) arr3[k++] = arr[i++];
        else arr3[k++] = arr2[j++];
        if(k == (M + N + 1) / 2)
             printf("%d\n", arr3[k - 1]);
    }
    while(i < M) {
        arr3[k++] = arr[i++];
        if(k == (M + N + 1) / 2)
             printf("%d\n", arr3[k - 1]);
    }
    while(j < N) {
        arr3[k++] = arr2[j++];
        if(k == (M + N + 1) / 2)
             printf("%d\n", arr3[k - 1]);
    }
    return 0;
}

原文地址:https://www.cnblogs.com/littlepage/p/12248657.html

时间: 2024-08-04 09:11:22

PAT Advanced 1029 Median (25分)的相关文章

PAT 甲级 1029 Median (25 分)(思维题,找两个队列的中位数,没想到)*

1029 Median (25 分) Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequence

1029 Median (25 分)

1029 Median (25 分) Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequence

1029 Median (25分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be

PAT:1029. Median (25) AC

#include<stdio.h> #include<algorithm> using namespace std; int arr1[1000066]; int arr2[1000066]; int main() { int n1,n2; scanf("%d",&n1); for(int i=0 ; i<n1 ; ++i) { scanf("%d",&arr1[i]); } scanf("%d",&

1029. Median (25)【排序】——PAT (Advanced Level) Practise

题目信息 1029. Median (25) 时间限制400 ms 内存限制65536 kB 代码长度限制16000 B Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17}

PAT 1029. Median (25)

1029. Median (25) Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defi

PAT (Advanced Level) 1029. Median (25)

scanf读入居然会超时...用了一下输入挂才AC... #include<cstdio> #include<cstring> #include<cmath> #include<string> #include<queue> #include<iostream> #include<algorithm> using namespace std; const int maxn=1000000+10; int a[maxn],b

1029. Median (25)

时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15,

PAT 5-8 File Transfer (25分)

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other? Input Specification: