PAT 甲级 1106 Lowest Price in Supply Chain (25分) (bfs)

1106 Lowest Price in Supply Chain (25分)

 

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one‘s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤), the total number of the members in the supply chain (and hence their ID‘s are numbered from 0 to N−1, and the root supplier‘s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K?i?? ID[1] ID[2] ... ID[K?i??]

where in the i-th line, K?i?? is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID‘s of these distributors or retailers. K?j?? being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0

Sample Output:

1.8362 2

题意:

供应链由零销商、经销商、供应商组成,从供应商开始,供应链上的每个人在购买货物的时候需要支付比原价格多r%的费用,供应链上不存在环,本题要求求出顾客为购买货物支付的最少费用,并且求出最低价格的供应链存在的条数.

题解:

bfs。先根据入度找到根节点root。用vector保存路径。接着bfs,记录下所有节点的深度depth。最后遍历所有零销商,找到depth最小的即可。开始看成路径最长,价格最贵的了。。。。应该是价格最低的。

AC代码:

#include<bits/stdc++.h>
using namespace std;
vector<int>v[100005];
queue<int>q;
double p,r;
int n;
int in[100005];
int depth[100005];
int main(){
    cin>>n>>p>>r;
    for(int i=0;i<n;i++){
        int m;
        cin>>m;
        for(int j=1;j<=m;j++){
            int x;
            cin>>x;
            v[i].push_back(x);
            in[x]++;
        }
    }
    int root=-1;
    for(int i=0;i<n;i++){
        if(in[i]==0){
            root=i;
            break;
        }
    }
    depth[root]=0;
    q.push(root);
    //cout<<"根"<<root<<endl;
    while(!q.empty()){
        int x=q.front();
        q.pop();
        //cout<<"v[x].size()"<<v[x].size()<<endl;
        for(int i=0;i<v[x].size();i++){
            int y=v[x].at(i);
            depth[y]=depth[x]+1;
            q.push(y);
            //cout<<"到"<<y<<"距离"<<depth[y]<<endl;
        }
    }
    int mm=100005;
    int num=1;
    for(int i=0;i<n;i++){
        if(v[i].size()==0){
            if(depth[i]<mm){
                mm=depth[i];
                num=1;
            }else if(depth[i]==mm) num++;
        }
    }
    for(int i=1;i<=mm;i++){
        p=p*(1+r*0.01);
    }
    printf("%.4lf %d",p,num);
    return 0;
} 

原文地址:https://www.cnblogs.com/caiyishuai/p/12241811.html

时间: 2024-10-02 00:19:22

PAT 甲级 1106 Lowest Price in Supply Chain (25分) (bfs)的相关文章

1106. Lowest Price in Supply Chain (25)【树+深搜】——PAT (Advanced Level) Practise

题目信息 1106. Lowest Price in Supply Chain (25) 时间限制200 ms 内存限制65536 kB 代码长度限制16000 B A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)– everyone involved in moving a product from supplier to customer. Starting from on

[建树(非二叉树)] 1106. Lowest Price in Supply Chain (25)

1106. Lowest Price in Supply Chain (25) A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone on the chain buy

1106. Lowest Price in Supply Chain (25)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone on the chain buys products from one's supplier in a pric

PAT (Advanced Level) 1106. Lowest Price in Supply Chain (25)

简单dfs #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<queue> #include<stack> #include<algorithm> using namespace std; const int maxn=100000+10; vector<int>g[m

1106 Lowest Price in Supply Chain

大致题意就是给出一棵树,求出叶子结点的最小权值,并输出该叶子节点的个数. 这是一道模板题,我近期做的几乎都是模板题.我现在认为 树与二叉树 是对 图 的一种严格约束,并且“二叉树,树,图”使用邻接表的存储结构比较多. 1 #include<iostream> 2 #include<vector> 3 #include<map> 4 using namespace std; 5 6 const int maxn = 100010; 7 vector<int>

PAT:1090. Highest Price in Supply Chain (25) AC

#include<stdio.h> #include<vector> using namespace std; const int MAX=100010; int DEPest=0,times=0; vector<int> child[MAX]; //child[父亲][孩子] 二维数组表示树形结构 void DFS(int root,int depth) { if(child[root].size()==0) //叶子节点开始判断深度 { if(depth>DE

1090. Highest Price in Supply Chain (25)【树】——PAT (Advanced Level) Practise

题目信息 1090. Highest Price in Supply Chain (25) 时间限制200 ms 内存限制65536 kB 代码长度限制16000 B A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)– everyone involved in moving a product from supplier to customer. Starting from o

pat1090. Highest Price in Supply Chain (25)

1090. Highest Price in Supply Chain (25) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to

PAT 1090. Highest Price in Supply Chain (25)(DFS啊 )

题目链接:http://www.patest.cn/contests/pat-a-practise/1090 A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone o