POJ 2075 Tangled in Cables (kruskal算法 MST + map)

Tangled in Cables

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 6039   Accepted: 2386

Description

You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found
in an old warehouse you bought. Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use
to run your cable between the houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.

Input

Only one town will be given in an input.

  • The first line gives the length of cable on the spool as a real number.
  • The second line contains the number of houses, N
  • The next N lines give the name of each house‘s owner. Each name consists of up to 20 characters {a–z,A–Z,0–9} and contains no whitespace or punctuation.
  • Next line: M, number of paths between houses
  • next M lines in the form

< house name A > < house name B > < distance >

Where the two house names match two different names in the list above and the distance is a positive real number. There will not be two paths between the same pair of houses.

Output

The output will consist of a single line. If there is not enough cable to connect all of the houses in the town, output

Not enough cable

If there is enough cable, then output

Need < X > miles of cable

Print X to the nearest tenth of a mile (0.1).

Sample Input

100.0
4
Jones
Smiths
Howards
Wangs
5
Jones Smiths 2.0
Jones Howards 4.2
Jones Wangs 6.7
Howards Wangs 4.0
Smiths Wangs 10.0

Sample Output

Need 10.2 miles of cable

Source

Mid-Atlantic 2004

题目链接:poj.org/problem?id=2075

题目大意:给一个总线长,和n个人,m组关系,表示两个人之间的距离,现在要求所有人之间都连通,问最少需要多长的线,若超过总长,则输出Not enough cable

题目分析:裸最小生成树问题,直接map一下字符串,再跑一下Kruskal

#include <cstdio>
#include <cstring>
#include <map>
#include <algorithm>
#include <iostream>
using namespace std;
int const MAX = 1e4;

int fa[MAX];
int re[MAX];
int n, m;
map<string, int> mp;

struct Edge
{
    int u, v;
    double w;
}e[MAX];

bool cmp(Edge a, Edge b)
{
    return a.w < b.w;
}

void UF_set()
{
    for(int i = 0; i < MAX; i++)
        fa[i] = i;
}

int Find(int x)
{
    return x == fa[x] ? x : fa[x] = Find(fa[x]);
}

void Union(int a, int b)
{
    int r1 = Find(a);
    int r2 = Find(b);
    if(r1 != r2)
        fa[r2] =r1;
}

double Kruskal()
{
    UF_set();
    int num = 0;
    double res = 0;
    for(int i = 0; i < m; i++)
    {
        int u = e[i].u;
        int v = e[i].v;
        if(Find(u) != Find(v))
        {
            Union(u, v);
            res += e[i].w;
            num ++;
        }
        if(num >= n - 1)
            break;
    }
    return res;
}

int main()
{
    string s, s1, s2;
    double val, sum, ans = 0;
    scanf("%lf", &sum);
    int cnt = 1;
    mp.clear();
    scanf("%d", &n);
    for(int i = 0; i < n; i++)
    {
        cin >> s;
        if(!mp[s])
            mp[s] = cnt ++;
    }
    scanf("%d", &m);
    for(int i = 0; i < m; i++)
    {
        cin >> s1 >> s2 >> val;
        e[i].u = mp[s1];
        e[i].v = mp[s2];
        e[i].w = val;
    }
    sort(e, e + m, cmp);
    ans = Kruskal();
    if(ans < sum)
        printf("Need %.1f miles of cable\n", ans);
    else
        printf("Not enough cable\n");
}
时间: 2024-12-15 06:56:42

POJ 2075 Tangled in Cables (kruskal算法 MST + map)的相关文章

POJ 2075 Tangled in Cables (c++/java)

http://poj.org/problem?id=2075 题目大意: 给你一些人名,然后给你n条连接这些人名所拥有的房子的路,求用最小的代价求连接这些房子的花费是否满足要求. 思路: 昨天20分钟的题,输入不小心写错了- -|||||看世界杯半场休息随便看了下发现了....T T 用map进行下标的映射,然后求MST即可. c++ #include<cstdio> #include<string> #include<map> #include<algorith

poj 2075 Tangled in Cables

Tangled in Cables Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other) Total Submission(s) : 19   Accepted Submission(s) : 6 Problem Description You are the owner of SmallCableCo and have purchased the franchise rights for

POJ 2075:Tangled in Cables 【Prim】

Tangled in Cables Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other) Total Submission(s) : 2   Accepted Submission(s) : 1 Problem Description You are the owner of SmallCableCo and have purchased the franchise rights for

poj 1789 Truck History(kruskal算法)

题目链接:http://poj.org/problem?id=1789 思路:把每一行看成一个一个点,每两行之间不懂得字符个数就看做是权值.然后用kruskal算法计算出最小生成树 我写了两个代码一个是用优先队列写的,但是超时啦,不知道为什么,希望有人可以解答.后面用的数组sort排序然后才AC. code: 数组sort排序AC代码: #include<cstdio> #include<queue> #include<algorithm> #include<io

ZOJ1372 POJ 1287 Networking 网络设计 Kruskal算法

题目链接:ZOJ1372 POJ 1287 Networking 网络设计 Networking Time Limit: 2 Seconds      Memory Limit: 65536 KB You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible

poj——2031 最小生成树(MST) Kruskal算法

poj——2031 最小生成树(MST)  Kruskal算法 Building a Space Station Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 4985   Accepted: 2503 Description You are a member of the space station engineering team, and are assigned a task in the constructio

ZOJ 1542 POJ 1861 Network 网络 最小生成树,求最长边,Kruskal算法

题目连接:ZOJ 1542 POJ 1861 Network 网络 Network Time Limit: 2 Seconds      Memory Limit: 65536 KB      Special Judge Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, t

POJ 1861 Network (Kruskal算法+输出的最小生成树里最长的边==最后加入生成树的边权 *【模板】)

Network Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 14021   Accepted: 5484   Special Judge Description Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the c

ZOJ 1718 POJ 2031 Building a Space Station 修建空间站 最小生成树 Kruskal算法

题目链接:ZOJ 1718 POJ 2031 Building a Space Station 修建空间站 Building a Space Station Time Limit: 2 Seconds      Memory Limit: 65536 KB You are a member of the space station engineering team, and are assigned a task in the construction process of the statio