poj2871 A Simple Question of Chemistry

A Simple Question of Chemistry

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6666   Accepted: 4426

Description

Your chemistry lab instructor is a very enthusiastic graduate student who clearly has forgotten what their undergraduate Chemistry 101 lab experience was like. Your instructor has come up with the brilliant idea that you will monitor the temperature of your
mixture every minute for the entire lab. You will then plot the rate of change for the entire duration of the lab.

Being a promising computer scientist, you know you can automate part of this procedure, so you are writing a program you can run on your laptop during chemistry labs. (Laptops are only occasionally dissolved by the chemicals used in such labs.) You will write
a program that will let you enter in each temperature as you observe it. The program will then calculate the difference between this temperature and the previous one, and print out the difference. Then you can feed this input into a simple graphing program
and finish your plot before you leave the chemistry lab.

Input

The input is a series of temperatures, one per line, ranging from -10 to 200. The temperatures may be specified up to two decimal places. After the final observation, the number 999 will indicate the end of the input data stream. All data sets will have at
least two temperature observations.

Output

Your program should output a series of differences between each temperature and the previous temperature. There is one fewer difference observed than the number of temperature observations (output nothing for the first temperature). Differences are always output
to two decimal points, with no leading zeroes (except for the ones place for a number less than 1, such as 0.01) or spaces. After the final output, print a line with "End of Output".

Sample Input

10.0
12.05
30.25
20
999

Sample Output

2.05
18.20
-10.25
End of Output

水!!!

参考代码:

#include<stdio.h>
int main()
{
    double n,n1;
 scanf("%lf",&n);
 while(n!=999)
 {
  scanf("%lf",&n1);
  if(n1!=999)
   printf("%.2f\n",n1-n);

   n=n1;

 }
 printf("End of Output\n");
 return 0;
}
时间: 2025-01-05 20:33:22

poj2871 A Simple Question of Chemistry的相关文章

zoj 1763 A Simple Question of Chemistry

A Simple Question of Chemistry Time Limit: 2 Seconds      Memory Limit: 65536 KB Your chemistry lab instructor is a very enthusiastic graduate student who clearly has forgotten what their undergraduate Chemistry 101 lab experience was like. Your inst

POJ 2871 A Simple Question of Chemistry(水题)

[题意简述]:后一个数减去前一个数并输出. [分析]:水 //208K 16Ms #include<iostream> using namespace std; int main() { double a; double b; bool flag = false; double ans; while(cin>>a) { if(a==999) { cout<<"End of Output"<<endl; break; } if(!flag)

YTUOJ-A Simple Question

Description 今天,pasher打算在一个浪漫的花园和他的搭档们聚餐,但是不幸的是,pasher忘记了花园的地点,他只记得这个花园看上去像个平行于坐标轴的正方形,他还记得花园的每个顶点上都有一棵大数.现在,pasher知道其中两棵树的坐标,且这两棵树在对角线上,你能帮他找出另外两棵树的坐标吗? Input 多组输入,直到文件末.每组输入包含一行,第一行包含四个整数,x1,y1,x2,y2,代表pasher知道的两棵树的坐标,(-100<=x1,y1,x2,y2<=100),其中x1,

转摘&lt;&lt;On becoming an expert C programmer&gt;&gt;

The following is from an EMail message that I sent to to an individual on 12-Apr-2001. You may find this EMail message useful. The Writer asked: ``I just recently visited your website ... Just wanted to say greetings and ask a simple question: Do you

Python Base Two

//fourth day to study python 24. In python , how to create funcation. we can use def to define funcation. such as: def MyFirstFuncation(): print('this is my first funcation') MyFirstFuncation() -> this is my first funcatio. if there are no MyFirstFun

How to read a scientific paper

How to read a scientific paper Nothing makes you feel stupid quite like reading a scientific journal article. I remember my first experience with these ultra-congested and aggressively bland manuscripts so dense that scientists are sometimes caught e

越狱Season 1-Episode 21: Go

Season 1, Episode 21: Go -Michael: I need you to let me get us out of here. 我需要你帮我出去 -Patoshik: If you try to screw me over again, I'll kill you screw: [俚语]诈骗  again: 再一次 你再戏弄我,我就杀了你 -doctor: Because if crazy steps out of line, crazy: 疯狂的 step: 措施,举措

全面解析《嵌入式程序员应该知道的16个问题》

文章为转载文章,写的很好,和大家分享下,原文连接如下: ----Sailor_forever分析整理,[email protected] http://blog.csdn.net/sailor_8318/archive/2008/03/25/2215041.aspx 1.预处理器(Preprocessor) 2.如何定义宏 3.预处理器标识#error的目的是什么? 4.死循环(Infinite loops) 5.数据声明(Data declarations) 6.关键字static的作用是什么

【转】嵌入式程序员应该知道的16个问题

全面解析<嵌入式程序员应该知道的16个问题> ----Sailor_forever分析整理,[email protected] http://blog.csdn.net/sailor_8318/archive/2008/03/25/2215041.aspx 1.预处理器(Preprocessor) 2.如何定义宏 3.预处理器标识#error的目的是什么? 4.死循环(Infinite loops) 5.数据声明(Data declarations) 6.关键字static的作用是什么? 7.