2015南阳CCPC D - Pick The Sticks 背包DP.

D - Pick The Sticks

Description

The story happened long long ago. One day, Cao Cao made a special order called "Chicken Rib" to his army. No one got his point and all became very panic. However, Cao Cao himself felt very proud of his interesting idea and enjoyed it.

Xiu Yang, one of the cleverest counselors of Cao Cao, understood the command Rather than keep it to himself, he told the point to the whole army. Cao Cao got very angry at his cleverness and would like to punish Xiu Yang. But how can you punish someone because he‘s clever? By looking at the chicken rib, he finally got a new idea to punish Xiu Yang.

He told Xiu Yang that as his reward of encrypting the special order, he could take as many gold sticks as possible from his desk. But he could only use one stick as the container.

Formally, we can treat the container stick as an L length segment. And the gold sticks as segments too. There were many gold sticks with different length ai and value vi. Xiu Yang needed to put these gold segments onto the container segment. No gold segment was allowed to be overlapped. Luckily, Xiu Yang came up with a good idea. On the two sides of the container, he could make part of the gold sticks outside the container as long as the center of the gravity of each gold stick was still within the container. This could help him get more valuable gold sticks.

As a result, Xiu Yang took too many gold sticks which made Cao Cao much more angry. Cao Cao killed Xiu Yang before he made himself home. So no one knows how many gold sticks Xiu Yang made it in the container.

Can you help solve the mystery by finding out what‘s the maximum value of the gold sticks Xiu Yang could have taken?

Input

The first line of the input gives the number of test cases, T(1≤T≤100). T test cases follow. Each test case start with two integers, N(1≤N≤1000) and L(1≤L≤2000), represents the number of gold sticks and the length of the container stick. N lines follow. Each line consist of two integers, ai(1≤ai≤2000) and vi(1≤vi≤109), represents the length and the value of the ith gold stick.

Output

For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is the maximum value of the gold sticks Xiu Yang could have taken.

Sample Input

4

3 74 12 18 1

3 74 22 18 4

3 54 12 28 9

1 110 3

Sample Output

Case #1: 2Case #2: 6Case #3: 11Case #4: 3

题意:给你一个长度为L的木棍容器,n个长度a[i],价值v[i]的木棍,将木棍放入容器中, 必须满足:木棍的中心在容器范围内     也就是说小木棍可以放在边缘最多伸出一半,问你最大价值是多少。题解:选木棍就是01背包,不过多了一个状态就是:当前是否有伸出去的木棍  只有三种情况: 没有,伸出1个,伸出2个     我们可以设计:dp[L][3]在长度L内 伸出木棍的情况     但注意滚动数组,及转移的后效。

///1085422276
#include<bits/stdc++.h>
using namespace std ;
typedef long long ll;
#define mem(a) memset(a,0,sizeof(a))
#define meminf(a) memset(a,127,sizeof(a))
#define TS printf("111111\n")
#define FOR(i,a,b) for( int i=a;i<=b;i++)
#define FORJ(i,a,b) for(int i=a;i>=b;i--)
#define READ(a,b,c) scanf("%d%d%d",&a,&b,&c)
#define inf 100000
inline ll read()
{
    ll x=0,f=1;
    char ch=getchar();
    while(ch<‘0‘||ch>‘9‘)
    {
        if(ch==‘-‘)f=-1;
        ch=getchar();
    }
    while(ch>=‘0‘&&ch<=‘9‘)
    {
        x=x*10+ch-‘0‘;
        ch=getchar();
    }
    return x*f;
}
//****************************************
#define maxn 2005

int v,a,n,L;
ll dp[4001][3],ans,f[4001][3];
int main(){
  int T=read();
  int oo=1;
  while(T--){
     scanf("%d%d",&n,&L);
     memset(f,-1,sizeof(f));
     memset(dp,-1,sizeof(dp));
     f[0][0]=0;
     dp[0][0]=0;
     L*=2;
     for(int i=1;i<=n;i++){
        scanf("%d%d",&a,&v);a*=2;
        for(int j=0;j<=L;j++){
            f[j][0]=dp[j][0];
            f[j][1]=dp[j][1];
            f[j][2]=dp[j][2];
        }
        for(int j=0;j<=L;j++){
        if(j+a<=L&&f[j][0]!=-1)
          dp[j+a][0]=max(dp[j+a][0],f[j][0]+v);

          if(j+(a/2)<=L&&f[j][0]!=-1)
          dp[j+(a/2)][1]=max(dp[j+(a/2)][1],f[j][0]+v);

         if(j+a<=L&&f[j][1]!=-1)
          dp[j+a][1]=max(dp[j+a][1],f[j][1]+v);

          if(j+a<=L&&f[j][2]!=-1)
          dp[j+a][2]=max(dp[j+a][2],f[j][2]+v);

          if(j+(a/2)<=L&&f[j][1]!=-1)
          dp[j+(a/2)][2]=max(dp[j+(a/2)][2],f[j][1]+v);

          if(a>=L&&f[0][0]!=-1)
            dp[L][2]=max(dp[L][2],f[0][0]+v);
        }
     }
     ans=-1;
    // cout<<dp[12][2]<<endl;
     for(int i=0;i<=L;i++){
        ans=max(ans,dp[i][0]);
          ans=max(ans,dp[i][1]);
            ans=max(ans,dp[i][2]);
     }
     printf("Case #%d: ",oo++);
     cout<<ans<<endl;
  }
 return 0;
}

代码

          
时间: 2024-10-04 02:44:03

2015南阳CCPC D - Pick The Sticks 背包DP.的相关文章

2015南阳CCPC D - Pick The Sticks dp

D - Pick The Sticks Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description The story happened long long ago. One day, Cao Cao made a special order called "Chicken Rib" to his army. No one got his point and all became very panic. However, Cao

2015南阳CCPC C - The Battle of Chibi DP

C - The Battle of Chibi Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description Cao Cao made up a big army and was going to invade the whole South China. Yu Zhou was worried about it. He thought the only way to beat Cao Cao is to have a spy in Cao

2015南阳CCPC L - Huatuo&#39;s Medicine 水题

L - Huatuo's Medicine Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description Huatuo was a famous doctor. He use identical bottles to carry the medicine. There are different types of medicine. Huatuo put medicines into the bottles and chain these b

2015南阳CCPC A - Secrete Master Plan 水题

D. Duff in Beach Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description Master Mind KongMing gave Fei Zhang a secrete master plan stashed in a pocket. The plan instructs how to deploy soldiers on the four corners of the city wall. Unfortunately, w

2015南阳CCPC H - Sudoku 暴力

H - Sudoku Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description Yi Sima was one of the best counselors of Cao Cao. He likes to play a funny game himself. It looks like the modern Sudoku, but smaller. Actually, Yi Sima was playing it different. F

2015南阳CCPC H - Sudoku 数独

H - Sudoku Description Yi Sima was one of the best counselors of Cao Cao. He likes to play a funny game himself. It looks like the modern Sudoku, but smaller. Actually, Yi Sima was playing it different. First of all, he tried to generate a 4×4 board

2015南阳CCPC E - Ba Gua Zhen 高斯消元 xor最大

Ba Gua Zhen Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description During the Three-Kingdom period, there was a general named Xun Lu who belonged to Kingdom Wu. Once his troop were chasing Bei Liu, he was stuck in the Ba Gua Zhen from Liang Zhuge.

2015南阳CCPC F - The Battle of Guandu 多源多汇最短路

The Battle of Guandu Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description In the year of 200, two generals whose names are Cao Cao and Shao Yuan are fighting in Guandu. The battle of Guandu was a great battle and the two armies were fighting at

hdu5543(Pick The Sticks) 01背包

Pick The Sticks Time Limit: 15000/10000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)Total Submission(s): 2540    Accepted Submission(s): 850 Problem Description The story happened long long ago. One day, Cao Cao made a special order