poj2752 Seek the Name, Seek the Fame(next数组的运用)

题目链接:http://poj.org/problem?id=2752

Seek the Name, Seek the Fame

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 12018   Accepted: 5906

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative
little cat works out an easy but fantastic algorithm:

Step1. Connect the father‘s name and the mother‘s name, to a new string S.

Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=‘ala‘, Mother=‘la‘, we have S = ‘ala‘+‘la‘ = ‘alala‘. Potential prefix-suffix strings of S are {‘a‘, ‘ala‘, ‘alala‘}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings
of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby‘s name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

Source

POJ Monthly--2006.01.22,Zeyuan Zhu

题意:寻找前子串与后子串相等的子串。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
#define MAXN 1000017
int next[MAXN];
int ans[MAXN];
int len;
void getnext( char T[])
{
    int i = 0, j = -1;
    next[0] = -1;
    while(i < len)
    {
        if(j == -1 || T[i] == T[j])
        {
            i++,j++;
            next[i] = j;
        }
        else
            j = next[j];
    }
}

int main()
{
    char ss[MAXN];
    int length;
    while(~scanf("%s",ss))
    {
        len = strlen(ss);
        getnext(ss);
		int n = 0 ;int i = len;
		ans[0]=len;
		while(next[i] > 0 )//倒着扫描next数组
		{//递归查找前子串和后子串相等的子串
			i = next[i];
			ans[++n] = i ;
		}
		for( i = n ; i >= 0 ; i--)
			printf("%d ",ans[i]);
		printf("\n");
    }
    return 0;
}

poj2752 Seek the Name, Seek the Fame(next数组的运用),布布扣,bubuko.com

时间: 2024-10-12 22:18:56

poj2752 Seek the Name, Seek the Fame(next数组的运用)的相关文章

poj2752 Seek the Name, Seek the Fame

Seek the Name, Seek the Fame Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 17348   Accepted: 8879 Description The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names t

POJ2752 (Seek the Name, Seek the Fame,kmp)

传送门 Seek the Name, Seek the Fame Time Limit: 2000MS   Memory Limit: 65536K       Description The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They

POJ2752 Seek the Name, Seek the Fame (kmp) 题解

Seek the Name, Seek the Fame Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 17094   Accepted: 8720 Description The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names t

POJ2752 Seek the Name, Seek the Fame 【KMP】

Seek the Name, Seek the Fame Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 11602   Accepted: 5680 Description The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names t

POJ2752——Seek the Name, Seek the Fame

Seek the Name, Seek the Fame Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 12620   Accepted: 6198 Description The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names t

POJ 2752 Seek the Name, Seek the Fame (KMP的next函数运用)

Seek the Name, Seek the Fame Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 14188   Accepted: 7068 Description The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names t

KMP中next的应用 POJ 2752 Seek the Name, Seek the Fame

Seek the Name, Seek the Fame Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 19163   Accepted: 9849 Description The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names t

POJ 2752 Seek the Name, Seek the Fame kmp失配函数next应用

点击打开链接 Seek the Name, Seek the Fame Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 12791   Accepted: 6304 Description The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give

poj_2752 Seek the Name, Seek the Fame

http://poj.org/problem?id=2752 分析: 题目要求一个既是S的前缀又是S的后缀的子串(S本身是自己的前缀又是自己的后缀).主要利用next数组求解.       e.g. no 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 S a b a b c a b a b a b a b c a b a b /0 next -1 0 0 1 2 0 1 2 3 4 3 4 3 4 5 6 7 8 9 Out: 2  4  9  1