hdu 2669

Description

The Sky is Sprite.

The Birds is Fly in the Sky.

The Wind is Wonderful.

Blew Throw the Trees

Trees are Shaking, Leaves are Falling.

Lovers Walk passing, and so are You.

................................Write in English class by yifenfei

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!

Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.

Input

The input contains multiple test cases.

Each case two nonnegative integer a,b (0<a, b<=2^31)

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.

Sample Input

77 51
10 44
34 79 

Sample Output

2 -3
sorry
7 -3 
题意:
前面一大段话都是废话,不要看就好了,题目的意思是给你两个正整数a,b,yaoni 要你求出一个正整数X和一个整数Y使得X*a+Y *b=1;如果这种情况不存在,输出sorry,如果存在,输出最小的X。
思路:
这是一道扩展欧几里得算法题,我看了一下算法竞赛与入门经典中的P313,书上讲了一个类似的题目,还有参考了一个专门讲扩展欧几里得算法的博客,地址http://www.cnblogs.com/yuelingzhi/archive/2011/08/13/2137582.html ,看了看,看出一点名堂了,然后把代码贴上去KO了。
代码:
#include<cstdio>
using namespace std;
int exgcd(int a,int b,int &x,int &y)
{
    if(b==0)
    {
        x=1;
        y=0;
        return a;
    }
    int  r=exgcd(b,a%b,x,y);
    int t=x;
    x=y;
    y=t-a/b*y;
    return r;
}
int main()
{
    int a,b,x,y,m;
    while(scanf("%d%d",&a,&b)!=EOF)
    {

        m=exgcd(a,b,x,y);
        if(m==1)
        {
            while(x<0)
            {
                x+=b;
                y-=a;
            }
            printf("%d %d\n",x,y);
        }

        else
            printf("sorry\n");
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-09 20:10:57

hdu 2669的相关文章

HDU 2669 (扩展欧几里得入门)

练习一下数学知识了.. [题目链接]click here~~ [题目大意]Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead. 求满足式子的x和y否则输出"sorry" [解题思路]扩展欧几里得的基础了, 扩展欧几里德算法是用来在已知a, b求解一组x,y,使它们满足 等式: ax+by = gcd

HDU 2669 Romantic(扩展欧几里德)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2669 Problem Description The Sky is Sprite. The Birds is Fly in the Sky. The Wind is Wonderful. Blew Throw the Trees Trees are Shaking, Leaves are Falling. Lovers Walk passing, and so are You. ..........

HDU 2669 Romantic

Description The Sky is Sprite. The Birds is Fly in the Sky. The Wind is Wonderful. Blew Throw the Trees Trees are Shaking, Leaves are Falling. Lovers Walk passing, and so are You. ................................Write in English class by yifenfei Gir

hdu 2669(扩展欧几里得)

Romantic Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4400    Accepted Submission(s): 1852 Problem Description The Sky is Sprite.The Birds is Fly in the Sky.The Wind is Wonderful.Blew Throw t

hdu 2669 Romantic 解题心得

原题: Description Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem! Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer pr

HDU 2669 Romantic 扩展欧几里得

点击打开链接 Romantic Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2958    Accepted Submission(s): 1160 Problem Description The Sky is Sprite. The Birds is Fly in the Sky. The Wind is Wonderful. B

HDU 2669 第六周 I题

Description The Sky is Sprite.  The Birds is Fly in the Sky.  The Wind is Wonderful.  Blew Throw the Trees  Trees are Shaking, Leaves are Falling.  Lovers Walk passing, and so are You.  ................................Write in English class by yifenf

HDU 2669 Romantic (扩展欧几里得定理)

题目大意:给两个数a和b,找出一组x,y使得a*x + b*y = 1,如果找不出输出sorry   题解:显然是用扩展欧几里得定理求解. 又扩展欧几里得定理有,如果a*x+b*y = d   要使得方程有解必有gcd(a,b)为d的约数. 而此题的d = 1  所以若gcd(a,b)!=1,则应该输出sorry #include <bits/stdc++.h> using namespace std; long long e_gcd(long long a,long long b,long

数论(一)

HDU 2669 ex_GCD HDU 1576 逆元,ex_GCD HDU 4828 卡特兰数 假设,依次放1-n,放第一排记为0,放第二排记为1,题目的条件就转化为卡特兰数的条件了 附:线性求逆元,卡特兰数(递推) p[1] = 1; for (int i = 2; i < 1000003; i++) { p[i] = - (MODP / i) * p[MODP % i]; p[i] = (p[i] % MODP + MODP) % MODP; } f[1] = 1; for (int i