How Many Answers Are Wrong

How Many Answers Are Wrong Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

TT and FF are ... friends. Uh... very very good friends -________-b

FF
is a bad boy, he is always wooing TT to play the following game with
him. This is a very humdrum game. To begin with, TT should write down a
sequence of integers-_-!!(bored).


Then,
FF can choose a continuous subsequence from it(for example the
subsequence from the third to the fifth integer inclusively). After
that, FF will ask TT what the sum of the subsequence he chose is. The
next, TT will answer FF‘s question. Then, FF can redo this process. In
the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn‘t
want to play with FF at all. To punish FF, she often tells FF the wrong
answers on purpose.

The bad boy is not a fool man. FF detects some answers
are incompatible. Of course, these contradictions make it difficult to
calculate the sequence.

However, TT is a nice and lovely girl. She doesn‘t have
the heart to be hard on FF. To save time, she guarantees that the
answers are all right if there is no logical mistakes indeed.

What‘s more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can‘t
make sure whether the current answer is right or wrong in a moment. So
he decides to write a program to help him with this matter. The program
will receive a series of questions from FF together with the answers FF
has received from TT. The aim of this program is to find how many
answers are wrong. Only by ignoring the wrong answers can FF work out
the entire sequence of integers. Poor FF has no time to do this job. And
now he is asking for your help~(Why asking trouble for himself~~Bad
boy)

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <=
40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and
Si. Means TT answered FF that the sum from Ai to Bi is Si. It‘s
guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.

Output

A single line with a integer denotes how many answers are wrong.

Sample Input

10 5

1 10 100

7 10 28

1 3 32

4 6 41

6 6 1

Sample Output

1

首先你要读懂题意,第二行1,10代表1标号到10标号10个数的和是100,以下类似。判断当前话是否与之前的话有矛盾,和食物链类似,r用矢量加减法,箭头指向左端的数,即其根节点。

#include<iostream>
#include<cstdio>

using namespace std;

#define N 200005

int f[N], r[N];  // f数组存储下标根节点,r存储下标到根节点(把一棵树上最左边数置为根节点方便判断,的sum

int found(int x)
{
    int k = f[x];
    if(f[x] != x)
    {
        f[x] = found(f[x]);
        r[x] = r[x]+r[k];  // 根节点在变,r肯定随之改变,就是之前根节点sum,加上根节点到r【f【x】】;
    }
    return f[x];
}

int main()
{
    int n, m, a, b, s;

    while(cin >> n >> m)
    {
        int cou = 0;
        for(int i = 1; i <= n; i++)
            f[i] = i, r[i] = 0;   // 初始化,最开始f是自身,r是0;

        for(int i = 0; i < m; i++)
        {
            cin >> a >> b >> s;

            a--;   // 为什么减一,首先你要读懂题意,当要判断3和5之间sum时,你就要用5到相同根节点的sum-2到同根sum(因为爱情=.=||

            int na = found(a), nb = found(b);

            if(na == nb && (r[a] + s) != r[b])  //  相同根节点时,eg:3,5。就要用2到相同根节点的sum+s(3~5sum,是否等于5~相同根节点sum
                cou++;
            else if(na > nb)
            {
                f[na] = nb;
                r[na] = r[b]-r[a]-s;  // if不在一棵树上(之前没联系,画个三角形箭头指向左边(较小的数,就知道该减还是加了
            }
            else if(na < nb)
            {
                f[nb] = na;
                r[nb] = r[a] - r[b] + s;  // 箭头指向较小的数即根节点。
            }
        }
        cout << cou << endl;
    }
    return 0;
}
时间: 2024-11-03 20:59:17

How Many Answers Are Wrong的相关文章

HDU 3038 - How Many Answers Are Wrong

Problem Description TT and FF are ... friends. Uh... very very good friends -________-b FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of intege

HDU3038 How Many Answers Are Wrong 【并查集】

How Many Answers Are Wrong Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3145 Accepted Submission(s): 1202 Problem Description TT and FF are - friends. Uh- very very good friends -__-b FF is a b

HDU - 3038 How Many Answers Are Wrong (带权并查集)

题意:n个数,m次询问,每次问区间a到b之间的和为s,问有几次冲突 思路:带权并查集的应用,[a, b]和为s,所以a-1与b就可以确定一次关系,通过计算与根的距离可以判断出询问的正确性 #include <iostream> #include <cstdio> #include <cstring> #include <algorithm> using namespace std; const int MAXN = 200010; int f[MAXN],a

HDU 3038 How Many Answers Are Wrong(带权并查集)

传送门 Description TT and FF are ... friends. Uh... very very good friends -________-b FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_

RTNETLINK answers: File exists错误解决方法

>一.写在前面: 因为是我刚学习linux好多问题需要解决,bolg仅作为记录自己的在技术这条道路上的点点滴滴. 二.事件起因: 最近因为女友的原因消沉的好长时间,在马哥那里的课程的结束到现在已经将近45天时间都没有温习,今天拿出来突然老师问我会不会配置lvs,顿时傻眼了.忘记光了,看来这温故而知新的道理不是白来的,然后就出现今天的的事情了. 今天在安装REdhat的时候遇见和网卡有关的问题,起初没有解决系统级别的经验就是最原始的办法,重启虚拟机,不然就是重装.来来回回折腾了好多次都没有成功(没

HDU 3038 How Many Answers Are Wrong(种类并查集)

题目链接 食物链类似的题,主要是在于转化,a-b的和为s,转换为b比a-1大s.然后并查集存 此节点到根的差. 假如x的根为a,y的根为b: b - y = rank[y] a - x = rank[x] y - x = s 可以推出b - a = rank[y] - rank[x] + s; 并查集 延迟更新什么的,都忘了啊. 还有这题,如果是x--的话,记得更新0的根. #include <cstring> #include <cstdio> #include <stri

Linux启动网卡时出现RTNETLINK answers: File exists错误解决方法

这里说一下,如果复制了虚拟机,设置新的MAC地址为什么? 在虚拟机的网络设置中--->高级.然后找到如下窗口,生成新的MAC地址即可. -------------------------------------------------------------------------------- 一.问题描述VMware中克隆虚拟机是经常的事情,虽然如此,用到虚拟机时,本人还是喜欢新安装一个操作系统,针对服务器的应用,在安装操作系统时,一并安装好,并且也花不了多少时间.但最近需要大量的配置一样的

HDU3038 How Many Answers Are Wrong[带权并查集]

How Many Answers Are Wrong Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 6336    Accepted Submission(s): 2391 Problem Description TT and FF are ... friends. Uh... very very good friends -_____

(转载)ASP.NET Quiz Answers: Does Page.Cache leak memory?

原文地址:http://blogs.msdn.com/b/tess/archive/2006/08/11/695268.aspx "We use Page.Cache to store temporary data, but we have recently discovered that it causes high memory consumption. The bad thing is that the memory never goes down even though the cach