HDU1398 Square Coins 【母函数模板】

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7995    Accepted Submission(s): 5416

Problem Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ...,
and 289-credit coins, are available in Silverland.

There are four combinations of coins to pay ten credits:

ten 1-credit coins,

one 4-credit coin and six 1-credit coins,

two 4-credit coins and two 1-credit coins, and

one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

Sample Input

2
10
30
0

Sample Output

1
4
27

直接套模板。

#include <stdio.h>
#define maxn 302

int c1[maxn], c2[maxn];

int main()
{
    int n, i, j, k;
    while(scanf("%d", &n), n){
        for(i = 0; i <= n; ++i){
            c1[i] = 1; c2[i] = 0;
        }
        for(i = 2; i * i <= n; ++i){
            for(j = 0; j <= n; ++j)
                for(k = j; k <= n; k += i * i)
                    c2[k] += c1[j];
            for(k = 0; k <= n; ++k){
                c1[k] = c2[k]; c2[k] = 0;
            }
        }
        printf("%d\n", c1[n]);
    }
    return 0;
}

HDU1398 Square Coins 【母函数模板】

时间: 2024-08-03 07:55:36

HDU1398 Square Coins 【母函数模板】的相关文章

HDU1398 Square Coins

Description People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 28

HDU1398 Square Coins【母函数】

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1398 题目大意: Silverland居住的人们使用方币,这种硬币的价值都是平方数.硬币的价值分别为1分.4分.9分, -,最大为289(17^2)分.要得到10分钱,共有四种硬币组合 10个1分硬币.1个4分硬币和6个1分硬币.2个4分硬币和2个1分硬币,1个9分硬币和1个1分硬币. 现在给你一个数,问:得到这个值,共有多少种不同的硬币组合方式. 思路: 典型的母函数问题. 可列出母函数 g(x

hdu1398 Square Coins(母函数)

题目类似于整数拆分,很明显用母函数来做. 母函数的写法基本固定,根据具体每项乘式的不同做出一些修改就行了.它的思路是从第一个括号开始,一个括号一个括号的乘开,用c1数组保存之前已经乘开的系数,即c1[j]表示在之前已经乘开过的那些括号处理后x的j次方的系数,c2数组是一个临时更新的统计数组,每处理一个括号就更新一遍c1数组即可. #include<iostream> #include<cstdio> #include<cstdlib> #include<cstri

杭电ACM1398——Square Coins~~母函数

这一题,简单的母函数的应用,好久没有写过母函数了,有点生疏了. 题目的硬币有17种,分别是1到17的平方的硬币. 下面的是AC的代码: #include <iostream> #include <cstring> #include <cmath> using namespace std; int dp[305], temp[305]; int main() { int i, j, k, l; for(i = 0; i < 305; i++) //初始化 { dp[

hdu 1398 Square Coins(母函数)

#include <stdio.h> #include <string.h> #include <iostream> #include <algorithm> #include <vector> #include <queue> #include <set> #include <map> #include <string> #include <math.h> #include <s

Square Coins (HDU 1398) ———母函数模板详解

Square Coins Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7748    Accepted Submission(s): 5238 Problem Description People in Silverland use square coins. Not only they have square shapes but

(平方幂母函数)hdu 1398 Square Coins

Square Coins Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8891    Accepted Submission(s): 6067 Problem Description People in Silverland use square coins. Not only they have square shapes but

hdu 1398 Square Coins(母函数|完全背包)

http://acm.hdu.edu.cn/showproblem.php?pid=1398 题意:有价值为1^2,2^2....7^2的硬币共17种,每种硬币都有无限个.问用这些硬币能够组成价值为n的钱数共有几种方案数. 母函数: #include <stdio.h> #include <iostream> #include <map> #include <set> #include <stack> #include <vector>

hdu 1398 Square Coins(母函数,完全背包)

链接:hdu 1398 题意:有17种货币,面额分别为i*i(1<=i<=17),都为无限张, 给定一个值n(n<=300),求用上述货币能使价值总和为n的方案数 分析:这题可以用母函数的思想,对300以内的值进行预处理即可 也可用完全背包思想求300以内的方案数 母函数: #include<stdio.h> int main() { int c1[305],c2[305],i,j,k,n; for(i=0;i<=300;i++){ c1[i]=1; c2[i]=0;