king VS king

king VS king

时间限制:3000 ms  |  内存限制:65535 KB

难度:1

描述

啊,从前有两个国家X和Y。两国都是兵强马壮,国王更是威猛无比。但是两个国王同时看上了一个美貌的女子,由于两个国王都深爱这名女子,都不想放弃,由于两名国王都是仁爱,害怕劳民伤财不想打仗,于是便有了个决定,决定分别派出 n 个人 来进行比赛ACM刷题;

国王们都深知( 田忌赛马这件事),于是出场的顺序都是从弱到强;每胜一场得2分,平一场得1分,输一场得0分;但是国王想要找一个裁判,因为他们都不相信对方国家的人,于是就想让你来当裁判,你一定能做到是吗??

输入
第一行有一个整数T<1<T<20>,代表有T组数据

第二行有一个整数n(1<n<100),紧随着两行,每行有n个数分别代表有X和Y国家的参赛人 员的水平,数据保证都在int 范围内。

输出
如果两国之间的分数相等,则输出 none

输出胜的一方(X或Y或none);

样例输入
334 5 63 2 151 2 3 4 52 7 1 1 241 2 3 4 4 3 2 1
样例输出
XXnone

#include<stdio.h>

#include<stdlib.h>

int a[101],b[101];

int cmp(const void *c,const void *d)

{

return *(int*)c-*(int*)d;

}

int main()

{

int t,n,i;

scanf("%d",&t);

while(t--)

{

int s1=0,s2=0;

scanf("%d",&n);

for(i=0;i<n;i++)

scanf("%d",&a[i]);

for(i=0;i<n;i++)

scanf("%d",&b[i]);

qsort(a,n,sizeof(a[0]),cmp);

qsort(b,n,sizeof(b[0]),cmp);

for(i=0;i<n;i++)

{

if(a[i]>b[i])

s1+=2;

else if(a[i]==b[i])

{

s1++;

s2++;

}

else

s2+=2;

}

if(s1==s2)

printf("none\n");

else if(s1>s2)

printf("X\n");

else

printf("Y\n");

}

return 0;

}

#include<stdio.h>

#include<stdlib.h>

int a[101],b[101];

int cmp(const void *c,const void *d)

{

return *(int*)c-*(int*)d;

}

int main()

{

int t,n,i;

scanf("%d",&t);

while(t--)

{

int s1=0,s2=0;

scanf("%d",&n);

for(i=0;i<n;i++)

scanf("%d",&a[i]);

for(i=0;i<n;i++)

scanf("%d",&b[i]);

qsort(a,n,sizeof(a[0]),cmp);

qsort(b,n,sizeof(b[0]),cmp);

for(i=0;i<n;i++)

{

if(a[i]>b[i])

s1+=2;

else if(a[i]==b[i])

{

s1++;

s2++;

}

else

s2+=2;

}

if(s1==s2)

printf("none\n");

else

printf("%c\n",s1>s2? ‘X‘:‘Y‘);

}

return 0;

}

方法二:运用双目运算符

时间: 2024-10-14 02:30:14

king VS king的相关文章

ACM-田忌赛马(king VS king)

描述 啊,从前有两个国家X和Y.两国都是兵强马壮,国王更是威猛无比.但是两个国王同时看上了一个美貌的女子,由于两个国王都深爱这名女子,都不想放弃,由于两名国王都是仁爱,害怕劳民伤财不想打仗,于是便有了个决定,决定分别派出 n 个人 来进行比赛ACM刷题: 国王们都深知( 田忌赛马这件事),于是出场的顺序都是从弱到强:每胜一场得2分,平一场得1分,输一场得0分:但是国王想要找一个裁判,因为他们都不相信对方国家的人,于是就想让你来当裁判,你一定能做到是吗?? 输入 第一行有一个整数T<1<T<

King.com:如何疯狂赚钱?(转)

$King.com(KING)$ 最近笔者在手机上疯狂玩着一个游戏,名叫Candy Crush Saga(糖果粉碎传奇),一个消除类的休闲游戏.周围的朋友都很奇怪,问我怎么会去玩一个女生才玩的消除游戏?作为一个重度的游戏爱好者,顶着朋友们的 嘲笑,花时间在这样一个玩法简单.色彩艳丽的小游戏,实在是因为该游戏本身有着难以抗拒的魔力,也促使我在今天谈谈这款风靡全球的作品. 2011年中,游戏开发商King.com旗下一个五人团队着手开发一款实验游戏,取名叫Candy Crush Saga(糖果粉碎传

Leetcode-5223 Queens That Can Attack the King(可以攻击国王的皇后)

1 typedef pair<int,int> P; 2 typedef long long ll; 3 #define _for(i,a,b) for(register int i = (a);i < b;i ++) 4 #define _rep(i,a,b) for(register int i = (a);i > b;i --) 5 #define INF 0x3f3f3f3f 6 #define MOD 100000000 7 #define maxn 1003 8 #de

POJ2728 Desert King

Time Limit: 3000MS   Memory Limit: 65536KB   64bit IO Format: %lld & %llu Description David the Great has just become the king of a desert country. To win the respect of his people, he decided to build channels all over his country to bring water to

hdu 5640 King&#39;s Cake(模拟)

Problem Description It is the king's birthday before the military parade . The ministers prepared a rectangle cake of size n×m(1≤n,m≤10000) . The king plans to cut the cake himself. But he has a strange habit of cutting cakes. Each time, he will cut

[SCOI2005]互不侵犯King

1087: [SCOI2005]互不侵犯King Time Limit: 10 Sec  Memory Limit: 162 MB Submit: 4255  Solved: 2458 [Submit][Status][Discuss] Description 在N×N的棋盘里面放K个国王,使他们互不攻击,共有多少种摆放方案.国王能攻击到它上下左右,以及左上 左下右上右下八个方向上附近的各一个格子,共8个格子. Input 只有一行,包含两个数N,K ( 1 <=N <=9, 0 <=

01分数规划+prim POJ2728 Desert King

Desert King Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 26009   Accepted: 7219 Description David the Great has just become the king of a desert country. To win the respect of his people, he decided to build channels all over his coun

POJ3682 King Arthur&#39;s Birthday Celebration

King Arthur is an narcissist who intends to spare no coins to celebrate his coming K-th birthday. The luxurious celebration will start on his birthday and King Arthur decides to let fate tell when to stop it. Every day he will toss a coin which has p

hdu_5314_Happy King(树的点分治)

题目链接:hdu_5314_Happy King 题意: 给出一颗n个结点的树,点上有权值: 求点对(x,y)满足x!=y且x到y的路径上最大值与最小值的差<=D: 题解: 还是树的点分治,在统计答案的时候先按到根的最小值排序,然后用最大值减D去找有多少个满足答案. 1 #include<bits/stdc++.h> 2 #define F(i,a,b) for(int i=a;i<=b;++i) 3 using namespace std; 4 typedef pair<i