Just a Hook
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 36313 Accepted Submission(s):
17713
Problem Description
In the game of DotA, Pudge’s meat hook is actually the
most horrible thing for most of the heroes. The hook is made up of several
consecutive metallic sticks which are of the same length.
Now Pudge wants to
do some operations on the hook.
Let us number the consecutive metallic
sticks of the hook from 1 to N. For each operation, Pudge can change the
consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver
sticks or golden sticks.
The total value of the hook is calculated as the sum
of values of N metallic sticks. More precisely, the value for each kind of stick
is calculated as follows:
For each cupreous stick, the value is 1.
For
each silver stick, the value is 2.
For each golden stick, the value is
3.
Pudge wants to know the total value of the hook after performing the
operations.
You may consider the original hook is made up of cupreous
sticks.
Input
The input consists of several test cases. The first
line of the input is the number of the cases. There are no more than 10
cases.
For each case, the first line contains an integer N,
1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and
the second line contains an integer Q, 0<=Q<=100,000, which is the number
of the operations.
Next Q lines, each line contains three integers X, Y,
1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the
sticks numbered from X to Y into the metal kind Z, where Z=1 represents the
cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden
kind.
Output
For each case, print a number in a line representing
the total value of the hook after the operations. Use the format in the
example.
Sample Input
1
10
2
1 5 2
5 9 3
Sample Output
Case 1: The total value of the hook is 24.
code:
#include <bits/stdc++.h>
using namespace std;
const int maxn=100000+10;
struct node
{
int l,r,sum,lazy;
}t[maxn<<2];
void build (int l,int r,int i)
{
t[i].r=r;
t[i].l=l;
t[i].lazy=0;
if(l==r)
{
t[i].sum=1;
return ;
}
int mid;
mid=(l+r)>>1;
build(l,mid,i<<1);
build(mid+1,r,i<<1|1);
t[i].sum=(t[i<<1].sum+t[i<<1|1].sum);
}
void pushdown (int i)
{
t[i<<1].lazy = t[i].lazy;
t[i<<1|1].lazy= t[i].lazy;
int len=t[i].r-t[i].l+1;
t[i<<1].sum= (len-len/2)*t[i].lazy;
t[i<<1|1].sum=(len/2)*t[i].lazy;
t[i].lazy=0;
}
void update(int l,int r,int i,int z)
{
if(l<=t[i].l && r>=t[i].r)
{
t[i].lazy=z;
t[i].sum=(t[i].r-t[i].l+1)*z;
}
else
{
if(t[i].lazy) pushdown(i);
int mid=(t[i].r+t[i].l)/2;
if(l<=mid)
update(l,r,i<<1,z);
if(r>=mid+1)
update(l,r,i<<1|1,z);
t[i].sum=(t[i<<1].sum+t[i<<1|1].sum);
}
}
int main()
{
int t1,a,b,z,n,Q;
scanf("%d",&t1);
for(int i=1;i<=t1;i++)
{
scanf("%d",&n);
build(1,n,1);
scanf("%d",&Q);
for(int j=0;j<Q;j++)
{
scanf("%d%d%d",&a,&b,&z);
update(a,b,1,z);
//for(int k=1;k<=19;k++)
//if(t[k].l)
//printf("%d %d=%d lazy:%d\n",t[k].l,t[k].r,t[k].sum,t[k].lazy);
}
printf("Case %d: The total value of the hook is %d.\n",i,t[1].sum);
}
return 0;
}
// pushdown 和 update 函数bug:
修改后ac: