hdu 3697 10 福州 现场 H - Selecting courses

Description

A new Semester is coming and students are troubling for selecting courses. Students select their course on the web course system. There are n courses, the ith course is available during the time interval (A i,B i). That means, if you want to select the ith course, you must select it after time Ai and before time Bi. Ai and Bi are all in minutes. A student can only try to select a course every 5 minutes, but he can start trying at any time, and try as many times as he wants. For example, if you start trying to select courses at 5 minutes 21 seconds, then you can make other tries at 10 minutes 21 seconds, 15 minutes 21 seconds,20 minutes 21 seconds… and so on. A student can’t select more than one course at the same time. It may happen that no course is available when a student is making a try to select a course

You are to find the maximum number of courses that a student can select.

Input

There are no more than 100 test cases.

The first line of each test case contains an integer N. N is the number of courses (0<N<=300)

Then N lines follows. Each line contains two integers Ai and Bi (0<=A i<B i<=1000), meaning that the ith course is available during the time interval (Ai,Bi).

The input ends by N = 0.

Output

For each test case output a line containing an integer indicating the maximum number of courses that a student can select.

Sample Input

2
1 10
4 5
0

Sample Output

2

这道题有原题了...记得还是我贪心第一题呢

先优先起点然后优先长度,画个图比一比就能证明

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

const int maxn=550;

struct node
{
	int ai,bi;
} task[maxn];
int nn;
bool mark[maxn];

bool cmp(node A, node B)
{
	if(A.bi==B.bi) return A.ai<B.ai;
	return A.bi<B.bi;
}

int solve(int ss)
{
	int ans=0;
	memset(mark,0,sizeof(mark));
	for(int i=ss;i<=task[nn-1].bi;i+=5){
		for(int j=0;j<nn;j++){
			if(mark[j]) continue;
			if(i>=task[j].ai&&i<task[j].bi){
				ans++;
				mark[j]=1;
				break;
			}
		}
	}
	return ans;
}

int main()
{
	int ans;
	while(scanf("%d",&nn),nn!=0){
		for(int i=0;i<nn;i++) scanf("%d%d",&task[i].ai,&task[i].bi);
		sort(task,task+nn,cmp);
		ans=0;
		for(int i=0;i<5;i++) ans=max(ans,solve(i));
		printf("%d\n",ans);
	}
}

  

时间: 2024-10-13 08:11:25

hdu 3697 10 福州 现场 H - Selecting courses的相关文章

hdu 3695 10 福州 现场 F - Computer Virus on Planet Pandora 暴力 ac自动机

F - Computer Virus on Planet Pandora Time Limit:2000MS     Memory Limit:128000KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 3695 Appoint description:  System Crawler  (2014-11-05) Description Aliens on planet Pandora also write comp

hdu 3687 10 杭州 现场 H - National Day Parade 暴力水题

H - National Day Parade Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 3687 Appoint description:  System Crawler  (2014-11-08) Description There are n×n students preparing for the National Day

hdu 3699 10 福州 现场 J - A hard Aoshu Problem

Description Math Olympiad is called “Aoshu” in China. Aoshu is very popular in elementary schools. Nowadays, Aoshu is getting more and more difficult. Here is a classic Aoshu problem: ABBDE __ ABCCC = BDBDE In the equation above, a letter stands for

hdu 3694 10 福州 现场 E - Fermat Point in Quadrangle

In geometry the Fermat point of a triangle, also called Torricelli point, is a point such that the total distance from the three vertices of the triangle to the point is the minimum. It is so named because this problem is first raised by Fermat in a

hdu 3696 10 福州 现场 G - Farm Game

Description “Farm Game” is one of the most popular games in online community. In the community each player has a virtual farm. The farmer can decide to plant some kinds of crops like wheat or paddy, and buy the corresponding crop seeds. After they gr

hdu 3682 10 杭州 现场 C - To Be an Dream Architect 简单容斥

C - To Be an Dream Architect Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 3682 Appoint description:  System Crawler  (2014-11-09) Description The “dream architect” is the key role in a team o

hdu 3685 10 杭州 现场 F - Rotational Painting 重心

F - Rotational Painting Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 3685 Appoint description:  System Crawler  (2014-11-09) Description Josh Lyman is a gifted painter. One of his great works

HDU 3697 Selecting courses(贪心)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3697 Problem Description A new Semester is coming and students are troubling for selecting courses. Students select their course on the web course system. There are n courses, the ith course is available

hdu 3697 Selecting courses (暴力+贪心)

Selecting courses Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 62768/32768 K (Java/Others) Total Submission(s): 1856    Accepted Submission(s): 469 Problem Description A new Semester is coming and students are troubling for selecting cours