HDU 2317 Nasty Hacks

Nasty Hacks

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2299    Accepted Submission(s): 1816

Problem Description

You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use

to fool their friends. The company has just finished their first product and it is time to sell it. You want to make as much money as possible and consider advertising in order to increase sales. You get an analyst to predict the expected revenue, both with
and without advertising. You now want to make a decision as to whether you should advertise or not, given the expected revenues.

Input

The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do
advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: -106 ≤ r, e ≤ 106 and 0 ≤ c ≤ 106.

Output

Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or not, or whether it does not make any difference.

Sample Input

3
0 100 70
100 130 30
-100 -70 40

Sample Output

advertise
does not matter
do not advertise

Source

Nordic 2006

解题思路:继续水题。直接比较每行的三个数,如果第一个数大于第二个数减去第三个数,则需要做广告;若等于,就无所谓;否则,不做广告。

AC代码:

#include <iostream>
#include <cstdio>
using namespace std;

int main(){
//	freopen("in.txt", "r", stdin);
	int n, a, b, c;
	while(scanf("%d", &n)==1){
		for(int i=0; i<n; i++){
			scanf("%d%d%d", &a, &b, &c);
			if(a < b - c) printf("advertise\n");
			else if(a == b - c)  printf("does not matter\n");
			else  printf("do not advertise\n");
		}
	}
	return 0;
}
时间: 2024-08-14 20:27:13

HDU 2317 Nasty Hacks的相关文章

HDOJ(HDU) 2317 Nasty Hacks(比较、)

Problem Description You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use to fool their friends. The company has just finished their first product and it is time to sell it. You want to

HDOJ 2317. Nasty Hacks 模拟水题

Nasty Hacks Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3049    Accepted Submission(s): 2364 Problem Description You are the CEO of Nasty Hacks Inc., a company that creates small pieces of

POJ 3030. Nasty Hacks 模拟水题

Nasty Hacks Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 13136   Accepted: 9077 Description You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use to fool their friends.

Poj 3030 Nasty Hacks

1.Link: http://poj.org/problem?id=3030 2.Content: Nasty Hacks Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 12350   Accepted: 8537 Description You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious softwa

HDU2317 Nasty Hacks【水题】

Nasty Hacks Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2620    Accepted Submission(s): 2047 Problem Description You are the CEO of Nasty Hacks Inc., a company that creates small pieces of

Nasty Hacks

Nasty Hacks Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other) Total Submission(s) : 30   Accepted Submission(s) : 8 Problem Description You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malici

杭电OJ(HDU)-ACM Steps-Chapter Two-《Biker&#39;s Trip Odometer》《Climbing Worm》《hide handkerchief》《Nasty Hac》

1.2.1 Biker's Trip Odometer #include<stdio.h> #include<math.h> const double PI=acos(-1.0); /* 计算题,根据公式做就行,PI*d*r/(12*5280);res1/t*3600; Sample Input 26 1000 5 27.25 873234 3000 26 0 1000 Sample Output Trip #1: 1.29 928.20 Trip #2: 1179.86 1415

hdu2317Nasty Hacks

Problem Description You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may useto fool their friends. The company has just finished their first product and it is time to sell it. You want to

HOJ 题目分类

转自:http://blog.sina.com.cn/s/blog_65f3869301011a1o.html ******************************************************************************* 简单题(包括枚举,二分查找,(复杂)模拟,基础数据结构(栈.队列),杂题等 ****************************************************************************